dev-python/requests-toolbelt: Port to py39
authorMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 05:44:23 +0000 (07:44 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 27 May 2020 06:10:49 +0000 (08:10 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/requests-toolbelt/requests-toolbelt-0.9.1.ebuild

index f6b8f41d9d89ce59f16e35a4859c3e9d71a50045..56521569fd3bf87b70853e580ef4f9663345f65b 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python{2_7,3_{6,7,8}} pypy3 )
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} pypy3 )
 
 inherit distutils-r1
 
@@ -17,7 +17,6 @@ IUSE="test"
 
 RDEPEND="<dev-python/requests-3.0.0[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
        test? (
                dev-python/betamax[${PYTHON_USEDEP}]
                dev-python/mock[${PYTHON_USEDEP}]