dev-python/pillow: Bump to 6.2.1
authorMichał Górny <mgorny@gentoo.org>
Tue, 22 Oct 2019 05:38:05 +0000 (07:38 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 22 Oct 2019 05:54:24 +0000 (07:54 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pillow/Manifest
dev-python/pillow/pillow-6.2.1.ebuild [new file with mode: 0644]

index 18ccbb01f491add67e05c1f0a4a536e2553864af..a85151615c51d6b1eb3036b6f8815705105dfdd8 100644 (file)
@@ -3,3 +3,4 @@ DIST pillow-5.4.1.tar.gz 15799745 BLAKE2B d9e3851a80a1f94d7292852b9ab806d9a26870
 DIST pillow-6.0.0.tar.gz 29205509 BLAKE2B 83e2d1abeea468b7bf344ea5003940b14d6c69649e02a954c0b3810fc5d77288c361fb40747171176d29843848d802b783a2b0c0de15476462f17f15552298fa SHA512 c5fbe1432d576fe4a70a15fa7a70a446ccbcb247fbd4c3605917fa26a6345eb9319c0153dba7637d521c358963f2f06f525219aa1af1502da2565d54dceef4c5
 DIST pillow-6.1.0.tar.gz 33523149 BLAKE2B 305613aa1f444327c0a70a9e88b51035dc87c17af9d0dd4be47192eeef1b496ba0da3675d9fed5dbaed1bd9a5f2c739370bfd7d1292d7db27230c7ad60b4db14 SHA512 b531644d7214f624369ada12a953c773a0009eaa50217e91aeae30b1ea065c685c7ad331bd9d5e952cb25edfaaf4e8255025004b4c83624ecd2dc06f3501d60a
 DIST pillow-6.2.0.tar.gz 37404132 BLAKE2B 3f86f7fcf4695f152f021fda629df182846e33e7031e1b6bb8f71b0cc1bd7e8039bb94ea8e480afa29324c3015902839cdcaaa359fe58f2bcd8c287a3eb13417 SHA512 9de48d9acdb4367325fb16f970bb533dc369b895615169e0ec77155b400d878e3ebb67f706243ff3e81cc957f9b5360ca8206d4f7fb2d00e9474abb9925bf9d5
+DIST pillow-6.2.1.tar.gz 37405020 BLAKE2B bf3592bcc159902acc35899463c8949daf7cc31f03283684dc55d5f1517fdfbc07e1feb73b65b0b9cb4052ee1d5281558b38f9bd08240d0fc5727909b98da158 SHA512 ee757ec2b8382d6d56fd0f0cdd4cd36440cc37f05741e27fc661449a16dc7c868966772060adb283de1b1b5ebc49b8eec46e0bdcdad9f5f4d5ebd77feab7ad31
diff --git a/dev-python/pillow/pillow-6.2.1.ebuild b/dev-python/pillow/pillow-6.2.1.ebuild
new file mode 100644 (file)
index 0000000..dbe4d52
--- /dev/null
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+REQUIRED_USE="test? ( jpeg tiff )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/olefile[${PYTHON_USEDEP}]
+       imagequant? ( media-gfx/libimagequant:0 )
+       jpeg? ( virtual/jpeg:0 )
+       jpeg2k? ( media-libs/openjpeg:2= )
+       lcms? ( media-libs/lcms:2= )
+       tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+       truetype? ( media-libs/freetype:2= )
+       webp? ( media-libs/libwebp:0= )
+       zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? (
+               dev-python/sphinx[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+       )
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               media-gfx/imagemagick[png]
+       )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+python_configure_all() {
+       # It's important that these flags are also passed during the install phase
+       # as well. Make sure of that if you change the lines below. See bug 661308.
+       mydistutilsargs=(
+               build_ext
+               --disable-platform-guessing
+               $(use_enable truetype freetype)
+               $(use_enable jpeg)
+               $(use_enable jpeg2k jpeg2000)
+               $(use_enable lcms)
+               $(use_enable tiff)
+               $(use_enable imagequant)
+               $(use_enable webp)
+               $(use_enable webp webpmux)
+               $(use_enable zlib)
+       )
+
+       # setup.py sucks at adding the right toolchain paths but it does
+       # accept additional ones from INCLUDE and LIB so set these. You
+       # wouldn't normally need these at all as the toolchain should look
+       # here anyway but this setup.py does stupid things.
+       export \
+               INCLUDE=${ESYSROOT}/usr/include \
+               LIB=${ESYSROOT}/usr/$(get_libdir)
+
+       # We have patched in this env var.
+       tc-export PKG_CONFIG
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+src_test() {
+       virtx distutils-r1_src_test
+}
+
+python_test() {
+       "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+       # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+       pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+       python_doheader src/libImaging/*.h
+       distutils-r1_python_install
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/_build/html/. )
+       if use examples ; then
+               docinto example
+               dodoc docs/example/*
+               docompress -x /usr/share/doc/${PF}/example
+       fi
+       distutils-r1_python_install_all
+}