always strip Windows binaries; no point in having debug info in them
authorAlin Năstac <mrness@gentoo.org>
Sun, 11 Mar 2007 10:22:32 +0000 (10:22 +0000)
committerAlin Năstac <mrness@gentoo.org>
Sun, 11 Mar 2007 10:22:32 +0000 (10:22 +0000)
Package-Manager: portage-2.1.2.2

dev-util/nsis/Manifest
dev-util/nsis/nsis-2.24.ebuild

index 11616669ea30357835be034c6713ea9948788676..dd111189d3c3eb4d8e0e378406887a946b96f152 100644 (file)
@@ -19,10 +19,10 @@ EBUILD nsis-2.23.ebuild 1364 RMD160 398499c1b95b308ec857c12717270af4df8eac2c SHA
 MD5 571faef59ed60699836e06be9259a79b nsis-2.23.ebuild 1364
 RMD160 398499c1b95b308ec857c12717270af4df8eac2c nsis-2.23.ebuild 1364
 SHA256 72bfcea97f9e9c3ab18bb628cc4cc1d6c30b820453840ec1eb2f45a3731348d8 nsis-2.23.ebuild 1364
-EBUILD nsis-2.24.ebuild 1802 RMD160 3611c785cd6797b34502de3887088144ac46ae8c SHA1 0a796e37f560b67b9fe59fdd7706fcdc20e3768d SHA256 12bea1b6237ee4b45e61724fa7cb1e480e3c0a98fc444f2a0fc2e0a09f4f6168
-MD5 1775e3a1deb24651d4ce43af16ec4057 nsis-2.24.ebuild 1802
-RMD160 3611c785cd6797b34502de3887088144ac46ae8c nsis-2.24.ebuild 1802
-SHA256 12bea1b6237ee4b45e61724fa7cb1e480e3c0a98fc444f2a0fc2e0a09f4f6168 nsis-2.24.ebuild 1802
+EBUILD nsis-2.24.ebuild 1790 RMD160 f966d9ae3966902ab622c28fe4413714467c0ead SHA1 b032715ab96862ea4ab1e1a1ec814e35ce48b39e SHA256 3bedb12f78e5e9a720a4b37dc282d7f2444e9f6932318692f76b281cfebb7048
+MD5 6a832d223c5b1c2fe22f532a23863dc2 nsis-2.24.ebuild 1790
+RMD160 f966d9ae3966902ab622c28fe4413714467c0ead nsis-2.24.ebuild 1790
+SHA256 3bedb12f78e5e9a720a4b37dc282d7f2444e9f6932318692f76b281cfebb7048 nsis-2.24.ebuild 1790
 MISC ChangeLog 1231 RMD160 5f53c5a1ae1dd6c7a04b7941c88b2c5d2e7b0a07 SHA1 c38f72b576ac760b779cb566f1304a625aaa0c20 SHA256 41236f750e814af72cede396af72c7a6a877b4603e4e8f15ad2d61adb0db7038
 MD5 db219669cc1e59b6445d6065160397cd ChangeLog 1231
 RMD160 5f53c5a1ae1dd6c7a04b7941c88b2c5d2e7b0a07 ChangeLog 1231
@@ -40,7 +40,7 @@ SHA256 393bef1399210212b1d7b162a9b5084398e527e0a98ff64bbb7bbd773b62a53b files/di
 -----BEGIN PGP SIGNATURE-----
 Version: GnuPG v2.0.3 (GNU/Linux)
 
-iD8DBQFF89MRJnxX6mF440QRAizWAJ9PTO6JyZOM+L99FMFbTKCEhwlmEgCgk46r
-zHS+OtA52edoMnB0vxDsSVk=
-=J3dM
+iD8DBQFF89h1JnxX6mF440QRAs6wAJ9f81aJjNFYeREFntbRwRAnyFYuqgCfUKvx
+6Mzyxat7JEAdibqCZYYhdrE=
+=EK+A
 -----END PGP SIGNATURE-----
index e1cedd9ef14c2959c9abc151e88278b2cea095b8..f2717ecfc083e610b9a184ed539945a1a65aa14f 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.24.ebuild,v 1.1 2007/03/11 09:59:23 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.24.ebuild,v 1.2 2007/03/11 10:22:32 mrness Exp $
 
 inherit eutils
 
@@ -34,31 +34,29 @@ src_unpack() {
 
 src_compile() {
        scons PREFIX=/usr PREFIX_CONF=/etc PREFIX_DOC="/usr/share/doc/${P}" PREFIX_DEST="${D}" \
-               SKIPPLUGINS=System VERSION=${PV} STRIP=no || die "scons failed"
+               SKIPPLUGINS=System VERSION=${PV} DEBUG=no STRIP=no || die "scons failed"
 }
 
 src_install() {
        scons PREFIX=/usr PREFIX_CONF=/etc PREFIX_DOC="/usr/share/doc/${P}" PREFIX_DEST="${D}" \
-               SKIPPLUGINS=System VERSION=${PV} STRIP=no install || die "scons install failed"
+               SKIPPLUGINS=System VERSION=${PV} DEBUG=no STRIP=no install || die "scons install failed"
 
        fperms -R go-w,a-x,a+X /usr/share/${PN}/ /usr/share/doc/${P}/ /etc/nsisconf.nsh
 
-       # Strip Windows binaries
-       if ! hasq nostrip ${FEATURES} ; then
-               local STRIP_FLAGS=${PORTAGE_STRIP_FLAGS:---strip-unneeded}
-               echo
-               echo "strip: mingw32-strip $STRIP_FLAGS"
-
-               cd "${D}"
-               local FILE
-               for FILE in $(find -iregex '.*\.\(dll\|exe\)$' | sed 's:^\./::') ; do
-                       if [[ "${FILE##*\/}" = "NSIS.exe" ]]; then
-                               # This program is distributed binary with nothing strippable in it
-                               # Avoid "File in wrong format" error
-                               continue
-                       fi
-                       echo "   ${FILE}"
-                       mingw32-strip ${STRIP_FLAGS} "${FILE}"
-               done
-       fi
+       # Always strip Windows binaries; no point in having Windows debug info
+       local STRIP_FLAGS="--strip-unneeded"
+       echo
+       echo "strip: mingw32-strip ${STRIP_FLAGS}"
+
+       cd "${D}"
+       local FILE
+       for FILE in $(find -iregex '.*\.\(dll\|exe\)$' | sed 's:^\./::') ; do
+               if [[ "${FILE##*\/}" = "NSIS.exe" ]]; then
+                       # This program is distributed binary with nothing strippable in it
+                       # Avoid "File in wrong format" error
+                       continue
+               fi
+               echo "   ${FILE}"
+               mingw32-strip ${STRIP_FLAGS} "${FILE}"
+       done
 }