dev-python/markdown: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 21:16:08 +0000 (22:16 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 21:16:08 +0000 (22:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/markdown/Manifest
dev-python/markdown/files/markdown-2.6.8-dont-build-docs-default.patch [deleted file]
dev-python/markdown/markdown-2.6.8.ebuild [deleted file]

index e9aa176540a41e653c46beaf7df9d4d159d47e57..3c412b694c7b156fa5bf5efc97c90cfddb76cfe4 100644 (file)
@@ -1,4 +1,3 @@
 DIST Markdown-2.6.11.tar.gz 274132 BLAKE2B 0d14d308c97d925db83d71f3b9be5622e77ee4a159fced15c811390b39950e81bff9ffc567f32e878cbc44014640ab0a2f596258cfd0dce6b66029105cec7370 SHA512 4e7dd3e04f181fa2751a359aede301fb29a23b9af74867ff9d1d0fdd051dcd16d04a5891e37aff0b309649c5fd13363802ec7e10fc33896e9453991efcab4a66
-DIST Markdown-2.6.8.tar.gz 307330 BLAKE2B 6867f15425bd84bc030ab52000dc2f83bff0c9885854cec4a2a785f80b18129160bc57da30226fe17f42043b4938482e2e4eff9cdb3d4370b0146cc09f1ff576 SHA512 85c1a16ebb50af79f378eb2fa936342df6174a4f597a74fee6d0495ef2bc4c7c8337463799e427cb6788b3429e400309958b5c4784f536593047ab2e47ac7c23
 DIST Markdown-3.1.1.tar.gz 294136 BLAKE2B 9fd024f64f7aaa774a49f60e312e47bbc2ff0f368f083e4dfd0c38d1f12839dfcf3455f1d0c8cb0b9c851fe0d3a779c70784859f1682703bd6022d57b6548235 SHA512 78f089f2eef5c73d683ac96fd20c87145e243d12b0f230b9b0228b995035fbb084dde40be788679c63637f05956487ad520cc9dd61d133926bf13521aa600090
 DIST Markdown-3.2.1.tar.gz 297048 BLAKE2B b7f72cb856f0986e0e3920bd7d7eb65790312ef9f270ba3cfa679786b921d1c4ce0a86d591d7d748254c11e9c86d9883130efbc0c2d6a26d94b1fe3d9622aeb9 SHA512 5616c77004e4e8f2eb3b1276526ba131891be6edc7371b412a4050bbd59904220e48986d556bb9bb0b9e8acadfcde7828b609d165f68b6aad7bb90a221f80480
diff --git a/dev-python/markdown/files/markdown-2.6.8-dont-build-docs-default.patch b/dev-python/markdown/files/markdown-2.6.8-dont-build-docs-default.patch
deleted file mode 100644 (file)
index 65b7d21..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
-Don't build docs by default, which causes issues when trying
-to remove .txt files, as they will be readded on installing.
-
---- a/setup.py
-+++ b/setup.py
-@@ -204,7 +204,7 @@
-     def initialize_options(self):
-         build.initialize_options(self)
--        self.no_build_docs = False
-+        self.no_build_docs = True
-     def has_docs(self):
-         return not self.no_build_docs
diff --git a/dev-python/markdown/markdown-2.6.8.ebuild b/dev-python/markdown/markdown-2.6.8.ebuild
deleted file mode 100644 (file)
index ec62f21..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the markdown markup language"
-HOMEPAGE="
-       https://python-markdown.github.io/
-       https://pypi.org/project/Markdown/
-       https://github.com/Python-Markdown/markdown"
-SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
-
-LICENSE="|| ( BSD GPL-2 )"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="doc test pygments"
-RESTRICT="!test? ( test )"
-
-DEPEND="
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/pyyaml[${PYTHON_USEDEP}]
-               dev-python/pygments[${PYTHON_USEDEP}]
-               dev-python/pytidylib[${PYTHON_USEDEP}]
-       )"
-# source cites pytidylib however from testruns it appears optional
-RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${P^}"
-PATCHES=(
-       # build system always builds docs
-       "${FILESDIR}"/${PN}-2.6.8-dont-build-docs-default.patch
-)
-
-python_compile_all() {
-       if use doc; then
-               esetup.py build_docs
-               HTML_DOCS=( "${BUILD_DIR}"/docs/. )
-
-               # remove .txt files
-               find "${BUILD_DIR}"/docs -name '*.txt' -delete || die
-       fi
-}
-
-python_test() {
-       cp -r -l run-tests.py tests "${BUILD_DIR}"/ || die
-       cd "${BUILD_DIR}" || die
-       "${EPYTHON}" run-tests.py || die "Tests fail with ${EPYTHON}"
-}