x11-libs/tslib: 1.21 version bump
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 25 Dec 2019 15:33:04 +0000 (16:33 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 25 Dec 2019 16:01:45 +0000 (17:01 +0100)
Closes: https://bugs.gentoo.org/618654
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
x11-libs/tslib/Manifest
x11-libs/tslib/files/tslib-1.21-optional-utils.patch [new file with mode: 0644]
x11-libs/tslib/metadata.xml
x11-libs/tslib/tslib-1.21.ebuild [new file with mode: 0644]

index f3765623e085b1ef78d260750de04d76a757c769..7d97865c8717c0ca521e584863924a26a05e0d07 100644 (file)
@@ -1,2 +1,3 @@
 DIST tslib-1.0-patches-5.tar.bz2 6602 BLAKE2B 3cd67f4eeacd0651354af8ee4637e27084e9ad61246e6cab631ef52c7435e6d37acdaffd4ca72d8435335860f12d2b0fb4205b33092ea603aafc837e2dba6885 SHA512 dcde900942a3c9e9114e2c36d1d9554eeae8e5ca64463d69c52188a30734b19d6ba0439e8bb009b0d535dfae3f8f8e688a6861ec0a0371fdcb0e9986abb963de
 DIST tslib-1.0.tar.bz2 47522 BLAKE2B 99f43b5175fadef240a973d0e88c80a227b5ffe518c97c6d890fa4194148ff099055b98e7b5b3fee542249bb9c9bae88a22d1d050f2f7ca1563d03b453aac34c SHA512 a12e569b1d9cd809776a605775c3000f4e405789d95eeda21451d3911b5aa67003c921d9988f5ea8eba8b32108c8b0816e6609b5f013a2594d27b6e00e75de8c
+DIST tslib-1.21.tar.xz 349216 BLAKE2B e19623c9390688b0aa85e6547a57542d2e10498c8ebbb30f840157d240dc9975c3e6735814a5e6f02fb71c273a52f860695cf4772fef28522e74c5781cdcb02a SHA512 66c5e5dc4e2314277e19af29b5dce1181573579f13b0e79fa43e658838d4c19a77feb978b60d7c6458337e8d6100ee54a42fc4af3a99fd8d6840cccafa6323c4
diff --git a/x11-libs/tslib/files/tslib-1.21-optional-utils.patch b/x11-libs/tslib/files/tslib-1.21-optional-utils.patch
new file mode 100644 (file)
index 0000000..5b94599
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/CMakeLists.txt   2019-10-22 10:27:05.000000000 +0200
++++ b/CMakeLists.txt   2019-12-25 16:18:52.814921538 +0100
+@@ -17,6 +17,7 @@
+ option(BUILD_SHARED_LIBS "ON:  tslib is build as shared; 
+                         OFF: tslib is build as static" ON)
+ option(ENABLE_TOOLS "build additional tools" ON)
++option(ENABLE_UTILS "build calibration/test binaries" ON)
+ set(LIBTS_VERSION_CURRENT 10)
+ set(LIBTS_VERSION_REVISION 3)
+@@ -28,7 +29,9 @@
+ add_subdirectory(src)
+ add_subdirectory(plugins)
+-add_subdirectory(tests)
++if (ENABLE_UTILS)
++      add_subdirectory(tests)
++endif ()
+ if (ENABLE_TOOLS)
+       add_subdirectory(tools)
+ endif ()
index 7407021b7ce51876037be50df3dd9c0f7300be73..640fc4e4a42a2f3596b7c6adcb5486f7ddced8cb 100644 (file)
@@ -8,4 +8,8 @@
        <upstream>
                <remote-id type="github">kergoth/tslib</remote-id>
        </upstream>
+       <use>
+               <flag name="evdev">Build experimental input module</flag>
+               <flag name="uinput">Provide alternative ts_uinput evdev device</flag>
+       </use>
 </pkgmetadata>
diff --git a/x11-libs/tslib/tslib-1.21.ebuild b/x11-libs/tslib/tslib-1.21.ebuild
new file mode 100644 (file)
index 0000000..ac72cb8
--- /dev/null
@@ -0,0 +1,60 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-multilib
+
+DESCRIPTION="Touchscreen Access Library"
+HOMEPAGE="https://github.com/kergoth/tslib"
+SRC_URI="https://github.com/libts/tslib/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2 uinput? ( GPL-2+ )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="evdev sdl uinput"
+
+BDEPEND="
+       evdev? ( virtual/pkgconfig[${MULTILIB_USEDEP}] )
+"
+DEPEND="
+       evdev? ( dev-libs/libevdev[${MULTILIB_USEDEP}] )
+       sdl? ( media-libs/libsdl2[${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS NEWS README{,.md} )
+
+PATCHES=( "${FILESDIR}/${P}-optional-utils.patch" )
+
+src_configure() {
+       my_configure() {
+               local mycmakeargs=(
+                       -Denable-input-evdev=$(usex evdev)
+                       -DENABLE_TOOLS=$(usex uinput $(multilib_is_native_abi && echo ON || echo OFF) OFF)
+                       -DENABLE_UTILS=$(multilib_is_native_abi && echo ON || echo OFF)
+                       -Denable-arctic2=ON
+                       -Denable-collie=ON
+                       -Denable-corgi=ON
+                       -Denable-cy8mrln-palmpre=ON
+                       -Denable-dejitter=ON
+                       -Denable-dmc=ON
+                       -Denable-dmc_dus3000=ON
+                       -Denable-galax=ON
+                       -Denable-h3600=ON
+                       -Denable-input=ON
+                       -Denable-linear-h2200=ON
+                       -Denable-linear=ON
+                       -Denable-mk712=ON
+                       -Denable-one-wire-ts-input=ON
+                       -Denable-pthres=ON
+                       -Denable-tatung=ON
+                       -Denable-ucb1x00=ON
+                       -Denable-variance=ON
+               )
+               multilib_is_native_abi && mycmakeargs+=( -Dwith-sdl=$(usex sdl) )
+
+               cmake-utils_src_configure
+       }
+       multilib_parallel_foreach_abi my_configure
+}