app-dicts/bookview: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:44 +0000 (14:18 +0200)
committerDavid Seifert <soap@gentoo.org>
Fri, 18 Oct 2019 12:18:44 +0000 (14:18 +0200)
Closes: https://bugs.gentoo.org/697422
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
app-dicts/bookview/bookview-3.2.1.ebuild
app-dicts/bookview/files/bookview-3.2.1-gentoo.diff

index 5093c1a5b93070ae5fa466ec20152a3bb7264fb3..9fdf455264a7b921211eae45d68b257925fd6fea 100644 (file)
@@ -1,9 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 DESCRIPTION="NDTP client written in Tcl/Tk"
 HOMEPAGE="http://www.sra.co.jp/people/m-kasahr/bookview/"
@@ -12,23 +10,16 @@ SRC_URI="ftp://ftp.sra.co.jp/pub/net/ndtp/bookview/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~ppc x86"
-IUSE=""
 
-RDEPEND=">=dev-lang/tk-8.3"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4"
+RDEPEND="dev-lang/tk:0"
+DEPEND="${RDEPEND}"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}/bookview"
-       epatch "${FILESDIR}/${P}-gentoo.diff"
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.diff )
 
 src_install() {
-       make DESTDIR="${D}" install || die
+       default
+       dodoc ChangeLog.0
 
        insinto /etc/X11/app-defaults
        newins "${FILESDIR}/Bookview.ad" Bookview
-
-       dodoc AUTHORS ChangeLog* INSTALL NEWS README
 }
index 3a3064a10594dc8abc990176c4b5bdfc07af107f..0c29aa3d7340d8d18a2160cc656855588428de0a 100644 (file)
@@ -1,5 +1,5 @@
---- bookview.in.ORIG   2004-11-03 18:39:28.000000000 +0900
-+++ bookview.in        2004-11-22 21:22:42.000000000 +0900
+--- a/bookview/bookview.in
++++ b/bookview/bookview.in
 @@ -120,6 +120,11 @@
  # Bitmap size.
  set bitmap_size 16