app-emulation/img: EAPI bump, fix bugs and other minor changes
authorYury Martynov <email@linxon.ru>
Tue, 3 Dec 2019 18:54:44 +0000 (21:54 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Thu, 5 Dec 2019 06:47:24 +0000 (08:47 +0200)
Closes: https://bugs.gentoo.org/699564
Closes: https://bugs.gentoo.org/679282
Package-Manager: Portage-2.3.79, Repoman-2.3.16
Signed-off-by: Yury Martynov <email@linxon.ru>
Closes: https://github.com/gentoo/gentoo/pull/13851
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
app-emulation/img/img-0.5.7-r1.ebuild [new file with mode: 0644]
app-emulation/img/img-0.5.7.ebuild [deleted file]
app-emulation/img/metadata.xml

diff --git a/app-emulation/img/img-0.5.7-r1.ebuild b/app-emulation/img/img-0.5.7-r1.ebuild
new file mode 100644 (file)
index 0000000..4b2367c
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGO_PN="github.com/genuinetools/img"
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
+HOMEPAGE="https://github.com/genuinetools/img"
+SRC_URI="https://github.com/genuinetools/img/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="MIT"
+SLOT="0"
+IUSE="seccomp"
+
+DEPEND="seccomp? ( sys-libs/libseccomp )"
+RDEPEND="${DEPEND}
+       app-emulation/runc"
+
+src_compile() {
+       GOPATH="${S}:$(get_golibdir_gopath)" \
+               GOCACHE="${T}/go-cache" \
+               IMG_DISABLE_EMBEDDED_RUNC=1 \
+               go build -v -work -x -tags "noembed $(usev seccomp)" \
+                       -ldflags="-s -w -X ${EGO_PN}/version.VERSION=${PV}" "${EGO_PN}" || die
+}
+
+src_install() {
+       dobin img
+       dodoc "src/${EGO_PN}"/{README.md,AUTHORS}
+}
diff --git a/app-emulation/img/img-0.5.7.ebuild b/app-emulation/img/img-0.5.7.ebuild
deleted file mode 100644 (file)
index 21373b5..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit golang-build golang-vcs-snapshot
-
-EGO_PN="github.com/genuinetools/img"
-GIT_COMMIT="d14bb92b69804443263d647647b0833013b8df91"
-ARCHIVE_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-
-DESCRIPTION="Standalone daemon-less unprivileged Dockerfile and OCI container image builder"
-HOMEPAGE="https://github.com/genuinetools/img"
-SRC_URI="${ARCHIVE_URI}"
-LICENSE="MIT"
-SLOT="0"
-IUSE="seccomp"
-
-RESTRICT="test"
-
-src_compile() {
-       local TAGS=$(usex seccomp 'seccomp' '')
-       pushd src/${EGO_PN} || die
-       GOPATH="${S}" go build -mod vendor -tags "noembed ${TAGS}" -v -ldflags "-X ${EGO_PN}/version.GITCOMMIT=${GIT_COMMIT} -X ${EGO_PN}/version.VERSION=${PV}" -o "${S}"/bin/img . || die
-       popd || die
-}
-
-src_install() {
-       dobin bin/*
-       dodoc -r src/${EGO_PN}/README.md
-}
index 7213eb804f94ea04f6155dd324f0ad711f538b5f..236a80be46dfcfc94169f30a08ffd765562f1d3b 100644 (file)
@@ -1,7 +1,14 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <!-- maintainer-needed -->
+       <maintainer type="person">
+               <email>email@linxon.ru</email>
+               <name>Yury Martynov</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer>
        <upstream>
                <remote-id type="github">genuinetools/img</remote-id>
        </upstream>