dev-qt/qtwebengine: pax_kernel is dead
authorAndreas Sturmlechner <asturm@gentoo.org>
Sat, 8 Feb 2020 20:23:27 +0000 (21:23 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sat, 8 Feb 2020 21:34:20 +0000 (22:34 +0100)
Closes: https://bugs.gentoo.org/708676
Package-Manager: Portage-2.3.87, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch [deleted file]
dev-qt/qtwebengine/metadata.xml
dev-qt/qtwebengine/qtwebengine-5.12.3.ebuild
dev-qt/qtwebengine/qtwebengine-5.13.2.ebuild
dev-qt/qtwebengine/qtwebengine-5.14.1.ebuild

diff --git a/dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch b/dev-qt/qtwebengine/files/qtwebengine-5.11.2-paxmark-mksnapshot.patch
deleted file mode 100644 (file)
index f7a5c06..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-Bug: https://bugs.gentoo.org/634220
-
---- a/src/3rdparty/chromium/v8/BUILD.gn
-+++ b/src/3rdparty/chromium/v8/BUILD.gn
-@@ -803,6 +803,7 @@
-     deps = [
-       ":mksnapshot($v8_snapshot_toolchain)",
-+      ":run_paxmark",
-     ]
-     script = "tools/run.py"
-@@ -854,6 +855,28 @@
-     }
-   }
- }
-+action("run_paxmark") {
-+  visibility = [ ":*" ]  # Only targets in this file can depend on this.
-+
-+  deps = [
-+    ":mksnapshot($v8_snapshot_toolchain)",
-+  ]
-+
-+  script = "/usr/sbin/pypaxctl"
-+
-+  sources = []
-+
-+  outputs = [
-+     "$target_out_dir/mksnapshot",
-+  ]
-+
-+  args = [
-+    "-sm",
-+    "./" + rebase_path(get_label_info(":mksnapshot($v8_snapshot_toolchain)",
-+                                      "root_out_dir") + "/mksnapshot",
-+                       root_build_dir),
-+  ]
-+}
- action("v8_dump_build_config") {
-   script = "tools/testrunner/utils/dump_build_config.py"
index acca7340ba1a18db5d7695d4fcaed1f4b716164e..180beb2cfc87f43b53213b014aac9f741e4ba506 100644 (file)
@@ -11,7 +11,6 @@
                <flag name="geolocation">Enable physical position determination
                        via <pkg>dev-qt/qtpositioning</pkg></flag>
                <flag name="jumbo-build">Combine source files to speed up build process.</flag>
-               <flag name="pax_kernel">Enable building under a PaX enabled kernel</flag>
                <flag name="system-ffmpeg">Use the system-wide <pkg>media-video/ffmpeg</pkg>
                        instead of bundled.</flag>
                <flag name="system-icu">Use the system-wide <pkg>dev-libs/icu</pkg>
index fbd7648f6f0a79301f38777de6797123836b3e7b..8161d840612d359d619615c4cfab98e894c96059 100644 (file)
@@ -2,8 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
+
 PYTHON_COMPAT=( python2_7 )
-inherit multiprocessing pax-utils python-any-r1 qt5-build
+inherit multiprocessing python-any-r1 qt5-build
 
 DESCRIPTION="Library for rendering dynamic web content in Qt5 C++ and QML applications"
 
@@ -11,8 +12,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
        KEYWORDS="arm x86"
 fi
 
-IUSE="alsa bindist designer geolocation jumbo-build pax_kernel pulseaudio
-       +system-ffmpeg +system-icu widgets"
+IUSE="alsa bindist designer geolocation jumbo-build pulseaudio +system-ffmpeg +system-icu widgets"
 REQUIRED_USE="designer? ( widgets )"
 
 RDEPEND="
@@ -75,7 +75,6 @@ DEPEND="${RDEPEND}
        dev-util/ninja
        dev-util/re2c
        sys-devel/bison
-       pax_kernel? ( sys-apps/elfix )
        !!=sys-devel/binutils-2.31.1-r5
        !!=sys-devel/binutils-2.32-r0
 "
@@ -87,8 +86,6 @@ PATCHES+=(
 )
 
 src_prepare() {
-       use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.11.2-paxmark-mksnapshot.patch" )
-
        if ! use jumbo-build; then
                sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \
                        src/core/config/common.pri || die
@@ -137,6 +134,4 @@ src_install() {
        if [[ ! -f ${D%/}${QT5_LIBDIR}/libQt5WebEngine.so ]]; then
                die "${CATEGORY}/${PF} failed to build anything. Please report to https://bugs.gentoo.org/"
        fi
-
-       pax-mark m "${D%/}${QT5_LIBEXECDIR}"/QtWebEngineProcess
 }
index 3a69fc348802fd7506fc3bee48edba30d5ead8ee..f5c244acbfc526bfeed1245ffbc68ad5444f608b 100644 (file)
@@ -2,8 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
 PYTHON_COMPAT=( python2_7 )
-inherit multiprocessing pax-utils python-any-r1 qt5-build
+inherit multiprocessing python-any-r1 qt5-build
 
 DESCRIPTION="Library for rendering dynamic web content in Qt5 C++ and QML applications"
 
@@ -11,8 +12,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
        KEYWORDS="amd64 arm arm64 ~x86"
 fi
 
-IUSE="alsa bindist designer jumbo-build pax_kernel pulseaudio
-       +system-ffmpeg +system-icu widgets"
+IUSE="alsa bindist designer jumbo-build pulseaudio +system-ffmpeg +system-icu widgets"
 REQUIRED_USE="designer? ( widgets )"
 
 RDEPEND="
@@ -75,14 +75,11 @@ DEPEND="${RDEPEND}
        dev-util/ninja
        dev-util/re2c
        sys-devel/bison
-       pax_kernel? ( sys-apps/elfix )
 "
 
 PATCHES+=( "${FILESDIR}/${PN}-5.12.5-icu-65.patch" )
 
 src_prepare() {
-       use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.11.2-paxmark-mksnapshot.patch" )
-
        if ! use jumbo-build; then
                sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \
                        src/core/config/common.pri || die
@@ -126,6 +123,4 @@ src_install() {
        if [[ ! -f ${D}${QT5_LIBDIR}/libQt5WebEngine.so ]]; then
                die "${CATEGORY}/${PF} failed to build anything. Please report to https://bugs.gentoo.org/"
        fi
-
-       pax-mark m "${D}${QT5_LIBEXECDIR}"/QtWebEngineProcess
 }
index db4d9855990df7b7e4878663f6f759e4d0dbefcf..ce5929f9ca8b376263ba95d21a0c5c57713b1bf8 100644 (file)
@@ -2,8 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
+
 PYTHON_COMPAT=( python2_7 )
-inherit multiprocessing pax-utils python-any-r1 qt5-build
+inherit multiprocessing python-any-r1 qt5-build
 
 DESCRIPTION="Library for rendering dynamic web content in Qt5 C++ and QML applications"
 
@@ -11,8 +12,7 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
        KEYWORDS="~amd64 ~arm ~arm64 ~x86"
 fi
 
-IUSE="alsa bindist designer jumbo-build pax_kernel pulseaudio
-       +system-ffmpeg +system-icu widgets"
+IUSE="alsa bindist designer jumbo-build pulseaudio +system-ffmpeg +system-icu widgets"
 REQUIRED_USE="designer? ( widgets )"
 
 RDEPEND="
@@ -75,12 +75,9 @@ DEPEND="${RDEPEND}
        dev-util/ninja
        dev-util/re2c
        sys-devel/bison
-       pax_kernel? ( sys-apps/elfix )
 "
 
 src_prepare() {
-       use pax_kernel && PATCHES+=( "${FILESDIR}/${PN}-5.11.2-paxmark-mksnapshot.patch" )
-
        if ! use jumbo-build; then
                sed -i -e 's|use_jumbo_build=true|use_jumbo_build=false|' \
                        src/buildtools/config/common.pri || die
@@ -124,6 +121,4 @@ src_install() {
        if [[ ! -f ${D}${QT5_LIBDIR}/libQt5WebEngine.so ]]; then
                die "${CATEGORY}/${PF} failed to build anything. Please report to https://bugs.gentoo.org/"
        fi
-
-       pax-mark m "${D}${QT5_LIBEXECDIR}"/QtWebEngineProcess
 }