media-libs/partio: EAPI-7 bump, bring 9999 up to speed w/ 1.5.4
authorAndreas Sturmlechner <asturm@gentoo.org>
Sun, 9 Jun 2019 21:41:00 +0000 (23:41 +0200)
committerAndreas Sturmlechner <asturm@gentoo.org>
Sun, 9 Jun 2019 21:42:44 +0000 (23:42 +0200)
Improve DESCRIPTION, sort DEPENDs.

Package-Manager: Portage-2.3.67, Repoman-2.3.14
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-libs/partio/partio-1.5.4.ebuild
media-libs/partio/partio-9999.ebuild

index f8604288badc3816e503cc0fc114577aed10a4d3..1b109fd6da7f61698e2dfab9e7c92c56e2f9aa2c 100644 (file)
@@ -1,11 +1,9 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
 PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
 inherit cmake-utils python-single-r1
 
 if [[ ${PV} == *9999 ]]; then
@@ -16,7 +14,7 @@ else
        KEYWORDS="~amd64 ~x86"
 fi
 
-DESCRIPTION="A library for particle IO and manipulation"
+DESCRIPTION="Library for particle IO and manipulation"
 HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
 
 LICENSE="BSD"
@@ -24,16 +22,16 @@ SLOT="0"
 IUSE="doc"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
+BDEPEND="
+       dev-lang/swig
+       doc? ( app-doc/doxygen[latex] )
+"
 RDEPEND="${PYTHON_DEPS}
        media-libs/freeglut
-       sys-libs/zlib:=
+       sys-libs/zlib
        virtual/opengl
 "
-
-DEPEND="${RDEPEND}
-       dev-lang/swig:*
-       doc? ( app-doc/doxygen[latex] )
-"
+DEPEND="${RDEPEND}"
 
 src_configure() {
        local mycmakeargs=(
index 8c68311fbd9b029a11636758ed74824ca24d0164..1b109fd6da7f61698e2dfab9e7c92c56e2f9aa2c 100644 (file)
@@ -1,23 +1,20 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
+EAPI=7
 
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
 PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit cmake-utils vcs-snapshot python-single-r1
+inherit cmake-utils python-single-r1
 
 if [[ ${PV} == *9999 ]]; then
        inherit git-r3
        EGIT_REPO_URI="https://github.com/wdas/partio.git"
 else
-       MY_GIT_COMMIT="2774ef3958da46d9f8a4230ebda9e04b1aa8f4e5"
-       SRC_URI="https://github.com/wdas/${PN}/archive/${MY_GIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+       SRC_URI="https://github.com/wdas/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
        KEYWORDS="~amd64 ~x86"
 fi
 
-DESCRIPTION="A library for particle IO and manipulation"
+DESCRIPTION="Library for particle IO and manipulation"
 HOMEPAGE="https://www.disneyanimation.com/technology/partio.html"
 
 LICENSE="BSD"
@@ -25,24 +22,20 @@ SLOT="0"
 IUSE="doc"
 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 
+BDEPEND="
+       dev-lang/swig
+       doc? ( app-doc/doxygen[latex] )
+"
 RDEPEND="${PYTHON_DEPS}
        media-libs/freeglut
+       sys-libs/zlib
        virtual/opengl
-       sys-libs/zlib:="
-
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen[latex] )
-       dev-lang/swig:*"
-
-src_prepare() {
-       cmake-utils_src_prepare
-       cmake_comment_add_subdirectory "src/tests"
-}
+"
+DEPEND="${RDEPEND}"
 
 src_configure() {
        local mycmakeargs=(
                $(cmake-utils_use_find_package doc Doxygen)
-               -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
        )
        cmake-utils_src_configure
 }