dev-lua/lua-term: version bump to 0.7
authorVictor Payno <vpayno+gentoo@gmail.com>
Tue, 3 Mar 2020 03:10:57 +0000 (19:10 -0800)
committerGeorgy Yakovlev <gyakovlev@gentoo.org>
Mon, 16 Mar 2020 00:17:54 +0000 (17:17 -0700)
Signed-off-by: Victor Payno <vpayno+gentoo@gmail.com>
Closes: https://github.com/gentoo/gentoo/pull/14827
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
dev-lua/lua-term/Manifest
dev-lua/lua-term/lua-term-0.7.ebuild [new file with mode: 0644]

index 51f2606ee339819b3d70945618ede5466015a479..cbd77ab2f28c0dfd1edbc898163ffd124409fbf4 100644 (file)
@@ -1 +1,2 @@
 DIST lua-term-0.3.tar.gz 3752 BLAKE2B 6d42129b60278a4bf756195bae28529a9a22688945ecf6c5648ea490645de363799e4fe5a188069e3739557c3b45ee83e28e315cdd69e987f022f28e3a673cb2 SHA512 e91585994c0337d4dbdc36f51cec9f66fe7319212e82c56752ed724bbbe273e4dc67977bd13e7963545bb075f23f69a448dfc4cc4d6c3c49e96af99cd3eb59e7
+DIST lua-term-0.7.tar.gz 4365 BLAKE2B 8f4080d4cd3b620cb1f261d417744f112d42b776ab3f4cdb0e52d04b6d64fc4a1ddbd634570496c3bc12e6b10efe5af8025d1f124198ebb3946414679a65f7f4 SHA512 2046ba1861ff590c191bb651941c45eb8b6e9a1252b05e78daaeb31837ce1fc7da9ba124aec34dc7842fd304e945754c463ffd75941125ff952e911ba66efa31
diff --git a/dev-lua/lua-term/lua-term-0.7.ebuild b/dev-lua/lua-term/lua-term-0.7.ebuild
new file mode 100644 (file)
index 0000000..e9c4c9e
--- /dev/null
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+# Yes, upstream used different version numbers.
+# The rockspec version number is 0.7, but the version associated with
+# the tarball is 0.07.
+MY_PV=0.07
+
+DESCRIPTION="Terminal functions for Lua"
+HOMEPAGE="https://github.com/hoelzro/lua-term"
+SRC_URI="https://github.com/hoelzro/lua-term/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+       echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+               -o core.so core.c"
+       $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -fPIC -shared \
+               -o core.so core.c || die
+}
+
+src_install() {
+       exeinto "$($(tc-getPKG_CONFIG) --variable INSTALL_CMOD lua)"/term
+       doexe core.so
+       insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
+       doins -r term
+}