media-video/parole: Remove support for non-existent deps
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 11:35:31 +0000 (13:35 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 11:51:01 +0000 (13:51 +0200)
media-video/parole/parole-1.0.0.ebuild
media-video/parole/parole-1.0.1.ebuild
profiles/base/package.use.mask

index 19fa3b98c7387f3851540d9ff9917b290e7d0287..09bfa0b3870f5f62692036d41cb9977a984252f4 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 ~mips x86"
-IUSE="clutter libnotify taglib"
+IUSE="libnotify taglib"
 
 COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
        >=dev-libs/glib-2.32:2=
@@ -24,11 +24,6 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
        >=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
        >=xfce-base/libxfce4util-4.11:0=
        >=xfce-base/xfconf-4.10:0=
-       clutter? (
-               >=media-libs/clutter-1.16.4:1.0=
-               >=media-libs/clutter-gtk-1.4.4:1.0=
-               <x11-libs/gtk+-3.22:3
-       )
        libnotify? ( >=x11-libs/libnotify-0.7:0= )
        taglib? ( >=media-libs/taglib-1.6:0= )"
 RDEPEND="${COMMON_DEPEND}
@@ -43,7 +38,8 @@ DOCS=( AUTHORS ChangeLog README THANKS TODO )
 
 src_configure() {
        local myconf=(
-               $(use_enable clutter)
+               # clutter backend does not work with new GTK+3 versions
+               --disable-clutter
                $(use_enable taglib)
                $(use_enable libnotify notify-plugin)
        )
index 6bc14f9e86904fe1881c15f94561bb0bc78d31ea..e25d25434825b08fa351f1fafd3e13b220bd2a7b 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~mips ~x86"
-IUSE="clutter libnotify taglib"
+IUSE="libnotify taglib"
 
 COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
        >=dev-libs/glib-2.32:2=
@@ -24,11 +24,6 @@ COMMON_DEPEND=">=dev-libs/dbus-glib-0.100:=
        >=xfce-base/libxfce4ui-4.11:0=[gtk3(+)]
        >=xfce-base/libxfce4util-4.11:0=
        >=xfce-base/xfconf-4.10:0=
-       clutter? (
-               >=media-libs/clutter-1.16.4:1.0=
-               >=media-libs/clutter-gtk-1.4.4:1.0=
-               <x11-libs/gtk+-3.22:3
-       )
        libnotify? ( >=x11-libs/libnotify-0.7:0= )
        taglib? ( >=media-libs/taglib-1.6:0= )"
 RDEPEND="${COMMON_DEPEND}
@@ -43,7 +38,8 @@ DOCS=( AUTHORS ChangeLog README THANKS TODO )
 
 src_configure() {
        local myconf=(
-               $(use_enable clutter)
+               # clutter backend does not work with new GTK+3 versions
+               --disable-clutter
                $(use_enable taglib)
                $(use_enable libnotify notify-plugin)
        )
index 71ee01400fd4892875f9b339615e068a4bba3ff2..e2ac9d936519282a470bbed9fb0c8d4aac2cc6ec 100644 (file)
@@ -186,12 +186,6 @@ www-plugins/gnash vaapi
 sys-boot/gnu-efi custom-cflags
 sys-boot/refind custom-cflags
 
-# Michał Górny <mgorny@gentoo.org> (8 Jul 2017)
-# The clutter backend is broken with new GTK+3 versions and upstream
-# haven't been able to fix it so far. Enforcing an old GTK+3 version
-# is not a good solution long-term, so mask the flag entirely.
-media-video/parole clutter
-
 # Michał Górny <mgorny@gentoo.org> (29 Jun 2017)
 # Upstream switched to CMake and no longer provides option to build
 # static and shared libs. The flag is preserved not to break USE