dev-java/tomcat-native: removed old 1.2.21
authorMiroslav Šulc <fordfrog@gentoo.org>
Tue, 11 Feb 2020 23:52:29 +0000 (00:52 +0100)
committerMiroslav Šulc <fordfrog@gentoo.org>
Tue, 11 Feb 2020 23:52:29 +0000 (00:52 +0100)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
dev-java/tomcat-native/Manifest
dev-java/tomcat-native/tomcat-native-1.2.21.ebuild [deleted file]

index 447fb59fc7f723c6f706402489642eabb923730e..c6a2d4c861cc9d5054e1535129f9077592d30133 100644 (file)
@@ -1,2 +1 @@
-DIST tomcat-native-1.2.21-src.tar.gz 418909 BLAKE2B f7559f204941cd8f8383bda7591e167c247062b4f79c507a5a449715a5554194197c4d34197f30622cbcbd81952597ae757623c903f11959dc8b4fa81234e127 SHA512 7f43f815785e5bc3e43f5b2e9ad1c90576a3c1528d57230328b7175bf475eb5f4e1f91b66fae74ad32cd76f044d7705f98a79109f6f84e5af75dc32bc8830b29
 DIST tomcat-native-1.2.23-src.tar.gz 419428 BLAKE2B b8e0584d3e42c33158c4edf0432b029ee924a509b00625af6a34af3d580fec510fa0222367ea8679a20b51cb5a7c55198f5a2d4ec60d0fa9dbec3a0a22a11b52 SHA512 89a0363961d322a87f4e752f4727f54f28ac6e4ad10fa21b6b7390c62b041d4068672d95495d9233c1cad7d6c1dc3c85fbd0186894085b3b94e476876af160ee
diff --git a/dev-java/tomcat-native/tomcat-native-1.2.21.ebuild b/dev-java/tomcat-native/tomcat-native-1.2.21.ebuild
deleted file mode 100644 (file)
index 82f1d3a..0000000
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Allows Tomcat to use certain native resources for better performance"
-HOMEPAGE="https://tomcat.apache.org/"
-SRC_URI="mirror://apache/tomcat/tomcat-connectors/native/${PV}/source/${P}-src.tar.gz"
-
-KEYWORDS="amd64 ~x86"
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-libs/apr:1=
-       dev-libs/openssl:0=
-       >=virtual/jre-1.8"
-
-DEPEND=">=virtual/jdk-1.8
-       test? ( dev-java/ant-junit:0 )"
-
-S=${WORKDIR}/${P}-src
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-
-src_configure() {
-       local myeconfargs=(
-               --with-apr="${EPREFIX}"/usr/bin/apr-1-config
-               --with-ssl="${EPREFIX}"/usr
-       )
-
-       cd native || die
-       econf "${myeconfargs[@]}"
-}
-
-src_compile() {
-       eant jar
-
-       cd native || die
-       default
-}
-
-src_install() {
-       java-pkg_newjar "dist/${P}.jar" "${PN}.jar"
-
-       cd native || die
-       default
-
-       ! use static-libs && find "${D}" -name '*.la' -delete || die
-}
-
-src_test() {
-       java-pkg-2_src_test
-}
-
-pkg_postinst() {
-       elog "For more information, please visit"
-       elog "https://tomcat.apache.org/tomcat-9.0-doc/apr.html"
-}