Version bump. Ebuild by Arfrever. Backported from Progress Overlay.
authorMarkos Chandras <hwoarang@gentoo.org>
Sun, 8 Jan 2012 21:05:38 +0000 (21:05 +0000)
committerMarkos Chandras <hwoarang@gentoo.org>
Sun, 8 Jan 2012 21:05:38 +0000 (21:05 +0000)
Package-Manager: portage-2.2.0_alpha84/cvs/Linux x86_64

dev-python/pygame/ChangeLog
dev-python/pygame/pygame-1.9.2_pre20120101.ebuild [new file with mode: 0644]

index 933c722996528a85373c5cbceeb2122eb1c892cb..fc2ce366c8fdce82f2edd554454c50e5a64acbd2 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for dev-python/pygame
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.82 2011/09/21 22:24:10 floppym Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.83 2012/01/08 21:05:38 hwoarang Exp $
+
+*pygame-1.9.2_pre20120101 (08 Jan 2012)
+
+  08 Jan 2012; Markos Chandras <hwoarang@gentoo.org>
+  +pygame-1.9.2_pre20120101.ebuild:
+  Version bump. Ebuild by Arfrever. Backported from Progress Overlay.
 
   21 Sep 2011; Mike Gilbert <floppym@gentoo.org> pygame-1.9.2_pre3203.ebuild:
   Fix broken automagic dep with portmidi, bug 383927 by sping.
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101.ebuild
new file mode 100644 (file)
index 0000000..e26ad49
--- /dev/null
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101.ebuild,v 1.1 2012/01/08 21:05:38 hwoarang Exp $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython *-pypy-*"
+PYTHON_TESTS_RESTRICTED_ABIS="3.1"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
+
+inherit distutils virtualx
+
+DESCRIPTION="Python bindings for SDL multimedia library"
+HOMEPAGE="http://www.pygame.org/"
+if [[ "${PV}" == *_pre* ]]; then
+       SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
+else
+       SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples X"
+
+DEPEND="dev-python/numpy
+       >=media-libs/libsdl-1.2.5[X?]
+       >=media-libs/sdl-image-1.2.2[png,jpeg]
+       >=media-libs/sdl-mixer-1.2.4
+       >=media-libs/sdl-ttf-2.0.6
+       >=media-libs/smpeg-0.4.4-r1"
+RDEPEND="${DEPEND}"
+
+if [[ "${PV}" != *_pre* ]]; then
+       S="${WORKDIR}/${P}release"
+fi
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="WHATSNEW"
+
+src_configure() {
+       "$(PYTHON -f)" config.py -auto
+
+       if ! use X; then
+               sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
+       fi
+
+       # Disable automagic dependency on PortMidi.
+       sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
+}
+
+src_test() {
+       testing() {
+               PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" run_tests.py
+       }
+       VIRTUALX_COMMAND="python_execute_function" virtualmake testing
+}
+
+src_install() {
+       distutils_src_install
+
+       delete_examples_and_tests() {
+               rm -fr "${ED}$(python_get_sitedir)/pygame/examples"
+               rm -fr "${ED}$(python_get_sitedir)/pygame/tests"
+       }
+       python_execute_function -q delete_examples_and_tests
+
+       if use doc; then
+               dohtml -r docs/*
+       fi
+
+       if use examples; then
+               insinto /usr/share/doc/${PF}/examples
+               doins -r examples/*
+       fi
+}