sys-auth/polkit-qt: Use kde.org
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 13 Nov 2019 19:52:38 +0000 (20:52 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 13 Nov 2019 21:24:16 +0000 (22:24 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-auth/polkit-qt/polkit-qt-0.113.0.ebuild

index 65ed2776fbf3ce75c59c4e05a5ec32189c598784..1d09067472db362ed59af38f517875e235e0f98e 100644 (file)
@@ -3,17 +3,20 @@
 
 EAPI=7
 
-MY_PN="${PN}-1"
-MY_P="${MY_PN}-${PV}"
-inherit cmake-utils
+KDE_ORG_NAME="polkit-qt-1"
+inherit cmake-utils kde.org
 
 DESCRIPTION="Qt wrapper around polkit-1 client libraries"
 HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
-SRC_URI="mirror://kde/stable/${MY_PN}/${MY_P}.tar.xz"
+
+if [[ ${KDE_BUILD_TYPE} = release ]]; then
+       SRC_URI="mirror://kde/stable/${KDE_ORG_NAME}/${KDE_ORG_NAME}-${PV}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+       S="${WORKDIR}/${KDE_ORG_NAME}-${PV}"
+fi
 
 LICENSE="LGPL-2"
 SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
 IUSE="debug"
 
 RDEPEND="
@@ -28,8 +31,6 @@ DEPEND="${RDEPEND}"
 
 DOCS=( AUTHORS README README.porting TODO )
 
-S="${WORKDIR}/${MY_P}"
-
 src_configure() {
        local mycmakeargs=(
                -DBUILD_EXAMPLES=OFF