dev-util/kbuild: live ebuild eapi bump to 6
authorAmy Liffey <amynka@gentoo.org>
Mon, 17 Jul 2017 20:27:10 +0000 (22:27 +0200)
committerAmy Liffey <amynka@gentoo.org>
Mon, 17 Jul 2017 20:28:37 +0000 (22:28 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.1

dev-util/kbuild/kbuild-9999.ebuild

index 32de18e3ea33746eac2305f9a72ce785fd1cbb76..5df4852ffb28e89156444afac72ec75ef02136a8 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=2
+EAPI=6
 
 WANT_AUTOMAKE=1.9
 
@@ -20,14 +20,15 @@ DEPEND="sys-devel/gettext
        virtual/yacc"
 RDEPEND=""
 
-S=${WORKDIR}/${MY_P/-src}
+S="${WORKDIR}/${MY_P/-src}"
 
 src_prepare() {
-               rm -rf "${S}/kBuild/bin"
+               default
+               rm -rf "${S}/kBuild/bin" || die
 
-               cd "${S}/src/kmk"
+               cd "${S}/src/kmk" || die
                eautoreconf
-               cd "${S}/src/sed"
+               cd "${S}/src/sed" || die
                eautoreconf
 }