net-misc/putty: Rename USE=kerberos to USE=gssapi
authorJeroen Roovers <jer@gentoo.org>
Sat, 26 Jan 2019 14:38:41 +0000 (15:38 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sat, 26 Jan 2019 14:39:20 +0000 (15:39 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/putty/metadata.xml
net-misc/putty/putty-0.70.ebuild
net-misc/putty/putty-9999.ebuild

index f8db72350db43e1f3e33fb894da85e415ca67bd8..bff885218f396f49fa6325b0b2efadd47e49aca7 100644 (file)
@@ -1,18 +1,24 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-       <maintainer type="person">
-               <email>jer@gentoo.org</email>
-               <name>Jeroen Roovers</name>
-       </maintainer>
-       <longdescription lang="en">
-               PuTTY is a free implementation of Telnet and SSH for Windows and Unix
-               platforms, along with an xterm terminal emulator. It supports flexible
-               terminal setup, mid-session reconfiguration using Ctrl-rightclick,
-               multiple X11 authentication protocols, and various other interesting
-               things not provided by ssh in an xterm.
-       </longdescription>
-       <use>
-               <flag name="gtk">Build the PuTTY client which requires <pkg>x11-libs/gtk+</pkg>:2. Otherwise only the CLI tools puttygen, plink, pscp and psftp will be built.</flag>
-       </use>
+<maintainer type="person">
+<email>jer@gentoo.org</email>
+<name>Jeroen Roovers</name>
+</maintainer>
+<longdescription lang="en">
+PuTTY is a free implementation of Telnet and SSH for Windows and Unix
+platforms, along with an xterm terminal emulator. It supports flexible terminal
+setup, mid-session reconfiguration using Ctrl-rightclick, multiple X11
+authentication protocols, and various other interesting things not provided by
+ssh in an xterm.
+</longdescription>
+<use>
+<flag name="gssapi">
+Enable support for GSSAPI (<pkg>virtual/krb5</pkg>)
+</flag>
+<flag name="gtk">
+Build the PuTTY client which requires <pkg>x11-libs/gtk+</pkg>:3. If disabled
+only the CLI tools puttygen, plink, pscp and psftp will be built.
+</flag>
+</use>
 </pkgmetadata>
index 1d6f330296b343821d82afe4b7fa51c87287838b..888ed3b7bbbb1e7c39897f6a9d354a0f9fdbbf8d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -10,7 +10,7 @@ LICENSE="MIT"
 
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc +gtk ipv6 kerberos"
+IUSE="doc +gtk ipv6 gssapi"
 SRC_URI="
        https://dev.gentoo.org/~jer/${PN}-icons.tar.bz2
        https://the.earth.li/~sgtatham/${PN}/latest/${P}.tar.gz
@@ -25,7 +25,7 @@ RDEPEND="
                x11-libs/libX11
                x11-libs/pango
        )
-       kerberos? ( virtual/krb5 )
+       gssapi? ( virtual/krb5 )
 "
 DEPEND="
        ${RDEPEND}
@@ -47,7 +47,7 @@ src_prepare() {
 src_configure() {
        cd "${S}"/unix || die
        econf \
-               $(use_with kerberos gssapi) \
+               $(use_with gssapi) \
                $(use_with gtk)
 }
 
index c677a8a6686df1e335c64aa54fd541c533c0d8b6..9d0477fe17e1ecdaacd2bdc5bbbe99885b61960a 100644 (file)
@@ -12,7 +12,7 @@ LICENSE="MIT"
 
 SLOT="0"
 KEYWORDS=""
-IUSE="doc +gtk ipv6 kerberos"
+IUSE="doc +gtk ipv6 gssapi"
 
 RDEPEND="
        !net-misc/pssh
@@ -23,7 +23,7 @@ RDEPEND="
                x11-libs/libX11
                x11-libs/pango
        )
-       kerberos? ( virtual/krb5 )
+       gssapi? ( virtual/krb5 )
 "
 DEPEND="
        ${RDEPEND}
@@ -53,8 +53,8 @@ src_prepare() {
 src_configure() {
        cd "${S}"/unix || die
        econf \
-               $(use_with kerberos gssapi) \
-               $(use_with gtk)
+               $(use_with gssapi) \
+               $(use_with gtk gtk=3)
 }
 
 src_compile() {