x11-misc/xbattbar: Version bump.
authorJeroen Roovers <jer@gentoo.org>
Wed, 16 Sep 2015 04:13:28 +0000 (06:13 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 16 Sep 2015 04:13:28 +0000 (06:13 +0200)
Package-Manager: portage-2.2.20.1

x11-misc/xbattbar/Manifest
x11-misc/xbattbar/files/xbattbar-1.4.8-const.patch [new file with mode: 0644]
x11-misc/xbattbar/xbattbar-1.4.8.ebuild [new file with mode: 0644]

index 8476368b5df3f8cc04ba03b638859fafc4dbc16f..c6c20726d84297325ef4602d62df2f01f77902d0 100644 (file)
@@ -1,3 +1,4 @@
 DIST xbattbar_1.4.3.orig.tar.gz 15722 SHA256 8f4963bac20836538530a738b7b921543e1381ea01f457c26937efba981292d9
 DIST xbattbar_1.4.4.orig.tar.gz 15922 SHA256 2e64855de0cef61f764a7eea81565f7a06fe82492db0b6a09662d6dd93b61448 SHA512 0cd09f4489d9ec551e202fc4791e250c5bf6fdb1801d9025662b79060eb7673c6e43dcf3c352370d42549587dd60879ccad6c6e401f86c7e2a641acbec176aa9 WHIRLPOOL 8eb4b95685ef92c783f9dbe26583cae9189490008630b92d32761548dea603b09cb2c0ed21f463694b7254aea9bd4dc60c835d2207a66812a9d33ef980b72740
 DIST xbattbar_1.4.5.orig.tar.gz 16191 SHA256 01b75b2f902d1315a08ec7ddfdcdafc7686cf88662bbf2be5bfcc892294c4b80 SHA512 cc9719e98dc038e0b5bbe1a13acea5cf6c15495b8a133b25663bd86688635bf6f3fefb360a27fb9f00b2012ba16f58bc6f63bfc8ee7eb227e30ad5c9ee1def56 WHIRLPOOL e39aaff055e7ebb7de2a21af5ea263b64949a2ae5e783d47e8879eb51d46a3aa766b29e913eff79ae2585ac3ddbd53710eb7c164a625c7cfdfdf237bf38de884
+DIST xbattbar_1.4.8.orig.tar.gz 16254 SHA256 d7f5cb83a783c3f3376ddb83b90bec90a70d62ff30b8819cf674bf9341677939 SHA512 1ec535ba997da4aa08b225b61b22eb87d74fc15c522d30f5361e1f56db6fd774f4230a95afdb7f1170144c0939724a80118c7289ea50d027a76649fa20164191 WHIRLPOOL 8cd6d35ee4d75df20babd4127ac7be6ac9ff2086fcc10572bff65af1a9d1635bf9ec2590d2aebec56b2c6aaf99d18368490092dc730325d92e4aa2eee2e88981
diff --git a/x11-misc/xbattbar/files/xbattbar-1.4.8-const.patch b/x11-misc/xbattbar/files/xbattbar-1.4.8-const.patch
new file mode 100644 (file)
index 0000000..818aa38
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/xbattbar-check-apm.c
++++ b/xbattbar-check-apm.c
+@@ -210,7 +210,7 @@
+ #define        APM_STAT_LINE_ON        1
+ typedef struct apm_info {
+-   const char driver_version[10];
++   char driver_version[10];
+    int        apm_version_major;
+    int        apm_version_minor;
+    int        apm_flags;
diff --git a/x11-misc/xbattbar/xbattbar-1.4.8.ebuild b/x11-misc/xbattbar/xbattbar-1.4.8.ebuild
new file mode 100644 (file)
index 0000000..18b2d30
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Advanced Power Management battery status display for X"
+HOMEPAGE="http://packages.qa.debian.org/x/xbattbar.html"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+       dev-lang/perl
+       x11-libs/libX11
+"
+RDEPEND="
+       ${DEPEND}
+       ${PYTHON_DEPS}
+       !ppc? ( >=sys-power/acpi-1.5 )
+" # ppc has APM
+
+src_prepare() {
+       epatch \
+               "${FILESDIR}"/${PN}-1.4.5.patch \
+               "${FILESDIR}"/${PN}-1.4.8-const.patch
+
+       sed -i \
+               -e "s:usr/lib:usr/$(get_libdir):" \
+               xbattbar.c || die
+
+       tc-export PKG_CONFIG
+}
+
+src_compile() {
+       use kernel_linux && append-flags -Dlinux
+       emake \
+               CC=$(tc-getCC) \
+               LIBDIR="$(get_libdir)" \
+               LDFLAGS="${LDFLAGS}"
+       python_fix_shebang ${PN}-check-sys
+}
+
+src_install() {
+       emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+       dodoc README
+}