net-libs/libsoup: bump to 2.60.3
authorMart Raudsepp <leio@gentoo.org>
Tue, 22 Jan 2019 12:17:54 +0000 (14:17 +0200)
committerMart Raudsepp <leio@gentoo.org>
Tue, 22 Jan 2019 12:22:25 +0000 (14:22 +0200)
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
net-libs/libsoup/Manifest
net-libs/libsoup/libsoup-2.60.3.ebuild [new file with mode: 0644]

index a49e9ab353787c695ac385385333aacbbe1c7e79..14a1cf87c2d0ab9a6bd421b7cffe0ba82db3b092 100644 (file)
@@ -1 +1,2 @@
 DIST libsoup-2.58.2.tar.xz 1815256 BLAKE2B 23c6e40f91a2dca13fcabe4fa3af7311874cbe06962c6cdc93d8d8d0a998d29cff9e7ce61190541b6114b4996d758b7c469b0354a6012856667e9541a78177cb SHA512 85af6fac87343bdd22312518402144d33916225f60d6fa158efdd84f7ee7ed1f9895989b3558f711c9aedc93cff35a4114ad79d6d2aa19c54cb326f162a4c7de
+DIST libsoup-2.60.3.tar.xz 1838640 BLAKE2B f398f1ba8c37149b46049b674af35915bab3257730d64683acf4a5ad7178818d6367d8378c0b54b163ce774dbf5077883e2cf2055ef5ccbfff775123b3cfa161 SHA512 56d03702643c8b37ed2ec23a0c7517b7d2d06d4cc01f374a8f1c6a03a95d5413522f430827c8daa30a6338fff11013e303fd12c927ca21c84f0d52a44e3525a8
diff --git a/net-libs/libsoup/libsoup-2.60.3.ebuild b/net-libs/libsoup/libsoup-2.60.3.ebuild
new file mode 100644 (file)
index 0000000..3149752
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5,3_6} )
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 multilib-minimal python-any-r1 vala
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="https://wiki.gnome.org/Projects/libsoup"
+
+LICENSE="LGPL-2+"
+SLOT="2.4"
+
+IUSE="debug gssapi +introspection samba ssl test vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+       >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+       >=dev-libs/libxml2-2.9.1-r4:2[${MULTILIB_USEDEP}]
+       >=dev-db/sqlite-3.8.2:3[${MULTILIB_USEDEP}]
+       >=net-libs/glib-networking-2.38.2[ssl?,${MULTILIB_USEDEP}]
+       gssapi? ( virtual/krb5[${MULTILIB_USEDEP}] )
+       introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+       samba? ( net-fs/samba )
+"
+DEPEND="${RDEPEND}
+       ${PYTHON_DEPS}
+       dev-util/glib-utils
+       >=dev-util/gtk-doc-am-1.20
+       >=dev-util/intltool-0.35
+       sys-devel/gettext
+       >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+       test? ( >=dev-libs/glib-2.40:2[${MULTILIB_USEDEP}] )
+       vala? ( $(vala_depend) )
+"
+#      test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+#              apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+#              apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+#              dev-lang/php[apache2,xmlrpc]
+#              net-misc/curl
+#              net-libs/glib-networking[ssl])"
+
+PATCHES=(
+       # https://bugs.gentoo.org/630516
+       "${FILESDIR}/${PN}-2.58.2-sparc-unaligned.patch"
+)
+
+src_prepare() {
+       if ! use test; then
+               # don't waste time building tests (bug #226271)
+               sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+                       || die "sed failed"
+       fi
+
+       # FIXME: workaround upstream not respecting --without-apache-httpd
+       sed -e '/check: start-httpd/d' \
+               -i tests/Makefile.am tests/Makefile.in || die
+
+       use vala && vala_src_prepare
+       gnome2_src_prepare
+}
+
+src_configure() {
+       # FIXME: we need addpredict to workaround bug #324779 until
+       # root cause (bug #249496) is solved
+       addpredict /usr/share/snmp/mibs/.index
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+       # Disable apache tests until they are usable on Gentoo, bug #326957
+       ECONF_SOURCE=${S} \
+       gnome2_src_configure \
+               --disable-static \
+               --disable-tls-check \
+               --without-gnome \
+               --without-apache-httpd \
+               $(usex debug --enable-debug=yes ' ') \
+               $(multilib_native_use_with gssapi) \
+               $(multilib_native_use_enable introspection) \
+               $(multilib_native_use_enable vala) \
+               $(use_with samba ntlm-auth '${EPREFIX}'/usr/bin/ntlm_auth)
+
+       if multilib_is_native_abi; then
+               # fix gtk-doc
+               ln -s "${S}"/docs/reference/html docs/reference/html || die
+       fi
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}