sys-fs/squashfs-tools: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Tue, 5 May 2020 09:55:32 +0000 (02:55 -0700)
committerMatt Turner <mattst88@gentoo.org>
Tue, 5 May 2020 09:55:53 +0000 (02:55 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
12 files changed:
sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-aligned-data.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-extmatch.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-local-cve-fix.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-musl.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch [deleted file]
sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch [deleted file]
sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild [deleted file]
sys-fs/squashfs-tools/squashfs-tools-4.3_p12.ebuild [deleted file]
sys-fs/squashfs-tools/squashfs-tools-4.3_p7.ebuild [deleted file]
sys-fs/squashfs-tools/squashfs-tools-9999.ebuild

diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-2gb.patch
deleted file mode 100644 (file)
index 467448f..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-From 9c1db6d13a51a2e009f0027ef336ce03624eac0d Mon Sep 17 00:00:00 2001
-From: "Guan, Xin" <guanx.bac@gmail.com>
-Date: Sat, 13 Sep 2014 13:15:26 +0200
-Subject: [PATCH] Fix 2GB-limit of the is_fragment(...) function.
-
-Applies to squashfs-tools 4.3.
-
-Reported-by: Bruno Wolff III <bruno@wolff.to>
-Signed-off-by: Guan, Xin <guanx.bac@gmail.com>
-Signed-off-by: Phillip Lougher <phillip@squashfs.org.uk>
----
- squashfs-tools/mksquashfs.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/squashfs-tools/mksquashfs.c b/squashfs-tools/mksquashfs.c
-index f1fcff1cc284..d221c35865a0 100644
---- a/squashfs-tools/mksquashfs.c
-+++ b/squashfs-tools/mksquashfs.c
-@@ -2029,7 +2029,7 @@ struct file_info *duplicate(long long file_size, long long bytes,
- inline int is_fragment(struct inode_info *inode)
- {
--      int file_size = inode->buf.st_size;
-+      off_t file_size = inode->buf.st_size;
-       /*
-        * If this block is to be compressed differently to the
--- 
-2.8.2
-
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-aligned-data.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-aligned-data.patch
deleted file mode 100644 (file)
index 024129f..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-the mksquashfs code has an all_zeros func that does:
-       long *p = (long *) file_buffer->data;
-
-make sure we force the data field to be aligned so that still works.
-
---- a/squashfs-tools/caches-queues-lists.h
-+++ b/squashfs-tools/caches-queues-lists.h
-@@ -123,6 +123,7 @@ struct file_buffer {
-       char locked;
-       char wait_on_unlock;
-       char noD;
-+      long _pad;
-       char data[0];
- };
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-extmatch.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-extmatch.patch
deleted file mode 100644 (file)
index 7ffc062..0000000
+++ /dev/null
@@ -1,121 +0,0 @@
-From https://github.com/plougher/squashfs-tools/pull/9
-
-From 4280e74de14070869787a9166242f9ce2dafd82e Mon Sep 17 00:00:00 2001
-From: Alexandru Ardelean <aa@ocedo.com>
-Date: Wed, 6 Jan 2016 15:33:43 +0200
-Subject: [PATCH] squashfs-tools: with fnmatch.h compatibility with musl
-
-musl does not define FNM_EXTMATCH
-
-Signed-off-by: Alexandru Ardelean <aa@ocedo.com>
----
- squashfs-tools/action.c         |  2 +-
- squashfs-tools/fnmatch_compat.h | 32 ++++++++++++++++++++++++++++++++
- squashfs-tools/mksquashfs.c     |  2 +-
- squashfs-tools/unsquashfs.c     |  1 +
- squashfs-tools/unsquashfs.h     |  1 -
- 5 files changed, 35 insertions(+), 3 deletions(-)
- create mode 100644 squashfs-tools/fnmatch_compat.h
-
-diff --git a/squashfs-tools/action.c b/squashfs-tools/action.c
-index 35889a4..4b06ccb 100644
---- a/squashfs-tools/action.c
-+++ b/squashfs-tools/action.c
-@@ -31,7 +31,6 @@
- #include <sys/stat.h>
- #include <sys/types.h>
- #include <unistd.h>
--#include <fnmatch.h>
- #include <pwd.h>
- #include <grp.h>
- #include <sys/wait.h>
-@@ -43,6 +42,7 @@
- #include "mksquashfs.h"
- #include "action.h"
- #include "error.h"
-+#include "fnmatch_compat.h"
- /*
-  * code to parse actions
-diff --git a/squashfs-tools/fnmatch_compat.h b/squashfs-tools/fnmatch_compat.h
-new file mode 100644
-index 0000000..7b4afd8
---- /dev/null
-+++ b/squashfs-tools/fnmatch_compat.h
-@@ -0,0 +1,32 @@
-+#ifndef FNMATCH_COMPAT
-+#define FNMATCH_COMPAT
-+/*
-+ * Squashfs
-+ *
-+ * Copyright (c) 2015
-+ * Phillip Lougher <phillip@squashfs.org.uk>
-+ *
-+ * This program is free software; you can redistribute it and/or
-+ * modify it under the terms of the GNU General Public License
-+ * as published by the Free Software Foundation; either version 2,
-+ * or (at your option) any later version.
-+ *
-+ * This program is distributed in the hope that it will be useful,
-+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
-+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-+ * GNU General Public License for more details.
-+ *
-+ * You should have received a copy of the GNU General Public License
-+ * along with this program; if not, write to the Free Software
-+ * Foundation, 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-+ *
-+ * fnmatch_compat.h
-+ */
-+
-+#include <fnmatch.h>
-+
-+#ifndef FNM_EXTMATCH
-+#define FNM_EXTMATCH  0
-+#endif
-+
-+#endif
-diff --git a/squashfs-tools/mksquashfs.c b/squashfs-tools/mksquashfs.c
-index d221c35..4e7cbdd 100644
---- a/squashfs-tools/mksquashfs.c
-+++ b/squashfs-tools/mksquashfs.c
-@@ -46,7 +46,6 @@
- #include <sys/mman.h>
- #include <pthread.h>
- #include <regex.h>
--#include <fnmatch.h>
- #include <sys/wait.h>
- #include <limits.h>
- #include <ctype.h>
-@@ -76,6 +75,7 @@
- #include "read_fs.h"
- #include "restore.h"
- #include "process_fragments.h"
-+#include "fnmatch_compat.h"
- int delete = FALSE;
- int fd;
-diff --git a/squashfs-tools/unsquashfs.c b/squashfs-tools/unsquashfs.c
-index 1323dd6..2428baa 100644
---- a/squashfs-tools/unsquashfs.c
-+++ b/squashfs-tools/unsquashfs.c
-@@ -30,6 +30,7 @@
- #include "xattr.h"
- #include "unsquashfs_info.h"
- #include "stdarg.h"
-+#include "fnmatch_compat.h"
- #include <sys/sysinfo.h>
- #include <sys/types.h>
-diff --git a/squashfs-tools/unsquashfs.h b/squashfs-tools/unsquashfs.h
-index ecd0bb4..0edbd25 100644
---- a/squashfs-tools/unsquashfs.h
-+++ b/squashfs-tools/unsquashfs.h
-@@ -40,7 +40,6 @@
- #include <grp.h>
- #include <time.h>
- #include <regex.h>
--#include <fnmatch.h>
- #include <signal.h>
- #include <pthread.h>
- #include <math.h>
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-local-cve-fix.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-local-cve-fix.patch
deleted file mode 100644 (file)
index dca6ab6..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-taken from Fedora
-
-commit af393379e34c5677f95bbec11645b6c3028195b4
-Author: Bruno Wolff III <bruno@wolff.to>
-Date:   Wed Jun 24 14:27:31 2015 -0500
-
-Update printf formats to match datatypes after CVE patch
-
---- a/squashfs-tools/unsquash-4.c
-+++ b/squashfs-tools/unsquash-4.c
-@@ -35,7 +35,7 @@
-       size_t indexes = SQUASHFS_FRAGMENT_INDEXES(sBlk.s.fragments);
-       long long *fragment_table_index;
--      TRACE("read_fragment_table: %d fragments, reading %d fragment indexes "
-+      TRACE("read_fragment_table: %u fragments, reading %zu fragment indexes "
-               "from 0x%llx\n", sBlk.s.fragments, indexes,
-               sBlk.s.fragment_table_start);
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-mem-overflow.patch
deleted file mode 100644 (file)
index a9b0001..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-taken from Fedora
-
-From 604b607d8ac91eb8afc0b6e3d917d5c073096103 Mon Sep 17 00:00:00 2001
-From: Phillip Lougher <phillip@squashfs.org.uk>
-Date: Wed, 11 Jun 2014 04:51:37 +0100
-Subject: mksquashfs: ensure value does not overflow a signed int in -mem
- option
-
-Signed-off-by: Phillip Lougher <phillip@squashfs.org.uk>
-
-diff --git a/squashfs-tools/mksquashfs.c b/squashfs-tools/mksquashfs.c
-index 5370ecf..9676dc8 100644
---- a/squashfs-tools/mksquashfs.c
-+++ b/squashfs-tools/mksquashfs.c
-@@ -5193,7 +5193,16 @@ print_compressor_options:
-                                        argv[0]);
-                               exit(1);
-                       }
--                      /* convert from bytes to Mbytes */
-+
-+                      /*
-+                       * convert from bytes to Mbytes, ensuring the value
-+                       * does not overflow a signed int
-+                       */
-+                      if(number >= (1LL << 51)) {
-+                              ERROR("%s: -mem invalid mem size\n", argv[0]);
-+                              exit(1);
-+                      }
-+
-                       total_mem = number / 1048576;
-                       if(total_mem < (SQUASHFS_LOWMEM / SQUASHFS_TAKE)) {
-                               ERROR("%s: -mem should be %d Mbytes or "
--- 
-cgit v0.10.1
-
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-musl.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-musl.patch
deleted file mode 100644 (file)
index 52b7f48..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-From https://github.com/plougher/squashfs-tools/pull/9
-
-From b0ca8a5c98ff73e70b2ab1bc24aa824aa2458287 Mon Sep 17 00:00:00 2001
-From: Alexandru Ardelean <aa@ocedo.com>
-Date: Wed, 6 Jan 2016 15:36:48 +0200
-Subject: [PATCH] pseudo.c: add explicit <sys/stat.h> include
-
-Signed-off-by: Alexandru Ardelean <aa@ocedo.com>
----
- squashfs-tools/pseudo.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/squashfs-tools/pseudo.c b/squashfs-tools/pseudo.c
-index f85fe60..83bfc97 100644
---- a/squashfs-tools/pseudo.c
-+++ b/squashfs-tools/pseudo.c
-@@ -32,6 +32,7 @@
- #include <stdlib.h>
- #include <sys/types.h>
- #include <sys/wait.h>
-+#include <sys/stat.h>
- #include <ctype.h>
- #include "pseudo.h"
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-sysmacros.patch
deleted file mode 100644 (file)
index 1430b1a..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-sys/types.h might not always include sys/sysmacros.h for major/minor/makedev
-
---- a/squashfs-tools/mksquashfs.c
-+++ b/squashfs-tools/mksquashfs.c
-@@ -59,6 +59,7 @@
- #else
- #include <endian.h>
- #include <sys/sysinfo.h>
-+#include <sys/sysmacros.h>
- #endif
- #include "squashfs_fs.h"
---- a/squashfs-tools/unsquashfs.c
-+++ b/squashfs-tools/unsquashfs.c
-@@ -38,6 +38,10 @@
- #include <limits.h>
- #include <ctype.h>
-+#ifdef linux
-+#include <sys/sysmacros.h>
-+#endif
-+
- struct cache *fragment_cache, *data_cache;
- struct queue *to_reader, *to_inflate, *to_writer, *from_writer;
- pthread_t *thread, *inflator_thread;
diff --git a/sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch b/sys-fs/squashfs-tools/files/squashfs-tools-4.3-xattrs.patch
deleted file mode 100644 (file)
index 47b0ea5..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-From ffe9e55c4993422ce36213fa86d4fc29c22646ea Mon Sep 17 00:00:00 2001
-From: Wessel Dankers <wsl-debian-804194@fruit.je>
-Date: Fri, 17 Jun 2016 09:46:42 +0800
-Subject: [PATCH] unsquashfs: Correctly set file capabilities
-
-As posted on https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=804194.
----
- squashfs-tools/unsquashfs.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/squashfs-tools/unsquashfs.c b/squashfs-tools/unsquashfs.c
-index 1323dd6..a5f0117 100644
---- a/squashfs-tools/unsquashfs.c
-+++ b/squashfs-tools/unsquashfs.c
-@@ -821,8 +821,6 @@ int set_attributes(char *pathname, int mode, uid_t uid, gid_t guid, time_t time,
- {
-       struct utimbuf times = { time, time };
--      write_xattr(pathname, xattr);
--
-       if(utime(pathname, &times) == -1) {
-               ERROR("set_attributes: failed to set time on %s, because %s\n",
-                       pathname, strerror(errno));
-@@ -845,6 +843,8 @@ int set_attributes(char *pathname, int mode, uid_t uid, gid_t guid, time_t time,
-               return FALSE;
-       }
-+      write_xattr(pathname, xattr);
-+
-       return TRUE;
- }
--- 
-2.8.0.rc3.226.g39d4020
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3-r2.ebuild
deleted file mode 100644 (file)
index 815ea61..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DEB_VER="3"
-
-DESCRIPTION="Tool for creating compressed filesystem type squashfs"
-HOMEPAGE="http://squashfs.sourceforge.net"
-SRC_URI="mirror://sourceforge/squashfs/squashfs${PV}.tar.gz
-       mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_VER}.debian.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="debug lz4 lzma lzo static xattr +xz"
-
-LIB_DEPEND="sys-libs/zlib[static-libs(+)]
-       !xz? ( !lzo? ( sys-libs/zlib[static-libs(+)] ) )
-       lz4? ( app-arch/lz4[static-libs(+)] )
-       lzma? ( app-arch/xz-utils[static-libs(+)] )
-       lzo? ( dev-libs/lzo[static-libs(+)] )
-       xattr? ( sys-apps/attr[static-libs(+)] )
-       xz? ( app-arch/xz-utils[static-libs(+)] )"
-RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
-DEPEND="${RDEPEND}
-       static? ( ${LIB_DEPEND} )"
-
-S="${WORKDIR}/squashfs${PV}/${PN}"
-
-src_prepare() {
-       epatch "${WORKDIR}"/debian/patches/*.patch
-       epatch "${FILESDIR}"/${P}-sysmacros.patch
-       epatch "${FILESDIR}"/${P}-aligned-data.patch
-       epatch "${FILESDIR}"/${P}-2gb.patch
-       epatch "${FILESDIR}"/${P}-local-cve-fix.patch
-       epatch "${FILESDIR}"/${P}-mem-overflow.patch
-       epatch "${FILESDIR}"/${P}-xattrs.patch
-       epatch "${FILESDIR}"/${P}-extmatch.patch
-       epatch "${FILESDIR}"/${P}-musl.patch
-}
-
-use10() { usex $1 1 0 ; }
-
-src_configure() {
-       # restore GNU89 inline semantics to
-       # emit function symbols, bug 595290
-       append-cflags -std=gnu89
-
-       # set up make command line variables in EMAKE_SQUASHFS_CONF
-       EMAKE_SQUASHFS_CONF=(
-               LZMA_XZ_SUPPORT=$(use10 lzma)
-               LZO_SUPPORT=$(use10 lzo)
-               LZ4_SUPPORT=$(use10 lz4)
-               XATTR_SUPPORT=$(use10 xattr)
-               XZ_SUPPORT=$(use10 xz)
-       )
-
-       tc-export CC
-       use debug && append-cppflags -DSQUASHFS_TRACE
-       use static && append-ldflags -static
-}
-
-src_compile() {
-       emake "${EMAKE_SQUASHFS_CONF[@]}"
-}
-
-src_install() {
-       dobin mksquashfs unsquashfs
-       cd ..
-       dodoc CHANGES PERFORMANCE.README pseudo-file.example README* OLD-READMEs/*
-       doman "${WORKDIR}"/debian/manpages/*.[0-9]
-}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3_p12.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3_p12.ebuild
deleted file mode 100644 (file)
index a27640c..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="tools to create and extract Squashfs filesystems"
-HOMEPAGE="http://squashfs.sourceforge.net"
-SRC_URI="
-       mirror://sourceforge/squashfs/squashfs${PV/_p*}.tar.gz
-       mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="debug lz4 lzma lzo static xattr +xz zstd"
-
-LIB_DEPEND="
-       sys-libs/zlib[static-libs(+)]
-       !xz? ( !lzo? ( sys-libs/zlib[static-libs(+)] ) )
-       lz4? ( app-arch/lz4[static-libs(+)] )
-       lzma? ( app-arch/xz-utils[static-libs(+)] )
-       lzo? ( dev-libs/lzo[static-libs(+)] )
-       xattr? ( sys-apps/attr[static-libs(+)] )
-       xz? ( app-arch/xz-utils[static-libs(+)] )
-       zstd? ( app-arch/zstd[static-libs(+)] )
-"
-RDEPEND="
-       !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
-"
-DEPEND="
-       ${RDEPEND}
-       static? ( ${LIB_DEPEND} )
-"
-PATCHES=(
-       "${FILESDIR}"/${P/_p*}-sysmacros.patch
-       "${FILESDIR}"/${P/_p*}-aligned-data.patch
-       "${FILESDIR}"/${P/_p*}-local-cve-fix.patch
-       "${FILESDIR}"/${P/_p*}-mem-overflow.patch
-       "${FILESDIR}"/${P/_p*}-extmatch.patch
-       "${FILESDIR}"/${P/_p*}-musl.patch
-)
-
-S="${WORKDIR}/squashfs${PV/_p*}/${PN}"
-
-src_prepare() {
-       eapply -p2 "${WORKDIR}"/debian/patches/*.patch
-       eapply -p2 ${PATCHES[@]}
-       eapply_user
-}
-
-use10() { usex $1 1 0 ; }
-
-src_configure() {
-       # restore GNU89 inline semantics to
-       # emit function symbols, bug 595290
-       append-cflags -std=gnu89
-
-       # set up make command line variables in EMAKE_SQUASHFS_CONF
-       EMAKE_SQUASHFS_CONF=(
-               LZMA_XZ_SUPPORT=$(use10 lzma)
-               LZO_SUPPORT=$(use10 lzo)
-               LZ4_SUPPORT=$(use10 lz4)
-               XATTR_SUPPORT=$(use10 xattr)
-               XZ_SUPPORT=$(use10 xz)
-               ZSTD_SUPPORT=$(use10 zstd)
-       )
-
-       tc-export CC
-       use debug && append-cppflags -DSQUASHFS_TRACE
-       use static && append-ldflags -static
-}
-
-src_compile() {
-       emake "${EMAKE_SQUASHFS_CONF[@]}"
-}
-
-src_install() {
-       dobin mksquashfs unsquashfs
-       cd ..
-       dodoc CHANGES PERFORMANCE.README pseudo-file.example README* OLD-READMEs/*
-       doman "${WORKDIR}"/debian/manpages/*.[0-9]
-}
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.3_p7.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.3_p7.ebuild
deleted file mode 100644 (file)
index fb773fd..0000000
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="tools to create and extract Squashfs filesystems"
-HOMEPAGE="http://squashfs.sourceforge.net"
-SRC_URI="
-       mirror://sourceforge/squashfs/squashfs${PV/_p*}.tar.gz
-       mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
-"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-IUSE="debug lz4 lzma lzo static xattr +xz"
-
-LIB_DEPEND="
-       sys-libs/zlib[static-libs(+)]
-       !xz? ( !lzo? ( sys-libs/zlib[static-libs(+)] ) )
-       lz4? ( app-arch/lz4[static-libs(+)] )
-       lzma? ( app-arch/xz-utils[static-libs(+)] )
-       lzo? ( dev-libs/lzo[static-libs(+)] )
-       xattr? ( sys-apps/attr[static-libs(+)] )
-       xz? ( app-arch/xz-utils[static-libs(+)] )
-"
-RDEPEND="
-       !static? ( ${LIB_DEPEND//\[static-libs(+)]} )
-"
-DEPEND="
-       ${RDEPEND}
-       static? ( ${LIB_DEPEND} )
-"
-PATCHES=(
-       "${FILESDIR}"/${P/_p*}-sysmacros.patch
-       "${FILESDIR}"/${P/_p*}-aligned-data.patch
-       "${FILESDIR}"/${P/_p*}-local-cve-fix.patch
-       "${FILESDIR}"/${P/_p*}-mem-overflow.patch
-       "${FILESDIR}"/${P/_p*}-extmatch.patch
-       "${FILESDIR}"/${P/_p*}-musl.patch
-)
-
-S="${WORKDIR}/squashfs${PV/_p*}/${PN}"
-
-src_prepare() {
-       eapply -p2 "${WORKDIR}"/debian/patches/*.patch
-       eapply -p2 ${PATCHES[@]}
-       eapply_user
-}
-
-use10() { usex $1 1 0 ; }
-
-src_configure() {
-       # restore GNU89 inline semantics to
-       # emit function symbols, bug 595290
-       append-cflags -std=gnu89
-
-       # set up make command line variables in EMAKE_SQUASHFS_CONF
-       EMAKE_SQUASHFS_CONF=(
-               LZMA_XZ_SUPPORT=$(use10 lzma)
-               LZO_SUPPORT=$(use10 lzo)
-               LZ4_SUPPORT=$(use10 lz4)
-               XATTR_SUPPORT=$(use10 xattr)
-               XZ_SUPPORT=$(use10 xz)
-       )
-
-       tc-export CC
-       use debug && append-cppflags -DSQUASHFS_TRACE
-       use static && append-ldflags -static
-}
-
-src_compile() {
-       emake "${EMAKE_SQUASHFS_CONF[@]}"
-}
-
-src_install() {
-       dobin mksquashfs unsquashfs
-       cd ..
-       dodoc CHANGES PERFORMANCE.README pseudo-file.example README* OLD-READMEs/*
-       doman "${WORKDIR}"/debian/manpages/*.[0-9]
-}
index 1234cc3f4c5254e6cfa4ab917a8bb496416cc453..cb91a13dd1ef19014eed62570876587ae97afbae 100644 (file)
@@ -32,10 +32,6 @@ DEPEND="
        ${RDEPEND}
        static? ( ${LIB_DEPEND} )
 "
-PATCHES=(
-       "${FILESDIR}"/${PN}-4.3-sysmacros.patch
-)
-
 use10() { usex $1 1 0 ; }
 
 src_configure() {