Drop trailing whitespaces
authorJustin Lecher <jlec@gentoo.org>
Sun, 19 Mar 2017 10:20:26 +0000 (10:20 +0000)
committerJustin Lecher <jlec@gentoo.org>
Sun, 19 Mar 2017 10:25:23 +0000 (10:25 +0000)
Signed-off-by: Justin Lecher <jlec@gentoo.org>
15 files changed:
eclass/freebsd.eclass
eclass/gnome2-utils.eclass
eclass/gnome2.eclass
eclass/gst-plugins10.eclass
eclass/kernel-2.eclass
eclass/linux-mod.eclass
eclass/mate-desktop.org.eclass
eclass/mercurial.eclass
eclass/mozconfig-v6.51.eclass
eclass/netsurf.eclass
eclass/oasis.eclass
eclass/perl-functions.eclass
eclass/perl-module.eclass
eclass/python-utils-r1.eclass
eclass/ros-catkin.eclass

index 4c961c0bf2b6271e463c9b6e5121e70b82f57d3c..24bab67ce6207e8926bba0051dbd70c6662216f9 100644 (file)
@@ -41,7 +41,7 @@ RV="$(get_version_component_range 1-2 ${MY_PV})"
 #      9.1.9999   -->  releng/9.1
 #   9.9999     -->     stable/9
 #      9999 -->        head
-# 
+#
 # svn revision can be specified by patch level:
 #      freebsd-lib-9.9999_p247000 --> set svn -r 247000
 
@@ -263,7 +263,7 @@ freebsd_src_compile() {
 }
 
 # Helper function to make a multilib build with FreeBSD Makefiles.
-# Usage: 
+# Usage:
 # MULTIBUILD_VARIANTS=( $(get_all_abis) )
 # multibuild_foreach_variant freebsd_multilib_multibuild_wrapper my_function
 #
@@ -296,9 +296,9 @@ freebsd_multilib_multibuild_wrapper() {
        if [ ! -d "${MAKEOBJDIRPREFIX}" ] ; then
                mkdir "${MAKEOBJDIRPREFIX}" || die "Could not create ${MAKEOBJDIRPREFIX}."
        fi
-       
+
        CTARGET="${CHOST}" "$@"
-       
+
        # Restore the variables now.
        for i in CFLAGS CXXFLAGS LDFLAGS LDADD mymakeopts ; do
                ii="${i}_SAVE"
index dea6e562ac761fe2e767bf40d388aabab87a9949..f2aa2391a53229b0edc4433db1f336e38b858134 100644 (file)
@@ -99,12 +99,12 @@ gnome2_environment_reset() {
        export GST_REGISTRY="${T}/registry.xml"
 
        # Ensure we don't rely on dconf/gconf while building, bug #511946
-       export GSETTINGS_BACKEND="memory" 
+       export GSETTINGS_BACKEND="memory"
 
        if has ${EAPI:-0} 6; then
                # Try to cover the packages honoring this variable, bug #508124
                export GST_INSPECT="$(type -P true)"
-               
+
                # Stop relying on random DISPLAY variable values, bug #534312
                unset DISPLAY
        fi
index 7e5feee4ce767805a2b4558c2b140ce8a0e61d3b..8a83297b09598baaae6bc659f0004acc0f1fe4f7 100644 (file)
@@ -53,11 +53,11 @@ fi
 
 # @ECLASS-VARIABLE: GCONF_DEBUG
 # @DEFAULT_UNSET
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Whether to handle debug or not.
 # Some gnome applications support various levels of debugging (yes, no, minimum,
-# etc), but using --disable-debug also removes g_assert which makes debugging   
-# harder. This variable should be set to yes for such packages for the eclass   
+# etc), but using --disable-debug also removes g_assert which makes debugging
+# harder. This variable should be set to yes for such packages for the eclass
 # to handle it properly. It will enable minimal debug with USE=-debug.
 # Note that this is most commonly found in configure.ac as GNOME_DEBUG_CHECK.
 #
@@ -68,7 +68,7 @@ if has ${EAPI:-0} 4 5; then
                IUSE="debug"
        fi
 fi
-    
+
 # @ECLASS-VARIABLE: GNOME2_ECLASS_GIO_MODULES
 # @INTERNAL
 # @DESCRIPTION:
index 12ae3922c2e8088da36186cdf1364efc039a8f87..4e660ad92bd0f3dd4a3fa1d7335721d65ad2e2bf 100644 (file)
@@ -262,7 +262,7 @@ gst-plugins10_src_configure() {
 # Compiles requested gstreamer plugin.
 gst-plugins10_src_compile() {
        local plugin_dir
-       
+
        has ${EAPI:-0} 0 1 && gst-plugins10_src_configure "$@"
 
        for plugin_dir in ${GST_PLUGINS_BUILD_DIR} ; do
@@ -281,7 +281,7 @@ gst-plugins10_src_compile() {
 # Installs requested gstreamer plugin.
 gst-plugins10_src_install() {
        local plugin_dir
-       
+
        for plugin_dir in ${GST_PLUGINS_BUILD_DIR} ; do
                gst-plugins10_find_plugin_dir ${plugin_dir}
 
index 478b6b8c0a01eca42de0535e774c056f1f326dbe..264b0b426a2ff89492830dc78157bde62ed9c041 100644 (file)
@@ -2,9 +2,9 @@
 # Distributed under the terms of the GNU General Public License v2
 
 # @ECLASS: kernel-2.eclass
-# @MAINTAINER: 
+# @MAINTAINER:
 # Gentoo Kernel project <kernel@gentoo.org>
-# @AUTHOR: 
+# @AUTHOR:
 # John Mylchreest <johnm@gentoo.org>
 # Mike Pagano <mpagano@gentoo.org>
 # <so many, many others, please add yourself>
 # this is useful for things like wolk. IE:
 # EXTRAVERSION would be something like : -wolk-4.19-r1
 
-# @ECLASS-VARIABLE:  K_NOSETEXTRAVERSION       
+# @ECLASS-VARIABLE:  K_NOSETEXTRAVERSION
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # if this is set then EXTRAVERSION will not be
 # automatically set within the kernel Makefile
 
-# @ECLASS-VARIABLE: K_NOUSENAME                        
+# @ECLASS-VARIABLE: K_NOUSENAME
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # if this is set then EXTRAVERSION will not include the
 # first part of ${PN} in EXTRAVERSION
 
-# @ECLASS-VARIABLE: K_NOUSEPR                          
+# @ECLASS-VARIABLE: K_NOUSEPR
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # if this is set then EXTRAVERSION will not include the
 # anything based on ${PR}.
 
-# @ECLASS-VARIABLE: K_PREPATCHED                       
+# @ECLASS-VARIABLE: K_PREPATCHED
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # if the patchset is prepatched (ie: mm-sources,
 # the patchset version for
 # and not use it as a true package revision
 
-# @ECLASS-VARIABLE:  K_EXTRAEINFO                      
+# @ECLASS-VARIABLE:  K_EXTRAEINFO
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # this is a new-line seperated list of einfo displays in
 # postinst and can be used to carry additional postinst
 # messages
 
-# @ECLASS-VARIABLE:  K_EXTRAELOG                       
+# @ECLASS-VARIABLE:  K_EXTRAELOG
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # same as K_EXTRAEINFO except using elog instead of einfo
 
-# @ECLASS-VARIABLE:  K_EXTRAEWARN                      
+# @ECLASS-VARIABLE:  K_EXTRAEWARN
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # same as K_EXTRAEINFO except using ewarn instead of einfo
 
-# @ECLASS-VARIABLE:  K_SYMLINK                         
+# @ECLASS-VARIABLE:  K_SYMLINK
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # if this is set, then forcably create symlink anyway
 
-# @ECLASS-VARIABLE:  K_BASE_VER                        
+# @ECLASS-VARIABLE:  K_BASE_VER
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # for git-sources, declare the base version this patch is
 # based off of.
 
-# @ECLASS-VARIABLE:  K_DEFCONFIG                       
+# @ECLASS-VARIABLE:  K_DEFCONFIG
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # Allow specifying a different defconfig target.
 # If length zero, defaults to "defconfig".
 
-# @ECLASS-VARIABLE:  K_WANT_GENPATCHES         
+# @ECLASS-VARIABLE:  K_WANT_GENPATCHES
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # Apply genpatches to kernel source. Provide any
 # combination of "base", "extras" or "experimental".
 
-# @ECLASS-VARIABLE:  K_EXP_GENPATCHES_PULL     
+# @ECLASS-VARIABLE:  K_EXP_GENPATCHES_PULL
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # If set, we pull "experimental" regardless of the USE FLAG
 # but expect the ebuild maintainer to use K_EXP_GENPATCHES_LIST.
 
-# @ECLASS-VARIABLE:  K_EXP_GENPATCHES_NOUSE    
+# @ECLASS-VARIABLE:  K_EXP_GENPATCHES_NOUSE
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # If set, no USE flag will be provided for "experimental";
 # as a result the user cannot choose to apply those patches.
 
-# @ECLASS-VARIABLE:  K_EXP_GENPATCHES_LIST     
+# @ECLASS-VARIABLE:  K_EXP_GENPATCHES_LIST
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # A list of patches to pick from "experimental" to apply when
 # the USE flag is unset and K_EXP_GENPATCHES_PULL is set.
 
-# @ECLASS-VARIABLE:  K_FROM_GIT 
+# @ECLASS-VARIABLE:  K_FROM_GIT
 # @DEFAULT_UNSET
 # @DESCRIPTION:
-# If set, this variable signals that the kernel sources derives 
-# from a git tree and special handling will be applied so that 
+# If set, this variable signals that the kernel sources derives
+# from a git tree and special handling will be applied so that
 # any patches that are applied will actually apply.
 
-# @ECLASS-VARIABLE:  K_GENPATCHES_VER          
+# @ECLASS-VARIABLE:  K_GENPATCHES_VER
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # The version of the genpatches tarball(s) to apply.
 # If set, this kernel is unsupported by Gentoo Security
 # to the current eclass maintainer :)
 
-# @ECLASS-VARIABLE:  K_DEBLOB_AVAILABLE        
+# @ECLASS-VARIABLE:  K_DEBLOB_AVAILABLE
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # A value of "0" will disable all of the optional deblob
 # code. If empty, will be set to "1" if deblobbing is
 # possible. Test ONLY for "1".
 
-# @ECLASS-VARIABLE:  K_DEBLOB_TAG              
+# @ECLASS-VARIABLE:  K_DEBLOB_TAG
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # This will be the version of deblob script. It's a upstream SVN tag
 # such asw -gnu or -gnu1.
 
-# @ECLASS-VARIABLE:  K_PREDEBLOBBED            
+# @ECLASS-VARIABLE:  K_PREDEBLOBBED
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # This kernel was already deblobbed elsewhere.
 # If false, either optional deblobbing will be available
 # or the license will note the inclusion of freedist code.
 
-# @ECLASS-VARIABLE:  K_LONGTERM                        
+# @ECLASS-VARIABLE:  K_LONGTERM
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # If set, the eclass will search for the kernel source
 # in the long term directories on the upstream servers
 # as the location has been changed by upstream
 
-# @ECLASS-VARIABLE:  H_SUPPORTEDARCH           
+# @ECLASS-VARIABLE:  H_SUPPORTEDARCH
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # this should be a space separated list of ARCH's which
 # can be supported by the headers ebuild
 
-# @ECLASS-VARIABLE:  UNIPATCH_LIST                     
+# @ECLASS-VARIABLE:  UNIPATCH_LIST
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # space delimetered list of patches to be applied to the kernel
 
-# @ECLASS-VARIABLE:  UNIPATCH_EXCLUDE          
+# @ECLASS-VARIABLE:  UNIPATCH_EXCLUDE
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # An addition var to support exlusion based completely
 # this should _NOT_ be used from the ebuild as this is
 # reserved for end users passing excludes from the cli
 
-# @ECLASS-VARIABLE:  UNIPATCH_DOCS                     
+# @ECLASS-VARIABLE:  UNIPATCH_DOCS
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # space delimemeted list of docs to be installed to
 # the doc dir
 
-# @ECLASS-VARIABLE:  UNIPATCH_STRICTORDER      
+# @ECLASS-VARIABLE:  UNIPATCH_STRICTORDER
 # @DEFAULT_UNSET
 # @DESCRIPTION:
 # if this is set places patches into directories of
@@ -232,7 +232,7 @@ RESTRICT="binchecks strip"
 
 # @FUNCTION: debug-print-kernel2-variables
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # this function exists only to help debug kernel-2.eclass
 # if you are adding new functionality in, put a call to it
 # at the start of src_unpack, or during SRC_URI/dep generation.
@@ -305,7 +305,7 @@ handle_genpatches() {
 
 # @FUNCTION: detect_version
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # this function will detect and set
 # - OKV: Original Kernel Version (2.6.0/2.6.0-test11)
 # - KV: Kernel Version (2.6.0-gentoo/2.6.0-test11-gentoo-r1)
@@ -537,7 +537,7 @@ detect_version() {
 
 # @FUNCTION: kernel_is
 # @USAGE: <conditional version | version>
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # user for comparing kernel versions
 # or just identifying a version
 # e.g kernel_is 2 4
@@ -571,16 +571,16 @@ kernel_is() {
 
 # @FUNCTION: kernel_is_2_4
 # @USAGE:
-# @DESCRIPTION: 
-# return true if kernel is version 2.4 
+# @DESCRIPTION:
+# return true if kernel is version 2.4
 kernel_is_2_4() {
        kernel_is 2 4
 }
 
 # @FUNCTION: kernel_is_2_6
 # @USAGE:
-# @DESCRIPTION: 
-# return true if kernel is version 2.6 
+# @DESCRIPTION:
+# return true if kernel is version 2.6
 kernel_is_2_6() {
        kernel_is 2 6 || kernel_is 2 5
 }
@@ -670,7 +670,7 @@ fi
 
 # @FUNCTION: kernel_header_destdir
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # return header destination directory
 kernel_header_destdir() {
        [[ ${CTARGET} == ${CHOST} ]] \
@@ -680,15 +680,15 @@ kernel_header_destdir() {
 
 # @FUNCTION: cross_pre_c_headers
 # @USAGE:
-# @DESCRIPTION: 
-# set use if necessary for cross compile support 
+# @DESCRIPTION:
+# set use if necessary for cross compile support
 cross_pre_c_headers() {
        use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
 }
 
 # @FUNCTION: env_setup_xmakeopts
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # set the ARCH/CROSS_COMPILE when cross compiling
 
 env_setup_xmakeopts() {
@@ -708,7 +708,7 @@ env_setup_xmakeopts() {
 
 # @FUNCTION: unpack_2_4
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # unpack and generate .config for 2.4 kernels
 
 unpack_2_4() {
@@ -722,7 +722,7 @@ unpack_2_4() {
 
 # @FUNCTION: unpack_2_6
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # unpack and generate .config for 2.6 kernels
 
 unpack_2_6() {
@@ -748,8 +748,8 @@ unpack_2_6() {
 
 # @FUNCTION: universal_unpack
 # @USAGE:
-# @DESCRIPTION: 
-# unpack kernel sources 
+# @DESCRIPTION:
+# unpack kernel sources
 
 universal_unpack() {
        debug-print "Inside universal_unpack"
@@ -792,8 +792,8 @@ universal_unpack() {
 
 # @FUNCTION: unpack_set_extraversion
 # @USAGE:
-# @DESCRIPTION: 
-# handle EXTRAVERSION 
+# @DESCRIPTION:
+# handle EXTRAVERSION
 
 unpack_set_extraversion() {
        cd "${S}"
@@ -803,7 +803,7 @@ unpack_set_extraversion() {
 
 # @FUNCTION: unpack_fix_install_path
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Should be done after patches have been applied
 # Otherwise patches that modify the same area of Makefile will fail
 
@@ -816,7 +816,7 @@ unpack_fix_install_path() {
 
 # @FUNCTION: compile_headers
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # header compilation
 
 compile_headers() {
@@ -873,7 +873,7 @@ compile_headers() {
 
 # @FUNCTION: compile_headers_tweak_config
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # some targets can be very very picky, so let's finesse the
 # .config based upon any info we may have
 
@@ -893,7 +893,7 @@ compile_headers_tweak_config() {
 
 # @FUNCTION: install_universal
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Fix permissions in tarball
 
 install_universal() {
@@ -905,8 +905,8 @@ install_universal() {
 
 # @FUNCTION: install_headers
 # @USAGE:
-# @DESCRIPTION: 
-# Install headers 
+# @DESCRIPTION:
+# Install headers
 
 install_headers() {
        local ddir=$(kernel_header_destdir)
@@ -945,8 +945,8 @@ install_headers() {
 
 # @FUNCTION: install_sources
 # @USAGE:
-# @DESCRIPTION: 
-# Install sources 
+# @DESCRIPTION:
+# Install sources
 
 install_sources() {
        local file
@@ -977,8 +977,8 @@ install_sources() {
 
 # @FUNCTION: preinst_headers
 # @USAGE:
-# @DESCRIPTION: 
-# Headers preinst steps 
+# @DESCRIPTION:
+# Headers preinst steps
 
 preinst_headers() {
        local ddir=$(kernel_header_destdir)
@@ -988,7 +988,7 @@ preinst_headers() {
 
 # @FUNCTION: postinst_sources
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Sources post installation function.
 # see inline comments
 
@@ -1089,7 +1089,7 @@ postinst_sources() {
 
 # @FUNCTION: setup_headers
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Determine if ${PN} supports arch
 
 setup_headers() {
@@ -1109,8 +1109,8 @@ setup_headers() {
 
 # @FUNCTION: unipatch
 # @USAGE: <list of patches to apply>
-# @DESCRIPTION: 
-# Universal function that will apply patches to source 
+# @DESCRIPTION:
+# Universal function that will apply patches to source
 
 unipatch() {
        local i x y z extention PIPE_CMD UNIPATCH_DROP KPATCH_DIR PATCH_DEPTH ELINE
@@ -1128,7 +1128,7 @@ unipatch() {
        # We're gonna need it when doing patches with a predefined patchlevel
        eshopts_push -s extglob
 
-       # This function will unpack all passed tarballs, add any passed patches, 
+       # This function will unpack all passed tarballs, add any passed patches,
        # and remove any passed patchnumbers
        # usage can be either via an env var or by params
        # although due to the nature we pass this within this eclass
@@ -1366,7 +1366,7 @@ unipatch() {
 
 # @FUNCTION: getfilevar
 # @USAGE: <variable> <configfile>
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # pulled from linux-info
 
 getfilevar() {
@@ -1393,7 +1393,7 @@ getfilevar() {
 
 # @FUNCTION: detect_arch
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # This function sets ARCH_URI and ARCH_PATCH
 # with the neccessary info for the arch sepecific compatibility
 # patchsets.
@@ -1427,7 +1427,7 @@ detect_arch() {
 
 # @FUNCTION: headers___fix
 # @USAGE:
-# @DESCRIPTION: 
+# @DESCRIPTION:
 # Voodoo to partially fix broken upstream headers.
 # note: do not put inline/asm/volatile together (breaks "inline asm volatile")
 
@@ -1441,10 +1441,10 @@ headers___fix() {
                "$@"
 }
 
-# @FUNCTION: kernel-2_src_unpack() 
+# @FUNCTION: kernel-2_src_unpack()
 # @USAGE:
-# @DESCRIPTION: 
-# unpack sources, handle genpatches, deblob 
+# @DESCRIPTION:
+# unpack sources, handle genpatches, deblob
 
 kernel-2_src_unpack() {
        universal_unpack
@@ -1506,7 +1506,7 @@ kernel-2_src_unpack() {
 # @FUNCTION: kernel-2_src_prepare
 # @USAGE:
 # @DESCRIPTION:
-# Apply any user patches 
+# Apply any user patches
 
 kernel-2_src_prepare() {
 
@@ -1522,7 +1522,7 @@ kernel-2_src_prepare() {
 # @FUNCTION: kernel-2_src_compile
 # @USAGE:
 # @DESCRIPTION:
-# conpile headers or run deblob script 
+# conpile headers or run deblob script
 
 kernel-2_src_compile() {
        cd "${S}"
@@ -1548,7 +1548,7 @@ kernel-2_src_test() { :; }
 
 # @FUNCTION: kernel-2_pkg_preinst
 # @DESCRIPTION:
-# if ETYPE = headers, call preinst_headers 
+# if ETYPE = headers, call preinst_headers
 
 kernel-2_pkg_preinst() {
        [[ ${ETYPE} == headers ]] && preinst_headers
@@ -1568,7 +1568,7 @@ kernel-2_src_install() {
 # @FUNCTION: kernel-2_pkg_postinst
 # @USAGE:
 # @DESCRIPTION:
-# call postinst_sources for ETYPE = sources 
+# call postinst_sources for ETYPE = sources
 
 kernel-2_pkg_postinst() {
        [[ ${ETYPE} == sources ]] && postinst_sources
@@ -1578,7 +1578,7 @@ kernel-2_pkg_postinst() {
 # @USAGE:
 # @DESCRIPTION:
 # check for supported kernel version, die if ETYPE is unknown, call setup_headers
-# if necessary 
+# if necessary
 
 kernel-2_pkg_setup() {
        if kernel_is 2 4; then
index cb2dc125d70a3bb9c9218db8ff7e5b03400ba7ec..b3ea3e40f30fef299b1a7fb6e0e9e5c2ad2302e7 100644 (file)
@@ -133,7 +133,7 @@ IUSE="kernel_linux ${MODULES_OPTIONAL_USE}"
 SLOT="0"
 RDEPEND="${MODULES_OPTIONAL_USE}${MODULES_OPTIONAL_USE:+? (} kernel_linux? ( virtual/modutils ) ${MODULES_OPTIONAL_USE:+)}"
 DEPEND="${RDEPEND}
-    ${MODULES_OPTIONAL_USE}${MODULES_OPTIONAL_USE:+? (} 
+    ${MODULES_OPTIONAL_USE}${MODULES_OPTIONAL_USE:+? (}
        sys-apps/sed
        kernel_linux? ( virtual/linux-sources )
        ${MODULES_OPTIONAL_USE:+)}"
index 83113fcd59be07a7fba518330fcf9955e9172652..1f4ad3f354492c2ae293ababaf9a3193c33d3fad 100644 (file)
@@ -48,7 +48,7 @@ inherit versionator
 # If live ebuild, will be set to '9999'.
 : ${MATE_BRANCH:=$(get_version_component_range 1-2)}
 
-# Set SRC_URI or EGIT_REPO_URI based on whether live 
+# Set SRC_URI or EGIT_REPO_URI based on whether live
 if [[ ${PV} == 9999 ]]; then
        EGIT_REPO_URI="
                https://github.com/mate-desktop/${MATE_DESKTOP_ORG_PN}.git
index 65f5d805b60744e3be171aadc45cf6d9da2169be..ca41ff45ac2e8c38f4179af76070dbfc0a1c56ed 100644 (file)
@@ -81,7 +81,7 @@ EHG_OFFLINE="${EHG_OFFLINE:-${EVCS_OFFLINE}}"
 # Clone or update repository.
 #
 # If repository URI is not passed it defaults to EHG_REPO_URI, if module is
-# empty it defaults to basename of EHG_REPO_URI, sourcedir defaults to 
+# empty it defaults to basename of EHG_REPO_URI, sourcedir defaults to
 # EHG_CHECKOUT_DIR, which defaults to S.
 
 mercurial_fetch() {
index 6863f1e0b1f8ed663a24842be6b86eede4665fca..28a876fd204900b7c5ace8be38101f8b4bc79aa6 100644 (file)
@@ -238,7 +238,7 @@ mozconfig_config() {
                fi
        fi
 
-       # Enable position independent executables 
+       # Enable position independent executables
        mozconfig_annotate 'enabled by Gentoo' --enable-pie
        mozconfig_use_enable debug
        mozconfig_use_enable debug tests
index 20c864c8851c449f9218b21532f646efa03627a2..58c6662a049246c395c2b6ac88725a15275a8230 100644 (file)
@@ -103,7 +103,7 @@ multilib_src_configure() {
 
 # @FUNCTION: netsurf_make
 # @DESCRIPTION:
-# Calls emake with netsurf_makeconf and toolchain CC/LD 
+# Calls emake with netsurf_makeconf and toolchain CC/LD
 # as arguments for every NETSURF_COMPONENT_TYPE if activated.
 netsurf_make() {
        for COMPONENT_TYPE in ${NETSURF_COMPONENT_TYPE} ; do
@@ -125,7 +125,7 @@ netsurf_src_compile() {
        local problems=$(egrep -Hn -- ' (-O.?|-g)( |$)' \
                $(find . -type f -name 'Makefile*'))
        if [ -n "${problems}" ] ; then
-               elog "found bad flags: 
+               elog "found bad flags:
 ${problems}"
        fi
 
index aca744d409c6301cda05c873f2b4b64ba36b51de..ff97e8fe8b6206d835187603fdde9895de43795a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 # @ECLASS: oasis.eclass
-# @MAINTAINER: 
+# @MAINTAINER:
 # ml@gentoo.org
 # @AUTHOR:
 # Original Author: Alexis Ballier <aballier@gentoo.org>
@@ -98,7 +98,7 @@ oasis_src_configure() {
 # @DESCRIPTION:
 # Builds an oasis-based package.
 # Will build documentation if OASIS_BUILD_DOCS is defined and the doc useflag is
-# enabled. 
+# enabled.
 oasis_src_compile() {
        ${OASIS_SETUP_COMMAND:-ocaml setup.ml} -build || die
        if [ -n "${OASIS_BUILD_DOCS}" ] && use doc; then
index 4f6872500c204530d6ee765d4a2bcc0e2a0c94cf..81dcc0066dbdcbdaeb9a48b5fdbc20da94ab7352 100644 (file)
@@ -29,10 +29,10 @@ perlinfo_done=false
 # @FUNCTION: perl_set_version
 # @USAGE: perl_set_version
 # @DESCRIPTION:
-# Extract version information and installation paths from the current Perl 
-# interpreter. 
+# Extract version information and installation paths from the current Perl
+# interpreter.
 #
-# This sets the following variables: PERL_VERSION, SITE_ARCH, SITE_LIB, 
+# This sets the following variables: PERL_VERSION, SITE_ARCH, SITE_LIB,
 # ARCH_LIB, VENDOR_LIB, VENDOR_ARCH
 #
 # This function used to be called perlinfo as well.
@@ -215,7 +215,7 @@ perl_rm_files() {
 # @USAGE: perl_link_duallife_scripts
 # @DESCRIPTION:
 # Moves files and generates symlinks so dual-life packages installing scripts do not
-# lead to file collisions. Mainly for use in pkg_postinst and pkg_postrm, and makes 
+# lead to file collisions. Mainly for use in pkg_postinst and pkg_postrm, and makes
 # only sense for perl-core packages.
 perl_link_duallife_scripts() {
        debug-print-function $FUNCNAME "$@"
index 83d988e130048bd208f79f666d776f4722929c3f..af5a0c9e34466b70f2d9dd713d8fd4b2eff361c7 100644 (file)
@@ -446,9 +446,9 @@ perl-module_src_install() {
 # @FUNCTION: perl-module_pkg_postinst
 # @USAGE: perl-module_pkg_postinst
 # @DESCRIPTION:
-# This function is to be called during the pkg_postinst() phase. It only does 
+# This function is to be called during the pkg_postinst() phase. It only does
 # useful things for the perl-core category, where it handles the file renaming and symbolic
-# links that prevent file collisions for dual-life packages installing scripts. 
+# links that prevent file collisions for dual-life packages installing scripts.
 # In any other category it immediately exits.
 perl-module_pkg_postinst() {
        debug-print-function $FUNCNAME "$@"
@@ -462,9 +462,9 @@ perl-module_pkg_postinst() {
 # @FUNCTION: perl-module_pkg_postrm
 # @USAGE: perl-module_pkg_postrm
 # @DESCRIPTION:
-# This function is to be called during the pkg_postrm() phase. It only does 
+# This function is to be called during the pkg_postrm() phase. It only does
 # useful things for the perl-core category, where it handles the file renaming and symbolic
-# links that prevent file collisions for dual-life packages installing scripts. 
+# links that prevent file collisions for dual-life packages installing scripts.
 # In any other category it immediately exits.
 perl-module_pkg_postrm() {
        debug-print-function $FUNCNAME "$@"
index c75c4678e310b680f4a59ece68b25eacd029294e..a67e378d39974b6e9d5f11f6a4d3218b42a3aba5 100644 (file)
@@ -1270,14 +1270,14 @@ python_export_utf8_locale() {
                                        fi
                                        return 0
                                fi
-                       fi  
+                       fi
                done
 
                ewarn "Could not find a UTF-8 locale. This may trigger build failures in"
                ewarn "some python packages. Please ensure that a UTF-8 locale is listed in"
                ewarn "/etc/locale.gen and run locale-gen."
                return 1
-       fi  
+       fi
 
        return 0
 }
index b6b84a0dc5f38c3b73946ff09b5e599a61f3c485..fec873a922cb209850e2813b7874e404407964f2 100644 (file)
@@ -80,7 +80,7 @@ fi
 # @DESCRIPTION:
 # Some messages have dependencies on other messages.
 # In that case, CATKIN_MESSAGES_TRANSITIVE_DEPS should contain a space-separated list of atoms
-# representing those dependencies. The eclass uses it to ensure proper dependencies on these packages. 
+# representing those dependencies. The eclass uses it to ensure proper dependencies on these packages.
 if [ -n "${CATKIN_HAS_MESSAGES}" ] ; then
        IUSE="${IUSE} +ros_messages_python +ros_messages_cxx ros_messages_eus ros_messages_lisp ros_messages_nodejs"
        RDEPEND="${RDEPEND}