dev-python/spyder: Clean old up
authorMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 09:40:15 +0000 (10:40 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 6 Jan 2018 13:39:05 +0000 (14:39 +0100)
dev-python/spyder/Manifest
dev-python/spyder/files/spyder-3.0.2-build.patch [deleted file]
dev-python/spyder/files/spyder-3.2.3-build.patch [deleted file]
dev-python/spyder/spyder-3.0.2-r3.ebuild [deleted file]
dev-python/spyder/spyder-3.2.3.ebuild [deleted file]

index 2d9817b18693ffc15720c36245479b0ceca409a7..518bd6f7966ba6747deb98c1630f2259e7a424e9 100644 (file)
@@ -1,3 +1 @@
-DIST spyder-3.0.2.tar.gz 3207709 BLAKE2B e2a55db41610af6f29843a309fa3e4774fa49c07bf59f2152881738d41df413032e125d8cf19d5844f15e1b4ec56b2f335c6b4b319609a02f8bf40711dde75fe SHA512 7f3723bd98876aa4769877327a93aa02510689708012afc72148c67acd91ab134501ae57471d9cf0e17c9e3892a541b7730a2392ace3c6525443058d0ed01612
-DIST spyder-3.2.3.tar.gz 3342954 BLAKE2B bfe3c045883c5090a664097e943d868ee63b5c92f8f89e033ae5959ba04c02c832d830cb2f8f3b2c1b70f86824cc5e4b6f7633eafc68dd30601583f97a54345a SHA512 873a1a0c319fc6580dfbe7370dc5ca132d973b5baf75ba0b6cda228adb7fe7baf4fbdebf4d1984ed6f204c7d27b1bfc2c449199ab02aeb8caf9ebded738f3491
 DIST spyder-3.2.4.tar.gz 3345797 BLAKE2B 2df946f257fee7e87dd922b6ed3b3c0fa02438560cb7fa4087f25498eb134bfc8c342a0a928be37f08448dfea2917380a8521ead13954091b1854616012ace91 SHA512 46e89c68545695d1e64aaafdd2ed724b152a41088f1bfa645b8c66d8ae6bcc2d86e9830cd3f16edfb8027aad5786dfb67f2a8371839dd515df8ebe34446716e6
diff --git a/dev-python/spyder/files/spyder-3.0.2-build.patch b/dev-python/spyder/files/spyder-3.0.2-build.patch
deleted file mode 100644 (file)
index f476401..0000000
+++ /dev/null
@@ -1,140 +0,0 @@
-diff -r -U3 spyder-3.0.2.orig/setup.py spyder-3.0.2/setup.py
---- spyder-3.0.2.orig/setup.py 2016-10-25 07:05:22.000000000 +0700
-+++ spyder-3.0.2/setup.py      2016-12-12 19:44:13.840412632 +0700
-@@ -77,12 +77,7 @@
- def get_data_files():
-     """Return data_files in a platform dependent manner"""
-     if sys.platform.startswith('linux'):
--        if PY3:
--            data_files = [('share/applications', ['scripts/spyder3.desktop']),
--                          ('share/pixmaps', ['img_src/spyder3.png'])]
--        else:
--            data_files = [('share/applications', ['scripts/spyder.desktop']),
--                          ('share/pixmaps', ['img_src/spyder.png'])]
-+        data_files = [('share/pixmaps', ['img_src/spyder.png'])]
-     elif os.name == 'nt':
-         data_files = [('scripts', ['img_src/spyder.ico',
-                                    'img_src/spyder_reset.ico'])]
-@@ -105,111 +100,9 @@
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
--    def run(self):
--        install_data.run(self)
--        if sys.platform.startswith('linux'):
--            try:
--                subprocess.call(['update-desktop-database'])
--            except:
--                print("ERROR: unable to update desktop database",
--                      file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
--# Sphinx build (documentation)
--#==============================================================================
--def get_html_help_exe():
--    """Return HTML Help Workshop executable path (Windows only)"""
--    if os.name == 'nt':
--        hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
--        for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
--            if osp.isfile(hhc_exe):
--                return hhc_exe
--        else:
--            return
--
--try:
--    from sphinx import setup_command
--
--    class MyBuild(build):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + build.user_options
--        def __init__(self, *args, **kwargs):
--            build.__init__(self, *args, **kwargs)
--            self.no_doc = False
--        def with_doc(self):
--            setup_dir = os.path.dirname(os.path.abspath(__file__))
--            is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
--            install_obj = self.distribution.get_command_obj('install')
--            return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
--        sub_commands = build.sub_commands + [('build_doc', with_doc)]
--    CMDCLASS['build'] = MyBuild
--
--
--    class MyInstall(install):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + install.user_options
--        def __init__(self, *args, **kwargs):
--            install.__init__(self, *args, **kwargs)
--            self.no_doc = False
--    CMDCLASS['install'] = MyInstall
--
--
--    class MyBuildDoc(setup_command.BuildDoc):
--        def run(self):
--            build = self.get_finalized_command('build')
--            sys.path.insert(0, os.path.abspath(build.build_lib))
--            dirname = self.distribution.get_command_obj('build').build_purelib
--            self.builder_target_dir = osp.join(dirname, 'spyder', 'doc')
--
--            if not osp.exists(self.builder_target_dir):
--                os.mkdir(self.builder_target_dir)
--
--            hhc_exe = get_html_help_exe()
--            self.builder = "html" if hhc_exe is None else "htmlhelp"
--
--            try:
--                setup_command.BuildDoc.run(self)
--            except UnicodeDecodeError:
--                print("ERROR: unable to build documentation because Sphinx "\
--                      "do not handle source path with non-ASCII characters. "\
--                      "Please try to move the source package to another "\
--                      "location (path with *only* ASCII characters).",
--                      file=sys.stderr)
--            sys.path.pop(0)
--
--            # Building chm doc, if HTML Help Workshop is installed
--            if hhc_exe is not None:
--                fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
--                subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
--                if osp.isfile(fname):
--                    dest = osp.join(dirname, 'spyder')
--                    try:
--                        shutil.move(fname, dest)
--                    except shutil.Error:
--                        print("Unable to replace %s" % dest)
--                    shutil.rmtree(self.builder_target_dir)
--
--    CMDCLASS['build_doc'] = MyBuildDoc
--except ImportError:
--    print('WARNING: unable to build documentation because Sphinx '\
--          'is not installed', file=sys.stderr)
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
--# NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
--# platforms due to a bug in pip installation process (see Issue 1158)
--SCRIPTS = ['%s_win_post_install.py' % NAME]
--if PY3 and sys.platform.startswith('linux'):
--    SCRIPTS.append('spyder3')
--else:
--    SCRIPTS.append('spyder')
-+SCRIPTS = ['spyder']
- #==============================================================================
-@@ -259,8 +152,7 @@
-                    'Programming Language :: Python :: 3',
-                    'Development Status :: 5 - Production/Stable',
-                    'Topic :: Scientific/Engineering',
--                   'Topic :: Software Development :: Widget Sets'],
--      cmdclass=CMDCLASS)
-+                   'Topic :: Software Development :: Widget Sets'])
- #==============================================================================
diff --git a/dev-python/spyder/files/spyder-3.2.3-build.patch b/dev-python/spyder/files/spyder-3.2.3-build.patch
deleted file mode 100644 (file)
index 2a1fee5..0000000
+++ /dev/null
@@ -1,130 +0,0 @@
---- spyder-3.2.3.orig/setup.py 2017-08-29 00:42:56.000000000 +0200
-+++ spyder-3.2.3/setup.py      2017-09-16 20:57:08.610147911 +0200
-@@ -77,13 +77,7 @@
- def get_data_files():
-     """Return data_files in a platform dependent manner"""
-     if sys.platform.startswith('linux'):
--        if PY3:
--            data_files = [('share/applications', ['scripts/spyder3.desktop']),
--                          ('share/pixmaps', ['img_src/spyder3.png']),
--                          ('share/metainfo', ['scripts/spyder3.appdata.xml'])]
--        else:
--            data_files = [('share/applications', ['scripts/spyder.desktop']),
--                          ('share/pixmaps', ['img_src/spyder.png'])]
-+        data_files = [('share/pixmaps', ['img_src/spyder.png'])]
-     elif os.name == 'nt':
-         data_files = [('scripts', ['img_src/spyder.ico',
-                                    'img_src/spyder_reset.ico'])]
-@@ -106,102 +100,6 @@
- #==============================================================================
--# Make Linux detect Spyder desktop file
--#==============================================================================
--class MyInstallData(install_data):
--    def run(self):
--        install_data.run(self)
--        if sys.platform.startswith('linux'):
--            try:
--                subprocess.call(['update-desktop-database'])
--            except:
--                print("ERROR: unable to update desktop database",
--                      file=sys.stderr)
--CMDCLASS = {'install_data': MyInstallData}
--
--
--#==============================================================================
--# Sphinx build (documentation)
--#==============================================================================
--def get_html_help_exe():
--    """Return HTML Help Workshop executable path (Windows only)"""
--    if os.name == 'nt':
--        hhc_base = r'C:\Program Files%s\HTML Help Workshop\hhc.exe'
--        for hhc_exe in (hhc_base % '', hhc_base % ' (x86)'):
--            if osp.isfile(hhc_exe):
--                return hhc_exe
--        else:
--            return
--
--try:
--    from sphinx import setup_command
--
--    class MyBuild(build):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + build.user_options
--        def __init__(self, *args, **kwargs):
--            build.__init__(self, *args, **kwargs)
--            self.no_doc = False
--        def with_doc(self):
--            setup_dir = os.path.dirname(os.path.abspath(__file__))
--            is_doc_dir = os.path.isdir(os.path.join(setup_dir, 'doc'))
--            install_obj = self.distribution.get_command_obj('install')
--            return (is_doc_dir and not self.no_doc and not install_obj.no_doc)
--        sub_commands = build.sub_commands + [('build_doc', with_doc)]
--    CMDCLASS['build'] = MyBuild
--
--
--    class MyInstall(install):
--        user_options = [('no-doc', None, "Don't build Spyder documentation")] \
--                       + install.user_options
--        def __init__(self, *args, **kwargs):
--            install.__init__(self, *args, **kwargs)
--            self.no_doc = False
--    CMDCLASS['install'] = MyInstall
--
--
--    class MyBuildDoc(setup_command.BuildDoc):
--        def run(self):
--            build = self.get_finalized_command('build')
--            sys.path.insert(0, os.path.abspath(build.build_lib))
--            dirname = self.distribution.get_command_obj('build').build_purelib
--            self.builder_target_dir = osp.join(dirname, 'spyder', 'doc')
--
--            if not osp.exists(self.builder_target_dir):
--                os.mkdir(self.builder_target_dir)
--
--            hhc_exe = get_html_help_exe()
--            self.builder = "html" if hhc_exe is None else "htmlhelp"
--
--            try:
--                setup_command.BuildDoc.run(self)
--            except UnicodeDecodeError:
--                print("ERROR: unable to build documentation because Sphinx "\
--                      "do not handle source path with non-ASCII characters. "\
--                      "Please try to move the source package to another "\
--                      "location (path with *only* ASCII characters).",
--                      file=sys.stderr)
--            sys.path.pop(0)
--
--            # Building chm doc, if HTML Help Workshop is installed
--            if hhc_exe is not None:
--                fname = osp.join(self.builder_target_dir, 'Spyderdoc.chm')
--                subprocess.call('"%s" %s' % (hhc_exe, fname), shell=True)
--                if osp.isfile(fname):
--                    dest = osp.join(dirname, 'spyder')
--                    try:
--                        shutil.move(fname, dest)
--                    except shutil.Error:
--                        print("Unable to replace %s" % dest)
--                    shutil.rmtree(self.builder_target_dir)
--
--    CMDCLASS['build_doc'] = MyBuildDoc
--except ImportError:
--    print('WARNING: unable to build documentation because Sphinx '\
--          'is not installed', file=sys.stderr)
--
--
--#==============================================================================
- # Main scripts
- #==============================================================================
- # NOTE: the '[...]_win_post_install.py' script is installed even on non-Windows
-@@ -261,8 +159,7 @@
-                    'Programming Language :: Python :: 3',
-                    'Development Status :: 5 - Production/Stable',
-                    'Topic :: Scientific/Engineering',
--                   'Topic :: Software Development :: Widget Sets'],
--      cmdclass=CMDCLASS)
-+                   'Topic :: Software Development :: Widget Sets'])
- #==============================================================================
diff --git a/dev-python/spyder/spyder-3.0.2-r3.ebuild b/dev-python/spyder/spyder-3.0.2-r3.ebuild
deleted file mode 100644 (file)
index 1543c8d..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="https://github.com/spyder-ide/spyder/ https://pypi.python.org/pypi/spyder/ http://pythonhosted.org/spyder/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc hdf5"
-
-RDEPEND="
-       dev-python/PyQt5[${PYTHON_USEDEP},svg,webkit]
-       dev-python/QtPy[${PYTHON_USEDEP},svg,webkit]
-       dev-python/qtconsole[${PYTHON_USEDEP}]
-       >=dev-python/rope-0.10.7[${PYTHON_USEDEP}]
-       dev-python/jedi[${PYTHON_USEDEP}]
-       dev-python/pyflakes[${PYTHON_USEDEP}]
-       dev-python/sphinx[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/pylint[${PYTHON_USEDEP}]
-       dev-python/pep8[${PYTHON_USEDEP}]
-       dev-python/psutil[${PYTHON_USEDEP}]
-       dev-python/nbconvert[${PYTHON_USEDEP}]
-       dev-python/qtawesome[${PYTHON_USEDEP}]
-       dev-python/pickleshare[${PYTHON_USEDEP}]
-       dev-python/pyzmq[${PYTHON_USEDEP}]
-       dev-python/chardet[${PYTHON_USEDEP}]
-       hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-# Courtesy of Arfrever
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build doc doc/html || die "Generation of documentation failed"
-       fi
-}
-
-python_install() {
-       distutils-r1_python_install
-       python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/html/. )
-       distutils-r1_python_install_all
-       doicon spyder/images/spyder.svg
-       make_desktop_entry spyder Spyder spyder "Development;IDE"
-}
diff --git a/dev-python/spyder/spyder-3.2.3.ebuild b/dev-python/spyder/spyder-3.2.3.ebuild
deleted file mode 100644 (file)
index 485bde9..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
-
-inherit eutils distutils-r1
-
-DESCRIPTION="Python IDE with matlab-like features"
-HOMEPAGE="https://github.com/spyder-ide/spyder/ https://pypi.python.org/pypi/spyder/ http://pythonhosted.org/spyder/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc hdf5"
-
-RDEPEND="
-       dev-python/PyQt5[${PYTHON_USEDEP},svg,webkit]
-       dev-python/QtPy[${PYTHON_USEDEP},svg,webkit]
-       dev-python/qtconsole[${PYTHON_USEDEP}]
-       >=dev-python/rope-0.10.7[${PYTHON_USEDEP}]
-       dev-python/jedi[${PYTHON_USEDEP}]
-       dev-python/pyflakes[${PYTHON_USEDEP}]
-       dev-python/sphinx[${PYTHON_USEDEP}]
-       dev-python/pygments[${PYTHON_USEDEP}]
-       dev-python/pylint[${PYTHON_USEDEP}]
-       dev-python/pep8[${PYTHON_USEDEP}]
-       dev-python/psutil[${PYTHON_USEDEP}]
-       dev-python/nbconvert[${PYTHON_USEDEP}]
-       >=dev-python/qtawesome-0.4.1[${PYTHON_USEDEP}]
-       dev-python/pickleshare[${PYTHON_USEDEP}]
-       dev-python/pyzmq[${PYTHON_USEDEP}]
-       dev-python/chardet[${PYTHON_USEDEP}]
-       >=dev-python/pycodestyle-2.3.0
-       hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )"
-DEPEND="${RDEPEND}
-       app-arch/unzip"
-
-# Courtesy of Arfrever
-PATCHES=( "${FILESDIR}"/${P}-build.patch )
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build doc doc/html || die "Generation of documentation failed"
-       fi
-}
-
-python_install() {
-       distutils-r1_python_install
-       python_newscript scripts/${PN} ${PN}${EPYTHON:6:1}
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( doc/html/. )
-       distutils-r1_python_install_all
-       doicon spyder/images/spyder.svg
-       make_desktop_entry spyder Spyder spyder "Development;IDE"
-}