dev-util/opencl-headers: install directly into /usr/include
authorMarek Szuba <marecki@gentoo.org>
Wed, 8 Apr 2020 22:18:21 +0000 (23:18 +0100)
committerMarek Szuba <marecki@gentoo.org>
Wed, 8 Apr 2020 22:52:01 +0000 (23:52 +0100)
These cannot be in /usr/lib/OpenCL/vendor/... because eselect-opencl
doesn't know how to handle unified headers, resulting in build failures
due to missing header files. Seeing as we are planning to deprecate
eselect-opencl soon anyway, adapt this and opencl-icd-loader to the new
approach so that they can be used for transition testing without
breaking the more established ICD loader i.e. ocl-icd.

Note that this WILL cause massive dependency issues until
opencl-icd-loader has been added to virtual/opencl. Use with caution.

Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild [moved from dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild with 50% similarity]

similarity index 50%
rename from dev-util/opencl-headers/opencl-headers-2020.03.13.ebuild
rename to dev-util/opencl-headers/opencl-headers-2020.03.13-r1.ebuild
index 0c64e9cc994a4127497910f722a84430bd366320..917c0cad35006de9a6198202b0e50bb84067c1aa 100644 (file)
@@ -3,8 +3,6 @@
 
 EAPI=7
 
-inherit multilib-minimal
-
 MY_PN="OpenCL-Headers"
 MY_P="${MY_PN}-${PV}"
 
@@ -16,14 +14,13 @@ LICENSE="Apache-2.0"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 
+# To avoid file collisions in /usr/include/CL/
+DEPEND="!app-eselect/eselect-opencl"
+RDEPEND="${DEPEND}"
+
 S="${WORKDIR}/${MY_P}"
 
-multilib_src_install() {
-       # Ideally we would install these directly into /usr/include but that would conflict
-       # with eselect-opencl, therefore we install these into the vendor directory used by
-       # dev-libs/opencl-icd-loader. Hopefully we will get this resolved soon and we can
-       # stop messing with multilib in this package.
-       local ocl_dir="/usr/$(get_libdir)/OpenCL/vendors/opencl-icd-loader"
-       insinto "${ocl_dir}"/include
+src_install() {
+       insinto /usr/include
        doins -r "${S}"/CL
 }