dev-python/pytest-runner: add missed dep to DEPEND, bump
authorIan Delaney <idella4@gentoo.org>
Mon, 17 Aug 2015 04:22:53 +0000 (12:22 +0800)
committerIan Delaney <idella4@gentoo.org>
Mon, 17 Aug 2015 04:23:53 +0000 (12:23 +0800)
Package-Manager: portage-2.2.20

dev-python/pytest-runner/Manifest
dev-python/pytest-runner/pytest-runner-2.1.2.ebuild
dev-python/pytest-runner/pytest-runner-2.5.1.ebuild
dev-python/pytest-runner/pytest-runner-2.6.1.ebuild [new file with mode: 0644]

index 0f833b62391241a0c5de8bbd18e977ff9db10395..335c744f85dd61d20211e9aa3f02fa9f7b4e1086 100644 (file)
@@ -1,2 +1,3 @@
 DIST pytest-runner-2.1.2.zip 5413 SHA256 544b53ade15931ad9bc74fecd897c49b2f3a9a1affc94bcbd88508548f6abbfc SHA512 ac82dfbe102fb4079c061f5700e5100713b51e3d71cb736c7956d1f5404e3ad5a44bf72b5164fde961e189819ef532a60623068e6f05b42a73bd700d056a55b8 WHIRLPOOL f0d9f5b0bc5f3e3fa9556a2b6d5b5b3297f146f14668fc35aead8b69e7bf848487bbb74035e247e52dfa4f22139566e9203e4ef8e678b8ba4e3897a36a43ff0c
 DIST pytest-runner-2.5.1.zip 11419 SHA256 9c2d1d1ab4595d5cd5eef6950e3e11ca8f1719c7504d16a111ae1f5757660a7f SHA512 daf9054b3e83cbf8b8e551208804384b689af873eadd12dc5e1e52d70511b947c6c114a5dfe53e135e0428cea993d2930430f1e71b0a6effc08f9e40ff3a48e6 WHIRLPOOL 3cfd55be0da567b00f0347e40fc81f1243dbc4c837a49fa00dbb53f3c814121f0613fae5b6096d67c68c9f2ec3d5ab1d1f0a7a703dac63d9fe1a09b4d44e7f19
+DIST pytest-runner-2.6.1.tar.gz 6343 SHA256 761c6bb1e6ffe3788f23a3b18170a4d83d1d0b29ffaff8213dbc5ff6fd41714c SHA512 5f5e96a4b8072334d93ce38a361f5f9f50f8fb67943b2da30027b7e1e8304b4d0b46d34be1f6d90c859e5d6d75c991e6848427567cca6ad979803355a0397de0 WHIRLPOOL 3c623ea889f1b7bd1bf32a5371248163a03406f7bfa152ba33f77aa7821d812d8a6f877b5ecb7472c57372d5bc548e0fdf5798ab3c87840b9a1e753ca0857d3c
index 0aea7f6f7936f37dbdd5a0e2baa05948ec401048..f565879f17829639c5ed4033c8c818e14c960adb 100644 (file)
@@ -17,7 +17,9 @@ KEYWORDS="amd64 ~arm x86"
 SLOT="0"
 IUSE=""
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+       app-arch/unzip
+       dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
 
 PATCHES=(
index 8aabe06920ada81ff9ceb9e31b03cdcd7648c8b7..bc253b645f8df05c3c26c8bd10c9930dad200698 100644 (file)
@@ -18,6 +18,7 @@ SLOT="0"
 IUSE=""
 
 DEPEND="
+       app-arch/unzip
        dev-python/setuptools[${PYTHON_USEDEP}]
        dev-python/setuptools_scm[${PYTHON_USEDEP}]"
 RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
diff --git a/dev-python/pytest-runner/pytest-runner-2.6.1.ebuild b/dev-python/pytest-runner/pytest-runner-2.6.1.ebuild
new file mode 100644 (file)
index 0000000..40d1b41
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Adds support for tests durring installation of setup.py files"
+HOMEPAGE="http://pypi.python.org/pypi/pytest-runner https://bitbucket.org/pytest-dev/pytest-runner"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools_scm[${PYTHON_USEDEP}]
+       "
+RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+
+python_compile_all() {
+       # The build by rst2html.py makes non fatal errors building index.rst
+       if use doc; then
+               rst2html.py docs/history.rst > docs/history.html
+               rst2html.py docs/index.rst > docs/index.html
+       fi
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/. )
+       distutils-r1_python_install_all
+}