dev-python/future: Use distutils_enable_sphinx
authorMichał Górny <mgorny@gentoo.org>
Wed, 20 Nov 2019 14:21:36 +0000 (15:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Mon, 25 Nov 2019 12:34:57 +0000 (13:34 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/future/future-0.18.2.ebuild

index d5b55ddea8d25e4ac4c64e70d33c243fd55c8f0e..91b1a6a29af8a1ddf965011c64d26cf68f56916d 100644 (file)
@@ -17,16 +17,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~
 IUSE="doc"
 
 distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+       dev-python/sphinx-bootstrap-theme
 
 # TODO: make numpy unconditional when it supports py3.8
-BDEPEND="
+BDEPEND+="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               $(python_gen_any_dep '
-                       dev-python/sphinx[${PYTHON_USEDEP}]
-                       dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
-               ')
-       )
        test? (
                $(python_gen_cond_dep 'dev-python/numpy[${PYTHON_USEDEP}]' \
                        python{2_7,3_{5,6,7}})
@@ -37,12 +33,6 @@ PATCHES=(
        "${FILESDIR}"/${P}-tests.patch
 )
 
-python_check_deps() {
-       use doc || return 0
-       has_version "dev-python/sphinx[${PYTHON_USEDEP}]" &&
-               has_version "dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]"
-}
-
 python_prepare_all() {
        sed -i "/'sphinx.ext.intersphinx'/d" docs/conf.py || die
        # tests requiring network access
@@ -52,10 +42,3 @@ python_prepare_all() {
 
        distutils-r1_python_prepare_all
 }
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs/ docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}