sys-power/powerstat: update live ebuild
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>
Fri, 28 Feb 2020 19:19:13 +0000 (21:19 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 3 Mar 2020 14:53:42 +0000 (16:53 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua>
Closes: https://github.com/gentoo/gentoo/pull/14798
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
sys-power/powerstat/powerstat-9999.ebuild

index d86952ed42b3312be20864eb45d921d7c61e4dc4..b3ef9d2bcb8b8083b41c5b33b7471041af482f60 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -16,8 +16,14 @@ SLOT="0"
 KEYWORDS=""
 IUSE=""
 
-# Don't compress manpages
-PATCHES=( "${FILESDIR}"/"${PN}"-0.02.17-makefile.patch )
+src_prepare() {
+       default
+
+       # Don't compress manpages
+       sed -i  -e '/install:/s/ powerstat.8.gz//' \
+               -e '/cp powerstat.8/s/.gz//' \
+               Makefile || die "sed failed"
+}
 
 src_compile() {
        emake CC="$(tc-getCC)"