dev-libs/xapian-bindings: remove older version
authorAnthony G. Basile <blueness@gentoo.org>
Thu, 23 Apr 2020 18:11:00 +0000 (14:11 -0400)
committerAnthony G. Basile <blueness@gentoo.org>
Thu, 23 Apr 2020 18:22:39 +0000 (14:22 -0400)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
dev-libs/xapian-bindings/Manifest
dev-libs/xapian-bindings/xapian-bindings-1.4.7.ebuild [deleted file]

index 650a3ab0dc266d46c6c4c84355eb88a3cef48577..5c4f450d2ee8b2668d95e4cee74666b1440c0b2f 100644 (file)
@@ -1,4 +1,3 @@
 DIST xapian-bindings-1.2.25.tar.xz 1711860 BLAKE2B 66367dbc503333c4f59da8bb5bd4885fe9678aace45365573bac8e0e8e2c712795af2021ff52de9eeabb91f65a2f0447d1963424b1ae6558be95b737d1279e98 SHA512 5d27b2ae2722409ea99a1b9e6bf3f5c61ed9195b67121c090f1533340d3b11c546014985d0989a0725b60a07b392b9705bce054495f423bd3a7c99835aa336c7
 DIST xapian-bindings-1.4.14.tar.xz 1132008 BLAKE2B 3057f8f98cfd11e82555df4b554ad1ffed793ea92bf0f077ef4a495d09250da47116d76ded0deb07621f3b14ddd7f653aa0bb19add01d88fe077e637bee21ec4 SHA512 6d35c6c011c6d841254934f4dd59f4a2b842fe826af108e526cde9acbccec67b43517974331b21cbee5e828d0743aa5b9b973a96e1940065fbcfc342b8f23ead
 DIST xapian-bindings-1.4.15.tar.xz 1132248 BLAKE2B ba9f60263881ca558f9d3deab09bd07271e6f54e06a13d09bcb59bfaf9a637e959b3a62a9e9db0724ae2262e605fc3fd2160559d53702b2af5012f47177ea66a SHA512 dec8a0431c9070fc70d79b67bddc2e0adb10ef5366c4b9d7a135365ea6c6680d2e7682dbfd60c29eca51da48eaa0715509e30b13d5482d5a38bfd0d0156c43f9
-DIST xapian-bindings-1.4.7.tar.xz 1121700 BLAKE2B f8492113b76aba322c975aa2b957a627a32e5209d8b79f435dc85c899cf14619af6165265e624e2ba8806f3c91dd35d71d98c4a47f5d6f4fba1b7fb83700c0d0 SHA512 c904cd3abf19d68495b0487ea77265fdc92a3cd8b1c2437b89034efd349ce41198bbc4abca49f259f71a1ba0fd269b2cf9b6dd4c1607678a73cbed4de9c5a1d5
diff --git a/dev-libs/xapian-bindings/xapian-bindings-1.4.7.ebuild b/dev-libs/xapian-bindings/xapian-bindings-1.4.7.ebuild
deleted file mode 100644 (file)
index 16555fe..0000000
+++ /dev/null
@@ -1,305 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-PYTHON_REQ_USE="threads(+)"
-
-USE_PHP="php5-6 php7-1 php7-2"
-
-PHP_EXT_NAME="xapian"
-PHP_EXT_INI="yes"
-PHP_EXT_OPTIONAL_USE="php"
-
-USE_RUBY="ruby22 ruby23 ruby24"
-RUBY_OPTIONAL="yes"
-
-inherit java-pkg-opt-2 mono-env multibuild php-ext-source-r3 python-r1 ruby-ng toolchain-funcs
-
-DESCRIPTION="SWIG and JNI bindings for Xapian"
-HOMEPAGE="https://www.xapian.org/"
-SRC_URI="https://oligarchy.co.uk/xapian/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~ia64 ~mips ppc ppc64 ~sparc ~x86"
-IUSE="java lua mono perl php python ruby tcl"
-REQUIRED_USE="|| ( java lua mono perl php python ruby tcl )
-       python? ( ${PYTHON_REQUIRED_USE} )
-       ruby? ( || ( $(ruby_get_use_targets) ) )"
-
-COMMONDEPEND=">=dev-libs/xapian-1.4.7:0/30
-       lua? ( dev-lang/lua:= )
-       perl? ( dev-lang/perl:= )
-       python? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               ${PYTHON_DEPS}
-       )
-       ruby? ( $(ruby_implementations_depend) )
-       tcl? ( dev-lang/tcl:= )
-       mono? ( dev-lang/mono )"
-DEPEND="${COMMONDEPEND}
-       virtual/pkgconfig
-       java? ( >=virtual/jdk-1.6 )"
-RDEPEND="${COMMONDEPEND}
-       java? ( >=virtual/jre-1.6 )"
-
-S="${WORKDIR}/${P}"
-
-has_basic_bindings() {
-       # Update this list if new bindings are added that are not built
-       # multiple times for multiple versions like php, python and ruby are
-       return $(use mono || use java || use lua || use perl || use tcl)
-}
-
-php_copy_sources() {
-       local MULTIBUILD_VARIANTS=($(php_get_slots))
-       multibuild_copy_sources
-}
-
-php_foreach_impl() {
-       local MULTIBUILD_VARIANTS=($(php_get_slots))
-       multibuild_foreach_variant "$@"
-}
-
-ruby_copy_sources() {
-       local MULTIBUILD_VARIANTS=($(ruby_get_use_implementations))
-       multibuild_copy_sources
-}
-
-ruby_foreach_impl() {
-       local MULTIBUILD_VARIANTS=($(ruby_get_use_implementations))
-       multibuild_foreach_variant "$@"
-}
-
-pkg_setup() {
-       use mono && mono-env_pkg_setup
-       use java && java-pkg-opt-2_pkg_setup
-}
-
-src_unpack() {
-       default
-
-       if use php; then
-               local php_slot
-               for php_slot in $(php_get_slots); do
-                       # Unfortunately required for php-ext-source-r3_createinifiles().
-                       mkdir "${WORKDIR}/${php_slot}"
-               done
-       fi
-}
-
-src_prepare() {
-       use java && java-pkg-opt-2_src_prepare
-
-       # https://trac.xapian.org/ticket/702
-       export XAPIAN_CONFIG="/usr/bin/xapian-config"
-
-       if use php; then
-               php_copy_sources
-       fi
-
-       if use python; then
-               python_copy_sources
-       fi
-
-       if use ruby; then
-               ruby_copy_sources
-       fi
-
-       eapply_user
-}
-
-src_configure() {
-       if has_basic_bindings ; then
-               local conf=(
-                       --disable-documentation
-                       $(use_with mono csharp)
-                       $(use_with java)
-                       $(use_with lua)
-                       $(use_with perl)
-                       $(use_with tcl)
-                       --without-php
-                       --without-php7
-                       --without-python
-                       --without-python3
-                       --without-ruby
-               )
-
-               if use java; then
-                       local -x CXXFLAGS="${CXXFLAGS} $(java-pkg_get-jni-cflags)"
-               fi
-
-               if use perl; then
-                       local -x PERL_ARCH="$(perl -MConfig -e 'print $Config{installvendorarch}')"
-                       local -x PERL_LIB="$(perl -MConfig -e 'print $Config{installvendorlib}')"
-               fi
-
-               if use lua; then
-                       local -x LUA_INC="$("$(tc-getPKG_CONFIG)" --variable=INSTALL_INC lua)"
-                       local -x LUA_LIB="$("$(tc-getPKG_CONFIG)" --variable=INSTALL_CMOD lua)"
-               fi
-
-               econf "${conf[@]}"
-       fi
-
-       php_configure() {
-               local myconf=(
-                       --disable-documentation
-                       --without-java
-                       --without-lua
-                       --without-csharp
-                       --without-perl
-                       --without-python
-                       --without-python3
-                       --without-ruby
-                       --without-tcl
-               )
-               if [[ ${MULTIBUILD_VARIANT} == php5.* ]]; then
-                       myconf+=(
-                               --with-php
-                               --without-php7
-                       )
-                       local -x PHP_CONFIG="${EPREFIX}/usr/$(get_libdir)/${MULTIBUILD_VARIANT/-/.}/bin/php-config"
-               elif [[ ${MULTIBUILD_VARIANT} == php7.* ]]; then
-                       myconf+=(
-                               --without-php
-                               --with-php7
-                       )
-                       local -x PHP_CONFIG7="${EPREFIX}/usr/$(get_libdir)/${MULTIBUILD_VARIANT/-/.}/bin/php-config"
-               fi
-
-               econf "${myconf[@]}"
-       }
-
-       if use php; then
-               addpredict /usr/share/snmp/mibs/.index
-               addpredict /var/lib/net-snmp/mib_indexes
-
-               php_foreach_impl run_in_build_dir php_configure
-       fi
-
-       python_configure() {
-               local myconf=(
-                       --disable-documentation
-                       --without-java
-                       --without-lua
-                       --without-csharp
-                       --without-perl
-                       --without-php
-                       --without-php7
-                       --without-ruby
-                       --without-tcl
-               )
-               if python_is_python3; then
-                       myconf+=( --with-python3 )
-               else
-                       myconf+=( --with-python )
-               fi
-
-               # Avoid sandbox failures when compiling modules
-               addpredict "$(python_get_sitedir)"
-
-               econf "${myconf[@]}"
-       }
-
-       if use python; then
-               python_foreach_impl run_in_build_dir python_configure
-       fi
-
-       ruby_configure() {
-               local myconf=(
-                       --disable-documentation
-                       --without-java
-                       --without-lua
-                       --without-csharp
-                       --without-perl
-                       --without-php
-                       --without-php7
-                       --without-python
-                       --without-python3
-                       --with-ruby
-                       --without-tcl
-               )
-               local -x RUBY="${EPREFIX}/usr/bin/${MULTIBUILD_VARIANT}"
-
-               econf "${myconf[@]}"
-       }
-
-       if use ruby; then
-               ruby_foreach_impl run_in_build_dir ruby_configure
-       fi
-}
-
-src_compile() {
-       if has_basic_bindings ; then
-               default
-       fi
-
-       if use php; then
-               php_foreach_impl run_in_build_dir emake
-       fi
-
-       if use python; then
-               unset PYTHONDONTWRITEBYTECODE
-               python_foreach_impl run_in_build_dir emake
-       fi
-
-       if use ruby; then
-               ruby_foreach_impl run_in_build_dir emake
-       fi
-}
-
-src_test() {
-       if has_basic_bindings ; then
-               default
-       fi
-
-       if use php; then
-               php_foreach_impl run_in_build_dir emake check
-       fi
-
-       if use python; then
-               python_foreach_impl run_in_build_dir emake check
-       fi
-
-       if use ruby; then
-               ruby_foreach_impl run_in_build_dir emake check
-       fi
-}
-
-src_install() {
-       if has_basic_bindings ; then
-               emake DESTDIR="${D}" install
-       fi
-
-       if use java; then
-               java-pkg_dojar java/built/xapian.jar
-               # TODO: make the build system not install this...
-               java-pkg_doso java/.libs/libxapian_jni.so
-               rm -rf "${D}var" || die "could not remove java cruft!"
-       fi
-
-       if use php; then
-               php_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
-               php-ext-source-r3_createinifiles
-               # php-ext-source-r3_createinifiles() changes current directory.
-               cd "${S}"
-       fi
-
-       if use python; then
-               python_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
-       fi
-
-       if use ruby; then
-               ruby_foreach_impl run_in_build_dir emake DESTDIR="${D}" install
-       fi
-
-       # For some USE combinations this directory is not created
-       if [[ -d "${D}/usr/share/doc/xapian-bindings" ]]; then
-               mv "${D}/usr/share/doc/xapian-bindings" "${D}/usr/share/doc/${PF}" || die
-       fi
-
-       dodoc AUTHORS HACKING NEWS TODO README
-}