too many issues; punt
authorMike Frysinger <vapier@gentoo.org>
Wed, 24 Jan 2007 04:49:16 +0000 (04:49 +0000)
committerMike Frysinger <vapier@gentoo.org>
Wed, 24 Jan 2007 04:49:16 +0000 (04:49 +0000)
dev-lang/cm3/ChangeLog [deleted file]
dev-lang/cm3/Manifest [deleted file]
dev-lang/cm3/cm3-5.2.6.ebuild [deleted file]
dev-lang/cm3/cm3-5.2.7_pre050331.ebuild [deleted file]
dev-lang/cm3/files/05cm3 [deleted file]
dev-lang/cm3/files/cm3.cfg [deleted file]
dev-lang/cm3/files/digest-cm3-5.2.6 [deleted file]
dev-lang/cm3/files/digest-cm3-5.2.7_pre050331 [deleted file]
dev-lang/cm3/files/m3build [deleted file]
dev-lang/cm3/files/m3ship [deleted file]
dev-lang/cm3/metadata.xml [deleted file]

diff --git a/dev-lang/cm3/ChangeLog b/dev-lang/cm3/ChangeLog
deleted file mode 100644 (file)
index 3dab57c..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-# ChangeLog for dev-lang/cm3
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/ChangeLog,v 1.5 2005/04/02 04:30:42 vapier Exp $
-
-*cm3-5.2.7_pre050331 (02 Apr 2005)
-
-  02 Apr 2005; Mike Frysinger <vapier@gentoo.org>
-  +cm3-5.2.7_pre050331.ebuild:
-  Version bump #81798 by Stefan Sperling.
-
-*cm3-5.2.6 (17 Jul 2003)
-
-  17 Jul 2003; Mike Frysinger <vapier@gentoo.org> :
-  Version bump !  glibc-2.3.x errno fixes + ppc support :D
-
-*cm3-5.2.4 (17 Apr 2003)
-
-  30 Apr 2003; Mike Frysinger <vapier@gentoo.org> :
-  mmm should be all set now ... src_install has been all fleshed out
-
-  17 Apr 2003; Mike Frysinger <vapier@gentoo.org> :
-  Initial import.  Ebuild submitted by me.
-  It is incomplete though ... i dont use m3, i cant really test it ;)
diff --git a/dev-lang/cm3/Manifest b/dev-lang/cm3/Manifest
deleted file mode 100644 (file)
index 138eb15..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-MD5 265b1d9d60328bc587974b87989bd4fd ChangeLog 808
-MD5 4a92760230ce87e45653db9797a26de6 metadata.xml 1943
-MD5 ccab8b43f06a258e11ba91e58572d8ff cm3-5.2.7_pre050331.ebuild 1919
-MD5 873b1d73ec7a62d2f694a9c6fcabc70e cm3-5.2.6.ebuild 2324
-MD5 a071e91cf56b602fba2b046c25fa0826 files/05cm3 26
-MD5 b59e89e23c56831be2c1552870f15afb files/cm3.cfg 13025
-MD5 288b8f9b71b91ebd331a54a79abcfcd0 files/m3build 33
-MD5 6013cd456a4381ba3abd48bddba25305 files/digest-cm3-5.2.6 68
-MD5 697094d1f2a7219c52ebdd86dfbd9a8b files/m3ship 32
-MD5 65b3003c4f6af3ee0d2e3e9f4dd00c90 files/digest-cm3-5.2.7_pre050331 80
diff --git a/dev-lang/cm3/cm3-5.2.6.ebuild b/dev-lang/cm3/cm3-5.2.6.ebuild
deleted file mode 100644 (file)
index 9a633d9..0000000
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/cm3-5.2.6.ebuild,v 1.9 2004/07/11 15:43:51 vapier Exp $
-
-inherit fixheadtails
-
-DESCRIPTION="Critical Mass Modula-3 compiler"
-HOMEPAGE="http://www.elegosoft.com/cm3/"
-SRC_URI="http://www.elegosoft.com/cm3/${PN}-src-all-${PV}.tgz"
-
-LICENSE="CMASS-M3 DEC-M3"
-SLOT="0"
-KEYWORDS="x86 ppc"
-IUSE="tcltk"
-
-RDEPEND="tcltk? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
-       sys-devel/gcc
-       dev-lang/cm3-bin"
-PROVIDE="virtual/m3"
-
-S=${WORKDIR}
-
-src_unpack() {
-       unpack ${A}
-       cd ${S}
-       ht_fix_file \
-               m3-comm/rdwr/test/john/src/Main.m3 \
-               m3-demo/mentor/src/unionfind/junoLogs/reorder \
-               m3-sys/m3cc/gcc/config.guess--cfl \
-               m3-sys/m3cc/gcc/configure \
-               m3-sys/m3cc/gcc/configure--cfl \
-               m3-sys/m3cc/gcc/contrib/test_summary \
-               m3-sys/m3cc/gcc/gcc/configure \
-               m3-sys/m3cc/gcc/gcc/configure--cfl \
-               m3-sys/m3cc/gcc/gcc/configure.in \
-               m3-sys/m3cc/gcc/ltcf-c.sh \
-               m3-sys/m3cc/gcc/ltcf-gcj.sh \
-               m3-sys/m3gdb/gdb/configure \
-               m3-sys/m3tests/src/m3makefile \
-               scripts/pkginfo.sh
-}
-
-setup_env() {
-       export GCC_BACKEND="yes"
-       export M3GDB="no"
-       export HAVE_SERIAL="no"
-       unset M3GC_SIMPLE
-       use tcltk \
-               && HAVE_TCL="yes" \
-               || HAVE_TCL="no"
-}
-
-src_compile() {
-       setup_env
-       cd scripts
-       for s in do-cm3-core do-cm3-base ; do
-               env -u P ROOT=${S} ./${s}.sh build || die "building ${s}"
-       done
-}
-
-src_install() {
-       setup_env
-       local TARGET=`grep 'TARGET.*=' /usr/bin/cm3.cfg | awk '{print $4}' | sed 's:"::g'`
-       sed -i "s:\"/usr/lib/cm3/:\"${D}/usr/lib/cm3/:g" `find -name .M3SHIP` || die "fixing .M3SHIP"
-
-       cd scripts
-       dodir /usr/lib/cm3
-       for s in do-cm3-core do-cm3-base ; do
-               env -u P ROOT=${S} ./${s}.sh ship || die "shipping ${s}"
-       done
-       cd ${D}/usr/lib/cm3/pkg
-       sed -i "s:${S}/*[^/-]*-[^/\"]*:/usr/lib/cm3/pkg:" `grep -RIl ${PORTAGE_TMPDIR}/portage *` || die "fixing .M3EXPORTS"
-
-       # do all this crazy linking so as to overwrite cm3-bin stuff
-       dodir /usr/bin
-       insinto /usr/lib/cm3/bin
-       doins /usr/bin/cm3.cfg
-       dosym /usr/lib/cm3/pkg/cm3/${TARGET}/cm3 /usr/lib/cm3/bin/cm3
-       dosym /usr/lib/cm3/bin/cm3 /usr/bin/cm3
-       dosym /usr/lib/cm3/bin/cm3cg /usr/bin/cm3cg
-       dosym /usr/lib/cm3/bin/cm3.cfg /usr/bin/cm3.cfg
-       dobin ${FILESDIR}/m3{build,ship}
-
-       insinto /etc/env.d
-       doins ${FILESDIR}/05cm3
-}
diff --git a/dev-lang/cm3/cm3-5.2.7_pre050331.ebuild b/dev-lang/cm3/cm3-5.2.7_pre050331.ebuild
deleted file mode 100644 (file)
index df6873f..0000000
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/cm3/cm3-5.2.7_pre050331.ebuild,v 1.2 2005/04/02 04:45:42 vapier Exp $
-
-inherit fixheadtails
-
-STAMP=${PV/*_pre}
-MY_PV=${PV/_pre*}-20${STAMP:0:2}-${STAMP:2:2}-${STAMP:4:2}
-DESCRIPTION="Critical Mass Modula-3 compiler"
-HOMEPAGE="http://www.elegosoft.com/cm3/"
-SRC_URI="http://www.elegosoft.com/cm3/${PN}-src-all-d${MY_PV}.tgz"
-
-LICENSE="CMASS-M3 DEC-M3"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="tcltk"
-
-RDEPEND="tcltk? ( dev-lang/tcl )"
-DEPEND="${RDEPEND}
-       sys-devel/gcc
-       >=dev-lang/cm3-bin-${PV}"
-PROVIDE="virtual/m3"
-
-S=${WORKDIR}
-
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
-       ht_fix_all
-}
-
-setup_env() {
-       export GCC_BACKEND="yes"
-       export M3GDB="no"
-       export HAVE_SERIAL="no"
-       unset M3GC_SIMPLE
-       use tcltk \
-               && HAVE_TCL="yes" \
-               || HAVE_TCL="no"
-}
-
-src_compile() {
-       setup_env
-       cd scripts
-       for s in do-cm3-core do-cm3-base ; do
-               env -u P ROOT="${S}" ./${s}.sh build || die "building ${s}"
-       done
-}
-
-src_install() {
-       setup_env
-       local TARGET=`grep 'TARGET.*=' /usr/bin/cm3.cfg | awk '{print $4}' | sed 's:"::g'`
-       sed -i "s:\"/usr/lib/cm3/:\"${D}/usr/lib/cm3/:g" `find -name .M3SHIP` || die "fixing .M3SHIP"
-
-       cd scripts
-       dodir /usr/lib/cm3
-       for s in do-cm3-core do-cm3-base ; do
-               env -u P ROOT="${S}" ./${s}.sh ship || die "shipping ${s}"
-       done
-       cd "${D}"/usr/lib/cm3/pkg
-       sed -i "s:${S}/*[^/-]*-[^/\"]*:/usr/lib/cm3/pkg:" `grep -RIl ${PORTAGE_TMPDIR}/portage *` || die "fixing .M3EXPORTS"
-
-       # do all this crazy linking so as to overwrite cm3-bin stuff
-       dodir /usr/bin
-       insinto /usr/lib/cm3/bin
-       doins /usr/bin/cm3.cfg
-       dosym /usr/lib/cm3/pkg/cm3/${TARGET}/cm3 /usr/lib/cm3/bin/cm3
-       dosym /usr/lib/cm3/bin/cm3 /usr/bin/cm3
-       dosym /usr/lib/cm3/bin/cm3cg /usr/bin/cm3cg
-       dosym /usr/lib/cm3/bin/cm3.cfg /usr/bin/cm3.cfg
-       dobin "${FILESDIR}"/m3{build,ship}
-
-       doenvd "${FILESDIR}"/05cm3
-}
diff --git a/dev-lang/cm3/files/05cm3 b/dev-lang/cm3/files/05cm3
deleted file mode 100644 (file)
index af1b2d9..0000000
+++ /dev/null
@@ -1 +0,0 @@
-LDPATH="/usr/lib/cm3/lib"
diff --git a/dev-lang/cm3/files/cm3.cfg b/dev-lang/cm3/files/cm3.cfg
deleted file mode 100644 (file)
index bbe323e..0000000
+++ /dev/null
@@ -1,351 +0,0 @@
-% Copyright 1996 Critical Mass, Inc. All rights reserved.
-% 
-% Standard configuration file for LINUX with ELF object files
-%
-
-%-------------------------------------------------- compilation environment ---
-
-%M3_PROFILING = TRUE  % set by cm3 since 5.1.2 (option -profile)
-%M3_PROFILING = FALSE
-
-readonly TARGET       = "LINUXLIBC6"      % code generation target
-if M3_PROFILING 
-  readonly BUILD_DIR  = TARGET & "p"      % code generation target
-else
-  readonly BUILD_DIR  = TARGET            % directory for results
-end
-readonly OS_TYPE      = "POSIX"           % { "WIN32" or "POSIX" }
-readonly WORD_SIZE    = "32BITS"          % { "32BITS" or "64BITS" }
-readonly GNU_PLATFORM = "i486--linuxelf"  % "cpu-vendor-os" string for GNU
-%readonly INSTALL_KEY  = BEGIN_CONFIG
-%  "What is your installation key?"
-%    14 %-- user specified key
-%END_CONFIG
-
-readonly NAMING_CONVENTIONS = "0"
-%                                        object files       libraries
-%  0=Unix                          =>  .o   .io    .mo       libXX.a
-%  1=Unix with a grumpy C compiler =>  .o   _i.o   _m.o      libXX.a
-%  2=Windows NT or Windows 95      =>  .obj .io    .mo       XX.lib
-%
-
-%-------------------------------------------------- default compile options ---
-% "set_config_options" is called before starting the compilation.  It should
-% be used to provide system-wide default options.
-
-proc set_config_options () is
-  m3_option ("-why")   %-- produce a listing that explains what's happening and why
-  m3_debug (TRUE)      %-- produce object code with debugging symbols
-  M3_OPTIONS += "-w1"  %-- produce "level 1" warnings
-end
-
-%--------------------------------------------------------- Reactor defaults ---
-% The first time a user runs Reactor, it will configure itself to use
-% the executables defined below.
-
-%INITIAL_REACTOR_BROWSER = BEGIN_CONFIG
-%  "What should be the default World-Wide Web browser for new Reactor users?"
-%     0  "netscape"
-%     6 "/usr/local/bin"           "netscape"
-%     6 "/usr/local/netscape/bin"  "netscape"
-%     6 "/usr/local/netscape/bin"  "netscape-3"
-%     6 "/usr/local/netscape/bin"  "netscape-2"
-%     6 "/usr/local/netscape"      "netscape"
-%     6 "/usr/local/mosaic"        "mosaic"
-%     6 "/usr/local/moasic"        "Xmosaic"
-%END_CONFIG
-% A World-Wide Web browser.  Reactor passes it an initial URL
-% its first command-line argument.
-
-INITIAL_REACTOR_EDITOR = "GENTOO_INITIAL_REACTOR_EDITOR"
-% A text editor.  Reactor passes it "<file> +<line>" on the
-% command-line when it wants to edit <file> initially positioned
-% at <line>.
-
-%------------------------------------------------------------- export paths ---
-% During the installation, destination directories that do not exists 
-% will be created. You need the necessary permissions to do so; otherwise,
-% the installation will fail, but can be restarted after you have 
-% fixed the permissions.
-
-INSTALL_ROOT = "GENTOO_INSTALL_ROOT"
-
-BIN_INSTALL   = INSTALL_ROOT & "/bin"        % executables
-if M3_PROFILING 
-  LIB_INSTALL   = INSTALL_ROOT & "/libp"       % libraries
-else
-  LIB_INSTALL   = INSTALL_ROOT & "/lib"        % libraries
-end
-PKG_INSTALL   = INSTALL_ROOT & "/pkg"        % packages
-DOC_INSTALL   = INSTALL_ROOT & "/doc"        % documents
-EMACS_INSTALL = INSTALL_ROOT & "/elisp"      % emacs lisp code
-MAN_INSTALL   = INSTALL_ROOT & "/man"        % man pages
-HTML_INSTALL  = INSTALL_ROOT & "/www"        % public hypertext
-
-% On some systems (e.g. AFS) you must install public files in a different
-% place from where you use them.  If that is the case for your system,
-% specify the "use" location here, otherwise leave them alone.
-%
-USE_ROOT  = INSTALL_ROOT
-BIN_USE   = BIN_INSTALL       % executables
-LIB_USE   = LIB_INSTALL       % libraries
-PKG_USE   = PKG_INSTALL       % packages
-
-readonly INSTALL_IMPLS = TRUE
-% TRUE
-%    => save all source files during the install
-%    => makes debugging easier and browsing more fruitful
-% FALSE
-%    => save only the exported interfaces and templates 
-%    => makes the installed system slightly smaller.
-
-%------------------------------------------------ external system libraries ---
-% SYSTEM_LIBS provides a mapping from Modula-3 names for the common
-% external libraries to site-dependent information about how they
-% are accessed.  If SYSTEM_LIBS{x} is defined it should be a list
-% of linker arguments that are used when linking against that library.
-% If SYSTEM_LIBS{x} is not defined, the Modula-3 system will assume
-% that the library is not available.
-
-SYSTEM_LIBS = {
-  "LIBC"       : [ "-lm" ],
-%-- not on most Linux platforms
-% "LEX-YACC"   : [ BEGIN_CONFIG
-%                    "Where are the lex/yacc libraries?"
-%                      11 "libl.a"
-%                      12 "/usr/lib"
-%                      12 "/usr/local/lib"
-%                      12 "/usr/local/gnu/lib"
-%                      13 "/usr/lib"
-%                  END_CONFIG, "-ll" ],
-  "FLEX-BISON" : [ "-L/usr/lib", "-lfl" ],
-%  "POSTGRES95" : [ BEGIN_CONFIG
-%  "OPENGL"     : [ BEGIN_CONFIG
-%  "ODBC"       : [ BEGIN_CONFIG
-%  "MOTIF"      : [ BEGIN_CONFIG
-%  "X11"        : [ BEGIN_CONFIG
-  "TCP"        : [ ]
-}
-
-% SYSTEM_LIBORDER defines the order in which SYSTEM_LIBS should be
-% scanned by the linker.
-
-SYSTEM_LIBORDER = [ "OPENGL", "DECPEX", "MOTIF", "X11", "TCP", "ODBC",
-                    "POSTGRES95", "FLEX-BISON", "LEX-YACC", "LIBC" ]
-
-%---------------------------------------------------------- system programs ---
-
-readonly SYSTEM_CC  = "/usr/bin/gcc" % C compiler
-readonly SYSTEM_AR  = "/usr/bin/ar" % Archiver
-readonly SYSTEM_ASM = "/usr/bin/as" % Assembler
-
-%--------------------------------------------------------- Modula-3 backend ---
-% For platforms without an integrated backend, "m3_backend" is called to
-% translate Modula-3 intermediate code to object code.
-
-readonly m3back = "@" & BIN_USE & "/cm3cg"
-
-proc m3_backend (source, object, optimize, debug) is
-  local args = [ "-quiet", source, "-o", object ]
-  if optimize  args += "-O"  end
-  if debug     args += "-g"  end
-  if M3_PROFILING args += "-p" end
-  return try_exec (m3back, args)
-end
-
-M3_BACKEND_MODE = "3"
-% -- defines how the frontend, backend, and assembler interact
-%  "0"  -- don't call m3_backend, M3CG produces object code
-%  "1"  -- don't call m3_backend, M3CG produces assembly code
-%  "2"  -- call m3_backend, it produces object code
-%  "3"  -- call m3_backend, it produces assembly code
-
-%--------------------------------------------------------------- C compiler ---
-% "compile_c" is called to compile C source files.  Note that this function
-% is only called if your program or library explicitly includes C source
-% code, the system distributed by Critical Mass does not.
-
-proc compile_c (source, object, options, optimize, debug) is
-  local args = [ "-fPIC", options ]
-  if optimize  args += "-O"  end
-  if debug     args += "-g"  end
-  if M3_PROFILING args += "-pg" end
-  return try_exec ("@" & SYSTEM_CC, args, "-c", source)
-end
-
-%---------------------------------------------------------------- assembler ---
-% "assemble" is called to assemble .s or .asm files.  Note that this function
-% is only called if your program or library explicitly includes assembly source
-% code, the system distributed by Critical Mass does not.
-
-proc assemble (source, object) is
-  return try_exec ("@" & SYSTEM_ASM, source, "-o", object)
-end
-
-%--------------------------------------------------------- library creation ---
-% "make_lib" is called to combine a collection of object modules into
-% a library.
-
-GCWRAPFLAGS = "-Wl,--wrap,adjtime,--wrap,getdirentries,--wrap,readv,--wrap,utimes,--wrap,wait3"
-
-proc make_lib (lib, options, objects, imported_libs, shared) is
-  local ret_code = 0
-  local lib_a    = format ("lib%s.a", lib)
-  local lib_so   = format ("lib%s.so", lib)
-  local lib_sox  = format ("lib%s.so.5", lib)
-
-  % first, build the non-shared library
-  ret_code = try_exec ("@/usr/bin/ar", "crus", lib_a, objects)
-  if not equal (ret_code, 0) return ret_code end
-
-  if shared
-    % build the shared library
-    if M3_PROFILING 
-      ret_code = try_exec ("@" & SYSTEM_CC, "-pg -shared " & GCWRAPFLAGS & 
-                           "-Wl,-soname," & lib_sox,
-                           "-o", lib_sox, objects)
-    else
-      ret_code = try_exec ("@" & SYSTEM_CC, "-shared " & GCWRAPFLAGS & 
-                           "-Wl,-soname," & lib_sox,
-                           "-o", lib_sox, objects)
-    end
-    if not equal (ret_code, 0) return ret_code end
-
-    % create the version aliases
-    link_file(lib_sox, lib_so)
-
-    % finally, make sure the shared library stuff gets installed properly
-    install_derived (lib_sox)
-    install_derived_link (lib_sox, lib_so)
-    install_link_to_derived (lib_sox, LIB_INSTALL)
-    install_link_to_derived (lib_so, LIB_INSTALL)
-  else
-    delete_file (lib_so)
-    delete_file (lib_sox)
-  end
-
-  return 0
-end
-
-%-------------------------------------------------------------------
-% "skip_lib" is called when the compiler decides it doesn't need to
-% call "make_lib", but it wants to discover the names of the derived
-% files that should be deleted or shipped.
-
-proc skip_lib (lib, shared) is
-  local lib_so   = format ("lib%s.so", lib)
-  local lib_sox  = format ("lib%s.so.5", lib)
-
-  if shared
-    % make sure the shared library stuff gets installed properly
-    install_derived (lib_sox)
-    install_derived (lib_so)
-    install_link_to_derived (lib_sox, LIB_INSTALL)
-    install_link_to_derived (lib_so, LIB_INSTALL)
-  else
-    delete_file (lib_so)
-    delete_file (lib_sox)
-  end
-
-  return 0
-end
-
-%------------------------------------------------------------------- linker ---
-% "m3_link" is called to produce a final executable.
-%---  "-pdb:none" enables the use of windbg with the resulting executable.
-
-proc m3_link (prog, options, objects, imported_libs, shared) is
-  local args = []
-  if M3_PROFILING args += "-pg" end
-  args += [ "-o", prog, options, objects, imported_libs ]
-  if shared
-    return try_exec ("@" & SYSTEM_CC, args, GCWRAPFLAGS)
-  else
-    return try_exec ("@" & SYSTEM_CC, "-static", args, GCWRAPFLAGS)
-    %%% -- see M3_NEED_STANDALONE_LINKS  below
-    %%%return try_exec ("@" & SYSTEM_CC, args)
-  end
-end
-
-%-------------------------------------------------------------------
-% "skip_link" is called when the compiler decides it doesn't need to
-% call "m3_link", but it wants to discover the names of the derived
-% files that should be deleted or shipped.
-
-proc skip_link (prog, shared) is
-  return 0
-end
-
-%------------------------------------------------------------ misc. options ---
-% Note, most of these options can be set from the command line.  Otherwise,
-% they can be set "permanently" here in the config file or in as needed
-% in user's m3makefiles.
-
-M3_FRONT_FLAGS = [ ]
-% --- internal configuration options passed directly to the Modula-3 front-end
-
-M3_OPTIONS = [ ]
-% --- user options passed directly to the Modula-3 front-end
-
-% M3_KEEP_FILES = TRUE
-% --- keep intermediate and temporary files
-
-M3_WINDOWS_GUI = FALSE
-% --- generate a Windows GUI subsystem program instead of a console one.
-
-% M3_COVERAGE = TRUE
-% --- compile & link with coverage options
-
-M3_COVERAGE_LIB = LIB_USE & "/report_coverage.o"
-% --- library linked in programs compiled with "-Z" coverage option
-
-M3_SPLIT_LIBNAMES = TRUE
-% --- split library names and pass -L/-l arguments to the linker
-
-M3_SHARED_LIB_ARG = "-Wl,-R"
-% --- pass "-R" flags to the linker too...
-
-% M3_BOOTSTRAP = TRUE
-% --- generate bootstrap code (assembly) instead of finaly object code
-
-% M3_COMPILE_ONCE = TRUE
-% --- don't recompile code to improve opaque object references
-
-% SYS_HAS_LOADER = TRUE
-% --- generate a loader info file with objects, libraries and timestamps
-
-% M3_SKIP_LINK = TRUE
-% --- skip the final link for programs, presumably to use the loader instead
-
-% M3_MAIN_IN_C = TRUE
-% --- generate the Modula-3 main program as C code
-
-% X11_WITH_SHARED_MEM = TRUE
-% --- X11 libraries include the shared memory extensions (XShm...)
-
-%M3_NEED_STANDALONE_LINKS = TRUE
-% --- linker is broken and we need to build a directory of symbolic
-%     links pointing to the non-shared libraries.
-
-%-------------------------------------------------------------------- emacs ---
-% If you have emacs and want to compile ".el" files to ".elc" files,
-% fill in the function below.  Otherwise, comment out or delete the
-% entire function.  Note, the distributed code assumes gnuemacs version 19
-% or later.
-
-%readonly proc emacs_compile (el) is
-%  exec ("emacs -batch -f batch-byte-compile", el)
-%end
-
-%------------------------------------------------------------- GNU variants ---
-% The two large pieces of GNU software used by the Modula-3 system
-% gcc(=m3cc) and gdb(=m3gdb) often require slightly different C compilers
-% or flags.  They are specified here.  Note that they may be overridden
-% from the m3build command line.
-%
-% To use the GNU defaults for CC and CFLAGS, specify "*".
-%
-
-GNU_CC     = "GENTOO_GNU_CC"
-GNU_CFLAGS = "GENTOO_GNU_CFLAGS"
-GNU_MAKE   = "GENTOO_GNU_MAKE"
diff --git a/dev-lang/cm3/files/digest-cm3-5.2.6 b/dev-lang/cm3/files/digest-cm3-5.2.6
deleted file mode 100644 (file)
index 12093fd..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 44fd8c9c905707e4f9835eaf6b747127 cm3-src-all-5.2.6.tgz 30410022
diff --git a/dev-lang/cm3/files/digest-cm3-5.2.7_pre050331 b/dev-lang/cm3/files/digest-cm3-5.2.7_pre050331
deleted file mode 100644 (file)
index 77c8f35..0000000
+++ /dev/null
@@ -1 +0,0 @@
-MD5 be989b4fb3f1d1a6a9a6de9d8e64a512 cm3-src-all-d5.2.7-2005-03-31.tgz 33069086
diff --git a/dev-lang/cm3/files/m3build b/dev-lang/cm3/files/m3build
deleted file mode 100644 (file)
index 6c0b9cd..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/bash
-exec cm3 -build "$@"
diff --git a/dev-lang/cm3/files/m3ship b/dev-lang/cm3/files/m3ship
deleted file mode 100644 (file)
index 01edd3e..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/bash
-exec cm3 -ship "$@"
diff --git a/dev-lang/cm3/metadata.xml b/dev-lang/cm3/metadata.xml
deleted file mode 100644 (file)
index a6d9038..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<herd>no-herd</herd>
-<maintainer>
-  <email>vapier@gentoo.org</email>
-  <name>Mike Frysinger</name>
-</maintainer>
-<longdescription>
- Critical Mass Modula-3 5.1 (CM3) is the latest release of the Modula-3 compiler 
-produced by Critical Mass, which contains considerable enhancements to the 
-compiler, run-time system, and core libraries, which have not been publicly 
-available so far. The changes made by Critical Mass, Inc. since their CM3 4.1 
-release include:
-
-    * Modula-3 modules loadable at runtime
-    * *IMPLICIT* exceptions (changes language semantics)
-    * checked runtime errors are mapped to the implicit exception RuntimeError.E
-    * garbage collector failures are also mapped to implicit exceptions
-    * COM-compatible object layout (for WIN32)
-    * Unicode support: WIDECHAR, Text, Text8, Text16, Unicode interfaces
-    * extended ASSERT pragma:
-      *ASSERT condition [ ("," | WITH) msg ] *
-    * new DEBUG pragma:
-      *DEBUG condition [ ("," | WITH) msg {, msg} ] *
-      *DEBUG [ msg {, msg } ] *
-    * 64 bit support for 64 bit machines
-
-There have been many more changes, and the 4.1 release also contained lots of 
-improvements compared to the SRC release, for example support for DLL generation 
-on Win32, much easier configuration procedure, binary installation (and 
-installer), reorganization and speedup of the builder etc.
-
-For the first free release of CM3, Elego Software Solutions has added the 
-following changes:
-
-    * new gcc backend based on gcc 2.95.2
-    * updated/added runtime support for platforms FreeBSD2, FreeBSD3, FreeBSD4, 
-LINUXLIBC6, and SOLgnu
-    * minimal binary installation packages for Win32, Linux, FreeBSD, and SOLgnu
-    * scripts for m3 package handling, system booting, installation, and 
-distribution archive creation
-</longdescription>
-</pkgmetadata>