dev-cpp/glibmm: bump to 2.62.0
authorMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 12:24:16 +0000 (14:24 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 12:24:31 +0000 (14:24 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-cpp/glibmm/Manifest
dev-cpp/glibmm/glibmm-2.62.0.ebuild [new file with mode: 0644]

index 32e978416769c1be1ed1e1fd5dffb964ce2115b3..95fe75556921c27d2b6af587b4e61d0f24cf7780 100644 (file)
@@ -1 +1,2 @@
 DIST glibmm-2.60.1.tar.xz 7132072 BLAKE2B 8d25287b7805d7196bffa909447db0e0fa0edd1c243b3ccdef91f1a6573ea0723cda8e88993e878e6c8440b23488b0ab8c9ed727bd4e2d4a46f56ba251510aa0 SHA512 89f1d10bd9b60232519e2e13c02b0b1010dacbe67a8bab06c3a5873649e5090ed3593d518bfd8e12933a08aaa5fc654b1475efc208e2256c7efd197274a28b79
+DIST glibmm-2.62.0.tar.xz 7398144 BLAKE2B a289c2e6a5737d9fa3d507e4741c1d19e949244db5a6eaec2329bda92e7e0a78e33acf9668ced19a52507fa88531da63fa35cf59dfb44ad2a7a8fa0839c7dae4 SHA512 f26fca5724c17d915480556b6918ae6e4999c14a25e7623cda3d37a59d6965310fc2b2d8a8500a849f1d0f00fd2d326eeddc690207846d38a13ae695ad0805de
diff --git a/dev-cpp/glibmm/glibmm-2.62.0.ebuild b/dev-cpp/glibmm/glibmm-2.62.0.ebuild
new file mode 100644 (file)
index 0000000..e960ee6
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ interface for glib2"
+HOMEPAGE="https://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+ GPL-2+" # GPL-2+ applies only to the build system
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="doc debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/libsigc++-2.9.1:2[${MULTILIB_USEDEP}]
+       >=dev-libs/glib-2.61.2:2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       doc? ( app-doc/doxygen )
+"
+# dev-cpp/mm-common needed for eautoreconf
+
+src_prepare() {
+       if ! use test; then
+               # don't waste time building tests
+               sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' \
+                       -i Makefile.am Makefile.in || die "sed 1 failed"
+       fi
+
+       # don't build examples - we want to install example sources, not binaries
+       sed 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+               -i Makefile.am Makefile.in || die "sed 2 failed"
+
+       gnome2_src_prepare
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" gnome2_src_configure \
+               $(use_enable debug debug-refcounting) \
+               $(multilib_native_use_enable doc documentation) \
+               --enable-deprecated-api
+}
+
+multilib_src_test() {
+       cd tests
+       default
+
+       for i in */test; do
+               ${i} || die "Running tests failed at ${i}"
+       done
+}
+
+multilib_src_install() {
+       gnome2_src_install
+}
+
+multilib_src_install_all() {
+       einstalldocs
+
+       find examples -type d -name '.deps' -exec rm -rf {} \; 2>/dev/null
+       find examples -type f -name 'Makefile*' -exec rm -f {} \; 2>/dev/null
+       dodoc -r examples
+}