dev-python/pkginfo: version bump to 1.4.2
authorTim Harder <radhermit@gentoo.org>
Sat, 24 Mar 2018 07:45:59 +0000 (03:45 -0400)
committerTim Harder <radhermit@gentoo.org>
Sat, 24 Mar 2018 07:58:25 +0000 (03:58 -0400)
dev-python/pkginfo/Manifest
dev-python/pkginfo/pkginfo-1.4.2.ebuild [new file with mode: 0644]

index 0e770c9b936f2dac858f61140469d09970cda53d..0968a82b87f1d7b162ac716307454e48a54baf12 100644 (file)
@@ -1 +1,2 @@
 DIST pkginfo-1.2.1.tar.gz 31072 BLAKE2B 57ce5f6147b97af513dfdc6137180e5561822096cdbd21b673c49522384622c58f9eba8c65f24b54bc1e76dc0c6feede5d43e8aac945d94ffe79ea220e830470 SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a
+DIST pkginfo-1.4.2.tar.gz 33539 BLAKE2B d3cfc6bf7a9e748902b1f63434c745d8abf4e144c0a2b5d7a90236bfc2ce7f94922b0e08e5a08b13ba2025159bd90fecee25d9abdb283e7d52de0d34386aba59 SHA512 536628a2a2472e999695a115449a76f971453aea7ac3a08f10d9b08dfdf4a7b8e67c6010c6f18d300472a6afc8dff33331c955cc2f7bdb357504cd6a36390da3
diff --git a/dev-python/pkginfo/pkginfo-1.4.2.ebuild b/dev-python/pkginfo/pkginfo-1.4.2.ebuild
new file mode 100644 (file)
index 0000000..a006ae9
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
+HOMEPAGE="https://pypi.python.org/pypi/pkginfo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+       # Disable tests that seek to read the version of pkginfo from an installed state
+       # These test will still become installed and testable once installed
+       sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
+               -e 's:test_w_module_and_metadata_version:_&:' \
+               -e 's:test_w_package_name_and_metadata_version:_&:' \
+               -i pkginfo/tests/test_utils.py || die
+       sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
+               -i pkginfo/tests/test_develop.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_test() {
+       "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( docs/.build/html/. )
+       distutils-r1_python_install_all
+}