dev-python/notebook: bump to 5.7.8
authorVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 20:48:53 +0000 (16:48 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sat, 4 May 2019 22:58:04 +0000 (18:58 -0400)
Also, drop py2.

Bug: https://bugs.gentoo.org/685040
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.11

dev-python/notebook/Manifest
dev-python/notebook/notebook-5.7.8.ebuild [new file with mode: 0644]

index 9cb654aa8f4c3c38d769e88a514fefd81b946c82..6997588e9cee13a75bb46b414aaaca6011dcc3aa 100644 (file)
@@ -1,3 +1,4 @@
 DIST notebook-5.0.0.tar.gz 11481080 BLAKE2B 3cc483d338ca22c6b4d7199100875e9425f90e1a7059c016cec07500f0558c437db5f7e367a5c4441520deb68fa891be31c07cd93e858c872a1f12d893530479 SHA512 fbee29cc554f36e94b1fe9804187a50581e840cfb5884bcdf2fef82ad9ae3ae0e2082ea0056f815bfa2a1c2f203679169155e61e53253aa2e9004a43ff7fbcae
 DIST notebook-5.2.1.tar.gz 12458130 BLAKE2B f10a91fd79064fb09889c4ee30a84a0b34321d3a89f950609df9a90106ed4af75268cc1b087d0229882575d548b7b2b78632aa97452f89fc67910586911fc467 SHA512 defdb08e37dcec9fe799d0b03dc8dc2339f37c9417e4b138ba83b98433dd77f0dea3d83e07368e67f18155af1a67bbabea21ccd061d8a926b6b084fd25960576
 DIST notebook-5.7.0.tar.gz 13394162 BLAKE2B b74be075ec97896d8ace2ce9f45d4759aee3dba1a7515a412daa8fda4606198d1487e6760ed01d8a2726ac3bf334f2335f40bf8938e8ae1ca23c9cbb5a52eded SHA512 bc5ff0316b0f89ae2c8b8bc271a8824848e2a3d93420e895557229663c889916aa98e4d1503957abbd38ca61a1b3f9d421946d6c98e36f1153b1833f473330b1
+DIST notebook-5.7.8.tar.gz 13371684 BLAKE2B 077a94ec7085ae7325a972efb58f8d7eee5a541186522402084dfa55e335163fee30e68476265e9825c3623408989b1a0782ff6a5af71af4d8ea5e6e308c3a45 SHA512 1cccb23ce6810df85b3b600c0e2e5d6599be5551ea5243c7b1a9c73ed45c34dea8b16b0fbb3624aefb9eda848bce2fdcea1f3add8df3f00a90c13a9b01ea3f07
diff --git a/dev-python/notebook/notebook-5.7.8.ebuild b/dev-python/notebook/notebook-5.7.8.ebuild
new file mode 100644 (file)
index 0000000..11f0039
--- /dev/null
@@ -0,0 +1,115 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Jupyter Interactive Notebook"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+RDEPEND="
+       >=dev-libs/mathjax-2.4
+       dev-python/jinja[${PYTHON_USEDEP}]
+       >=dev-python/terminado-0.8.1[${PYTHON_USEDEP}]
+       >=www-servers/tornado-4.0[${PYTHON_USEDEP}]
+       dev-python/ipython_genutils[${PYTHON_USEDEP}]
+       >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
+       >=dev-python/jupyter_core-4.4.0[${PYTHON_USEDEP}]
+       >=dev-python/pyzmq-17[${PYTHON_USEDEP}]
+       >=dev-python/jupyter_client-5.2[${PYTHON_USEDEP}]
+       dev-python/nbformat[${PYTHON_USEDEP}]
+       >=dev-python/nbconvert-4.2.0[${PYTHON_USEDEP}]
+       dev-python/ipykernel[${PYTHON_USEDEP}]
+       dev-python/send2trash[${PYTHON_USEDEP}]
+       dev-python/prometheus_client[${PYTHON_USEDEP}]"
+
+# sphinx 2+ seems to have a problem with its github plugin. temporarily adding
+# a version constraint.
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? (
+               dev-python/nose[${PYTHON_USEDEP}]
+               dev-python/nose-exclude[${PYTHON_USEDEP}]
+               dev-python/nose_warnings_filters[${PYTHON_USEDEP}]
+               dev-python/requests[${PYTHON_USEDEP}]
+       )
+       doc? (
+               app-text/pandoc
+               dev-python/ipython[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.3.6[${PYTHON_USEDEP}]
+               <dev-python/sphinx-2[${PYTHON_USEDEP}]
+               dev-python/sphinxcontrib-github-alt[${PYTHON_USEDEP}]
+               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+               dev-python/nbsphinx[${PYTHON_USEDEP}]
+               test? (
+                       dev-python/nbval[${PYTHON_USEDEP}]
+                       dev-python/pytest[${PYTHON_USEDEP}]
+               )
+       )
+       "
+
+PATCHES=( "${FILESDIR}/${PN}"-5.7.0-no-mathjax.patch )
+
+# Opens a qtconsole
+restrict="doc"
+
+python_prepare_all() {
+       sed \
+               -e "/import setup/s:$:\nimport setuptools:g" \
+               -i setup.py || die
+
+       # disable bundled mathjax
+       sed -i 's/^.*MathJax.*$//' bower.json || die
+
+       # Prevent un-needed download during build
+       if use doc; then
+               sed \
+                       -e "/^    'sphinx.ext.intersphinx',/d" \
+                       -i docs/source/conf.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               addwrite /dev/dri/card0
+               emake -C docs html
+               HTML_DOCS=( docs/build/html/. )
+       fi
+}
+
+python_test() {
+       nosetests \
+               --verbosity=3 \
+               --exclude-dir notebook/tests/selenium \
+               notebook || die
+
+       # These doc-based tests are broken on gentoo for permission-related errors
+       # (they try to write files in system's ipython folder). Disabled for now.
+       # if use doc; then
+       #       pytest --nbval --current-env docs || die
+       # fi
+}
+
+python_install() {
+       distutils-r1_python_install
+
+       ln -sf \
+               "${EPREFIX}/usr/share/mathjax" \
+               "${D}$(python_get_sitedir)/notebook/static/components/MathJax" || die
+}
+
+pkg_preinst() {
+       # remove old mathjax folder if present
+       rm -rf "${EROOT%/}"/usr/lib*/python*/site-packages/notebook/static/components/MathJax || die
+}