media-sound/saydate: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 22:37:40 +0000 (00:37 +0200)
committerDavid Seifert <soap@gentoo.org>
Thu, 17 Oct 2019 22:37:40 +0000 (00:37 +0200)
Bug: https://bugs.gentoo.org/697272
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/saydate/saydate-0.3.0.ebuild

index 7b6489dbdcd83ab672d41bb46d8e82d88ece5551..95205e4dd16b7bc3aae0ce90468665425189bba6 100644 (file)
@@ -1,35 +1,39 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
-S=${WORKDIR}/${PN}
 DESCRIPTION="A Linux shell program that talks the date and system uptime"
 HOMEPAGE="http://unihedron.com/projects/saydate/saydate.php"
 SRC_URI="http://unihedron.com/projects/saydate/${P}.tar.gz"
+
 LICENSE="GPL-2"
 SLOT="0"
-
 KEYWORDS="amd64 ~ppc ppc64 sparc x86"
 
-DEPEND="=sys-apps/sed-4*"
-IUSE=""
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+       default
 
-# Don't leave this empty or it tries to install directly
-# on livefs
-src_compile() { :; }
+       sed -i 's:/dev/audio:/dev/dsp:' saydate au2raw DESIGN || die
+
+       # don't install pre-compressed files
+       gunzip man/{saydate,au2raw}.1.gz || die
+}
+
+src_compile() {
+       # Don't leave this empty or it tries
+       # to install directly on livefs
+       :
+}
 
-src_install () {
-       insinto /usr/share/man/man1
-       doins "${S}"/man/saydate.1.gz "${S}"/man/au2raw.1.gz
+src_install() {
+       dobin saydate au2raw
 
-       dodir /usr/share/saydate
        insinto /usr/share/saydate
-       doins "${S}"/data/*.raw
+       doins data/*.raw
 
-       sed -i "s:/dev/audio:/dev/dsp:" "${S}"/saydate
-       sed -i "s:/dev/audio:/dev/dsp:" "${S}"/au2raw
-       sed -i "s:/dev/audio:/dev/dsp:" "${S}"/DESIGN
+       doman man/{saydate,au2raw}.1
        dodoc README TODO HISTORY DESIGN
-       dobin saydate au2raw || die "dobin failed"
 }