dev-python/pytest-fixture-config: Revbump to drop py2
authorMichał Górny <mgorny@gentoo.org>
Sun, 8 Mar 2020 06:32:06 +0000 (07:32 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 8 Mar 2020 08:24:57 +0000 (09:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild b/dev-python/pytest-fixture-config/pytest-fixture-config-1.7.0-r1.ebuild
new file mode 100644 (file)
index 0000000..8cb9f46
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtualenv fixture for py.test"
+HOMEPAGE="https://github.com/manahl/pytest-plugins https://pypi.org/project/pytest-fixture-config/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+       dev-python/pytest[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/setuptools-git[${PYTHON_USEDEP}]
+       test? ( dev-python/six[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest