net-dns/bind-tools: Version bump
authorChristian Ruppert <idl0r@gentoo.org>
Thu, 24 Jan 2019 10:24:35 +0000 (11:24 +0100)
committerChristian Ruppert <idl0r@gentoo.org>
Thu, 24 Jan 2019 10:24:48 +0000 (11:24 +0100)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Christian Ruppert <idl0r@gentoo.org>
net-dns/bind-tools/Manifest
net-dns/bind-tools/bind-tools-9.12.3_p1.ebuild [new file with mode: 0644]

index a8de3d4e0f4c9f2dbe920bb07c180c9a5b4abed4..4c6f385ec01c7240006e9f434ff5edc88601f2e9 100644 (file)
@@ -3,3 +3,4 @@ DIST bind-9.11.4_p2.tar.gz 9617963 BLAKE2B 409cad7e0976f2e46406d45e87241d61d4d4f
 DIST bind-9.12.1.tar.gz 9302783 BLAKE2B 731ce67acb22f72e54de1122c5d5c3c1f0663c400bdff9545578a45e5fe3094c6d754351e57dd5c52cdfe1528305dfde25eba7382a723a60b8bfdfeebb9536cd SHA512 701e34a0a3313568c8e5cf76668fefc2a1fceb2ade0de201b8f678401569f1c622c3d1657a71772fa3298efc8b3cdefe974d98432c0087e8b45af3d50a4262fb
 DIST bind-9.12.2_p1.tar.gz 9429002 BLAKE2B 1460b4583a28df21490f71993c8cd595dd8f8ee76727cc8798ee34a6deb1f5a4d39706ec2833a42a7e63ce0dcad917ca975c7d725fc179e2dd0450d8d683ceb4 SHA512 22ce084179439518f7d82f0b80544db929bb4ec71d0e7bd7edad9ae915c903300837d6ead698c9fc23741796f0ba9ed3aa384b752ff65c3b9b20c8969d351cba
 DIST bind-9.12.2_p2.tar.gz 9422128 BLAKE2B c7d56f025f381a0136aa67ccd49a3254fcfe566d5e3601410e5cada26ccab32a901fe6e14bc14e6e287fa2b3904a4eee8e3ef63329f9bc4cb11f204590ff3623 SHA512 458adf6b3d0df286e7d345a21c40b639efcb275e76f9e0bf4e40a5d76dcac875016324393e129f29397be326d1017367c506ec9cbb35871c98fad4281bc4e05a
+DIST bind-9.12.3_p1.tar.gz 8625693 BLAKE2B 1899e04e409d3dafe63494fb7a0d8b813a6487754149bbfd01888cddc5e134ac675e9ac790684fb6fd8de4b1484e23ed7f1881c01234c9f16b27180c9a4594a9 SHA512 c1c91de88e4297e79b527775edd525c6fa948f169977563ab2e6ca93cac7317f8ca85863567f5cc151d4c6e3c081864ab1cf813bcfdd1165b52e9471b8317c28
diff --git a/net-dns/bind-tools/bind-tools-9.12.3_p1.ebuild b/net-dns/bind-tools/bind-tools-9.12.3_p1.ebuild
new file mode 100644 (file)
index 0000000..ccf606d
--- /dev/null
@@ -0,0 +1,158 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_PV=${MY_PV/_rc/rc}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="https://www.isc.org/downloads/file/${MY_P}/?version=tar-gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 GPL-2 HPND ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc gost gssapi idn ipv6 libedit libidn2 libressl readline seccomp ssl urandom xml"
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+REQUIRED_USE="gost? ( !libressl ssl )
+       idn? ( !libidn2 )
+       libidn2? ( !idn )"
+
+CDEPEND="
+       ssl? (
+               !libressl? ( dev-libs/openssl:0= )
+               libressl? ( dev-libs/libressl:= )
+       )
+       gost? (
+               || (
+                       =dev-libs/openssl-1.0*[-bindist]
+                       (
+                               >=dev-libs/openssl-1.1
+                               dev-libs/gost-engine
+                       )
+               )
+       )
+       xml? ( dev-libs/libxml2 )
+       idn? ( <net-dns/idnkit-2:= )
+       libidn2? ( net-dns/libidn2:= )
+       gssapi? ( virtual/krb5 )
+       libedit? ( dev-libs/libedit )
+       !libedit? (
+               readline? ( sys-libs/readline:0= )
+       )
+       seccomp? ( sys-libs/libseccomp )"
+DEPEND="${CDEPEND}
+       virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+       !<net-dns/bind-9.10.2"
+
+S="${WORKDIR}/${MY_P}"
+
+# bug 479092, requires networking
+RESTRICT="test"
+
+src_prepare() {
+       default
+
+       # Disable tests for now, bug 406399
+       sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+       # bug #220361
+       rm aclocal.m4
+       rm -rf libtool.m4/
+
+       mv configure.in configure.ac || die # configure.in is deprecated
+       eautoreconf
+}
+
+src_configure() {
+       local myeconfargs=(
+               --localstatedir="${EPREFIX}"/var
+               --without-python
+               --without-libjson
+               --without-zlib
+               --without-lmdb
+               $(use_enable ipv6)
+               $(use_with idn idnkit)
+               $(usex idn --with-idnlib=-lidnkit '')
+               $(use_with libidn2)
+               $(use_enable seccomp)
+               $(use_with ssl openssl "${EPREFIX}"/usr)
+               $(use_with xml libxml2)
+               $(use_with gssapi)
+               $(use_with readline)
+               $(use_with gost)
+       )
+
+       if use urandom; then
+               myeconfargs+=( --with-randomdev=/dev/urandom )
+       else
+               myeconfargs+=( --with-randomdev=/dev/random )
+       fi
+
+       # bug 607400
+       if use libedit ; then
+               myeconfargs+=( --with-readline=-ledit )
+       elif use readline ; then
+               myeconfargs+=( --with-readline=-lreadline )
+       else
+               myeconfargs+=( --without-readline )
+       fi
+
+       # bug 344029
+       append-cflags "-DDIG_SIGCHASE"
+
+       # localstatedir for nsupdate -l, bug 395785
+       tc-export BUILD_CC
+       econf "${myeconfargs[@]}"
+
+       # bug #151839
+       echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+       local AR=$(tc-getAR)
+
+       emake AR="${AR}" -C lib/
+       emake AR="${AR}" -C bin/delv/
+       emake AR="${AR}" -C bin/dig/
+       emake AR="${AR}" -C bin/nsupdate/
+       emake AR="${AR}" -C bin/dnssec/
+}
+
+src_install() {
+       dodoc README CHANGES
+
+       cd "${S}"/bin/delv || die
+       dobin delv
+       doman delv.1
+
+       cd "${S}"/bin/dig || die
+       dobin dig host nslookup
+       doman {dig,host,nslookup}.1
+
+       cd "${S}"/bin/nsupdate || die
+       dobin nsupdate
+       doman nsupdate.1
+       if use doc; then
+               docinto html
+               dodoc nsupdate.html
+       fi
+
+       cd "${S}"/bin/dnssec || die
+       for tool in dsfromkey importkey keyfromlabel keygen \
+               revoke settime signzone verify; do
+               dobin dnssec-"${tool}"
+               doman dnssec-"${tool}".8
+               if use doc; then
+                       docinto html
+                       dodoc dnssec-"${tool}".html
+               fi
+       done
+}