net-analyzer/zabbix: Closes Bug #667618
authorMatthew Marlowe <mattm@gentoo.org>
Mon, 5 Nov 2018 01:43:20 +0000 (17:43 -0800)
committerMatthew Marlowe <mattm@gentoo.org>
Mon, 5 Nov 2018 01:46:51 +0000 (17:46 -0800)
Signed-off-by: Matthew Marlowe <mattm@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

net-analyzer/zabbix/Manifest
net-analyzer/zabbix/zabbix-4.0.1.ebuild [new file with mode: 0644]

index 8cc5472a751529f337fbc82a845dc05ccbcc02ac..d75d4ae0968c35478d32a65ea9b160cc18579bac 100644 (file)
@@ -11,3 +11,4 @@ DIST zabbix-3.4.11.tar.gz 17517171 BLAKE2B 72f7d1cad3e8cb7972cb9c3698d35f70c45de
 DIST zabbix-3.4.12.tar.gz 17509251 BLAKE2B 158c7b3061059cc54a5988296404ed6670ca872fa8fa55f8de9708871ee03f163d0365420e23ef5df89a0a85e2f23d607952cf4fc02c974037555534ca164f08 SHA512 6707ff5a15d2c139775b4b5de32ceb4982c90aa4023af310ab9cb849895387984d32f59b7dc9fbaff8f317a630238437e4651ab8272b4535fb5fc3d88750e3ef
 DIST zabbix-3.4.13.tar.gz 17507365 BLAKE2B a5d1fa1a48df2ad66b844c2c85038a088ea5f7e3e67c2c3ab5f5d1ad695b3a31664d317e6a1cbf64d1f6a211304f50e5c38f5d973d4607f2caa202e1184420cf SHA512 4edcf6d9df0f100c639efa6bc18e67ed59819e719a2226593fd81212d4c2e46a19cb50501cca005246b4c01c4082a18e21c9049a99ac9df263180a3c24fa52f0
 DIST zabbix-3.4.14.tar.gz 17476022 BLAKE2B 9fccdf69bb74379fccfe044d68da8ce458e04c4686ae70a2fed5523309196b13fb022daa00d47ae9eb97a0774942efd766858dfe94890e20f38808ef2a3e3d15 SHA512 597ae107c16578ec2b1a364f2b61a7a7423a1cf39d3b04289e2f91dc0f931e796b566cbd451b14e026c35302120b647d6d574952a453189b066fb06081f9bb83
+DIST zabbix-4.0.1.tar.gz 18005197 BLAKE2B 3da109715f2061a0104f471f9717947510da8d7a3215fe219d5870bbd8bb1cd769d586c04da3e0aa35a114565bd94911e3c4e62eb66de39af754911a9839d2e3 SHA512 431cb75c62c64e0907cccad6633fe07a66fbaaf8595ca33add6de98a3f79832dd87c23ddaffada796a67055cbdef6d2e5d9c6427498518080205d5ddcd5fbdca
diff --git a/net-analyzer/zabbix/zabbix-4.0.1.ebuild b/net-analyzer/zabbix/zabbix-4.0.1.ebuild
new file mode 100644 (file)
index 0000000..f936b89
--- /dev/null
@@ -0,0 +1,332 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+# needed to make webapp-config dep optional
+WEBAPP_OPTIONAL="yes"
+inherit flag-o-matic webapp java-pkg-opt-2 user systemd toolchain-funcs
+
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers"
+HOMEPAGE="https://www.zabbix.com/"
+MY_P=${P/_/}
+MY_PV=${PV/_/}
+SRC_URI="https://prdownloads.sourceforge.net/zabbix/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+WEBAPP_MANUAL_SLOT="yes"
+KEYWORDS=""
+IUSE="+agent java curl frontend ipv6 xmpp ldap libxml2 mysql openipmi oracle +postgres proxy server ssh ssl snmp sqlite odbc static"
+REQUIRED_USE="|| ( agent frontend proxy server )
+       proxy? ( ^^ ( mysql oracle postgres sqlite odbc ) )
+       server? ( ^^ ( mysql oracle postgres odbc ) )
+       static? ( !oracle !snmp )"
+
+COMMON_DEPEND="snmp? ( net-analyzer/net-snmp )
+       ldap? (
+               net-nds/openldap
+               =dev-libs/cyrus-sasl-2*
+               net-libs/gnutls
+       )
+       mysql? ( >=virtual/mysql-5.0.3 )
+       sqlite? ( >=dev-db/sqlite-3.3.5 )
+       postgres? ( >=dev-db/postgresql-8.1:* )
+       oracle? ( >=dev-db/oracle-instantclient-basic-10.0.0.0 )
+       xmpp? ( dev-libs/iksemel )
+       libxml2? ( dev-libs/libxml2 )
+       curl? ( net-misc/curl )
+       openipmi? ( sys-libs/openipmi )
+       ssh? ( net-libs/libssh2 )
+       java? ( virtual/jdk:* )
+       odbc? ( dev-db/unixODBC )
+       server? ( sys-libs/zlib )
+       proxy?  ( sys-libs/zlib )
+       ssl? ( dev-libs/openssl:=[-bindist] )"
+
+RDEPEND="${COMMON_DEPEND}
+       proxy? ( net-analyzer/fping[suid] )
+       server? ( net-analyzer/fping[suid]
+               app-admin/webapp-config
+               dev-libs/libpcre
+               dev-libs/libevent )
+       java?   (
+               >=virtual/jre-1.4
+               dev-java/slf4j-api
+       )
+       frontend? (
+               >=dev-lang/php-5.4.0[bcmath,ctype,sockets,gd,truetype,xml,session,xmlreader,xmlwriter,nls,sysvipc,unicode]
+               || ( dev-lang/php[apache2] dev-lang/php[cgi] dev-lang/php[fpm] )
+               mysql? ( dev-lang/php[mysqli] )
+               odbc? ( dev-lang/php[odbc] )
+               oracle? ( dev-lang/php[oci8-instant-client] )
+               postgres? ( dev-lang/php[postgres] )
+               sqlite? ( dev-lang/php[sqlite] )
+               media-libs/gd[png]
+               app-admin/webapp-config )"
+DEPEND="${COMMON_DEPEND}
+       static? (
+               ldap? (
+                       net-nds/openldap[static-libs]
+                       =dev-libs/cyrus-sasl-2*[static-libs]
+                       net-libs/gnutls[static-libs]
+               )
+       mysql? ( >=virtual/mysql-5.0.3[static-libs] )
+       sqlite? ( >=dev-db/sqlite-3.3.5[static-libs] )
+       postgres? ( >=dev-db/postgresql-8.1:*[static-libs] )
+       libxml2? ( dev-libs/libxml2[static-libs] )
+       curl? ( net-misc/curl[static-libs] )
+       ssh? ( net-libs/libssh2[static-libs] )
+       odbc? ( dev-db/unixODBC[static-libs] )
+       )
+       virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+ZABBIXJAVA_BASE="opt/zabbix_java"
+
+pkg_setup() {
+       if use oracle; then
+               if [ -z "${ORACLE_HOME}" ]; then
+                       eerror
+                       eerror "The environment variable ORACLE_HOME must be set"
+                       eerror "and point to the correct location."
+                       eerror "It looks like you don't have Oracle installed."
+                       eerror
+                       die "Environment variable ORACLE_HOME is not set"
+               fi
+               if has_version 'dev-db/oracle-instantclient-basic'; then
+                       ewarn
+                       ewarn "Please ensure you have a full install of the Oracle client."
+                       ewarn "dev-db/oracle-instantclient* is NOT sufficient."
+                       ewarn
+               fi
+       fi
+
+       if use frontend; then
+               webapp_pkg_setup
+       fi
+
+       enewgroup zabbix
+       enewuser zabbix -1 -1 /var/lib/zabbix/home zabbix
+}
+
+java_prepare() {
+       cd "${S}/src/zabbix_java/lib"
+       rm -v *.jar || die
+
+       java-pkg_jar-from slf4j-api
+}
+
+src_prepare() {
+       default
+}
+
+src_configure() {
+       econf \
+               $(use_enable server) \
+               $(use_enable proxy) \
+               $(use_enable agent) \
+               $(use_enable ipv6) \
+               $(use_enable static) \
+               $(use_enable java) \
+               $(use_with ldap) \
+               $(use_with snmp net-snmp) \
+               $(use_with mysql) \
+               $(use_with postgres postgresql) \
+               $(use_with oracle) \
+               $(use_with sqlite sqlite3) \
+               $(use_with xmpp jabber) \
+               $(use_with curl libcurl) \
+               $(use_with openipmi openipmi) \
+               $(use_with ssh ssh2) \
+               $(use_with libxml2) \
+               $(use_with odbc unixodbc) \
+               $(use_with ssl openssl) \
+               || die "econf failed"
+}
+
+src_compile() {
+       if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
+               emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+       fi
+}
+
+src_install() {
+       dodir \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       keepdir \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       if use server; then
+               insinto /etc/zabbix
+               doins "${FILESDIR}/3.0"/zabbix_server.conf
+               doinitd "${FILESDIR}/3.0"/init.d/zabbix-server
+               dosbin src/zabbix_server/zabbix_server
+               fowners zabbix:zabbix /etc/zabbix/zabbix_server.conf
+               fperms 0640 /etc/zabbix/zabbix_server.conf
+               dodir /usr/share/zabbix
+               /bin/cp -R "${S}/database/" "${D}"/usr/share/zabbix/
+               systemd_dounit "${FILESDIR}/zabbix-server.service"
+               systemd_newtmpfilesd "${FILESDIR}/zabbix-server.tmpfiles" zabbix-server.conf
+       fi
+
+       if use proxy; then
+               doinitd "${FILESDIR}/3.0"/init.d/zabbix-proxy
+               dosbin src/zabbix_proxy/zabbix_proxy
+               insinto /etc/zabbix
+               doins "${FILESDIR}/3.0"/zabbix_proxy.conf
+               dodir /usr/share/zabbix
+               /bin/cp -R "${S}/database/" "${D}"/usr/share/zabbix/
+               systemd_dounit "${FILESDIR}/zabbix-proxy.service"
+               systemd_newtmpfilesd "${FILESDIR}/zabbix-proxy.tmpfiles" zabbix-proxy.conf
+       fi
+
+       if use agent; then
+               insinto /etc/zabbix
+               doins "${FILESDIR}/3.0"/zabbix_agentd.conf
+               doinitd "${FILESDIR}/3.0"/init.d/zabbix-agentd
+               dosbin src/zabbix_agent/zabbix_agentd
+               dobin \
+                       src/zabbix_sender/zabbix_sender \
+                       src/zabbix_get/zabbix_get
+               fowners zabbix:zabbix /etc/zabbix/zabbix_agentd.conf
+               fperms 0640 /etc/zabbix/zabbix_agentd.conf
+               systemd_dounit "${FILESDIR}/zabbix-agentd.service"
+               systemd_newtmpfilesd "${FILESDIR}/zabbix-agentd.tmpfiles" zabbix-agentd.conf
+       fi
+
+       fowners zabbix:zabbix \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+       fperms 0750 \
+               /etc/zabbix \
+               /var/lib/zabbix \
+               /var/lib/zabbix/home \
+               /var/lib/zabbix/scripts \
+               /var/lib/zabbix/alertscripts \
+               /var/lib/zabbix/externalscripts \
+               /var/log/zabbix
+
+       dodoc README INSTALL NEWS ChangeLog \
+               conf/zabbix_agentd.conf \
+               conf/zabbix_proxy.conf \
+               conf/zabbix_agentd/userparameter_examples.conf \
+               conf/zabbix_agentd/userparameter_mysql.conf \
+               conf/zabbix_server.conf
+
+       if use frontend; then
+               webapp_src_preinst
+               cp -R frontends/php/* "${D}/${MY_HTDOCSDIR}"
+               webapp_configfile \
+                       "${MY_HTDOCSDIR}"/include/db.inc.php \
+                       "${MY_HTDOCSDIR}"/include/config.inc.php
+               webapp_src_install
+       fi
+
+       if use java; then
+               dodir \
+                       /${ZABBIXJAVA_BASE} \
+                       /${ZABBIXJAVA_BASE}/bin \
+                       /${ZABBIXJAVA_BASE}/lib
+               keepdir /${ZABBIXJAVA_BASE}
+               exeinto /${ZABBIXJAVA_BASE}/bin
+               doexe src/zabbix_java/bin/zabbix-java-gateway-${MY_PV}.jar
+               exeinto /${ZABBIXJAVA_BASE}/lib
+               doexe \
+                       src/zabbix_java/lib/logback-classic-0.9.27.jar \
+                       src/zabbix_java/lib/logback-console.xml \
+                       src/zabbix_java/lib/logback-core-0.9.27.jar \
+                       src/zabbix_java/lib/logback.xml \
+                       src/zabbix_java/lib/android-json-4.3_r3.1.jar \
+                       src/zabbix_java/lib/slf4j-api-1.6.1.jar
+               fowners -R zabbix:zabbix /${ZABBIXJAVA_BASE}
+               doinitd "${FILESDIR}"/3.0/init.d/zabbix-jmx-proxy
+               doconfd "${FILESDIR}"/3.0/conf.d/zabbix-jmx-proxy
+       fi
+}
+
+pkg_postinst() {
+       if use server || use proxy ; then
+               elog
+               elog "You may need to configure your database for Zabbix,"
+               elog "if you have not already done so. "
+               elog
+
+               zabbix_homedir=$(egethome zabbix)
+               if [ -n "${zabbix_homedir}" ] && \
+                  [ "${zabbix_homedir}" != "/var/lib/zabbix/home" ]; then
+                       ewarn
+                       ewarn "The user 'zabbix' should have his homedir changed"
+                       ewarn "to /var/lib/zabbix/home if you want to use"
+                       ewarn "custom alert scripts."
+                       ewarn
+                       ewarn "A real homedir might be needed for configfiles"
+                       ewarn "for custom alert scripts (e.g. ~/.sendxmpprc when"
+                       ewarn "using sendxmpp for Jabber alerts)."
+                       ewarn
+                       ewarn "To change the homedir use:"
+                       ewarn "  usermod -d /var/lib/zabbix/home zabbix"
+                       ewarn
+               fi
+       fi
+
+       if use server; then
+               elog
+               elog "For distributed monitoring you have to run:"
+               elog
+               elog "zabbix_server -n <nodeid>"
+               elog
+               elog "This will convert database data for use with Node ID"
+               elog "and also adds a local node."
+               elog
+       fi
+
+       elog "--"
+       elog
+       elog "You may need to add these lines to /etc/services:"
+       elog
+       elog "zabbix-agent     10050/tcp Zabbix Agent"
+       elog "zabbix-agent     10050/udp Zabbix Agent"
+       elog "zabbix-trapper   10051/tcp Zabbix Trapper"
+       elog "zabbix-trapper   10051/udp Zabbix Trapper"
+       elog
+
+       if use server || use proxy ; then
+               # check for fping
+               fping_perms=$(stat -c %a /usr/sbin/fping 2>/dev/null)
+               case "${fping_perms}" in
+                       4[157][157][157])
+                               ;;
+                       *)
+                               ewarn
+                               ewarn "If you want to use the checks 'icmpping' and 'icmppingsec',"
+                               ewarn "you have to make /usr/sbin/fping setuid root and executable"
+                               ewarn "by everyone. Run the following command to fix it:"
+                               ewarn
+                               ewarn "  chmod u=rwsx,g=rx,o=rx /usr/sbin/fping"
+                               ewarn
+                               ewarn "Please be aware that this might impose a security risk,"
+                               ewarn "depending on the code quality of fping."
+                               ewarn
+                               ;;
+               esac
+       fi
+}