dev-ros/imu_filter_madgwick: Bump to 1.2.0.
authorAlexis Ballier <aballier@gentoo.org>
Fri, 8 Jun 2018 12:14:59 +0000 (14:14 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 8 Jun 2018 12:26:28 +0000 (14:26 +0200)
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-ros/imu_filter_madgwick/Manifest
dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild [new file with mode: 0644]

index 5c6576ba801515af762b12e70dd44d0ebfba8934..f88e2c915d89d3cd09ccde2a311a055d2f7fc383 100644 (file)
@@ -1 +1,2 @@
 DIST imu_tools-1.1.5.tar.gz 1653083 BLAKE2B 8c0e84333455a5b4cae215a2e54b74ff828d00a426b9ab13f4048a72556b6a526dc4256a53dc3e21e098cc31ea6d21e0d508066a4627d01c27681ce0b3b18035 SHA512 5009884852c71d6bb1b6c2be2f30ed333eca2ac6a7f29d02cb8f0821c0b95a33dd3b09049c4c4eeb1416fb0eb5dc454b3c6d36c2c24303f37c0d1d2c0c2d906a
+DIST imu_tools-1.2.0.tar.gz 1653607 BLAKE2B 76cccfeae657188e3be3774bcb19c5edac94e7070a6fd8a01c8a56857297491568f978820e6f32467b031ceece4742e6c0fe926e5d59ad19a2f6fb1c037ac3ec SHA512 3f39a2ec539949a6881cc106122d663706ddd3ed03ed822b9370e56beb56f1349bfd668a71e443ab2b9d525c6a3a88fad053768764160d9d0f04c08ba1ad2f8e
diff --git a/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild b/dev-ros/imu_filter_madgwick/imu_filter_madgwick-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..1594d52
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/roscpp
+       dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+       dev-ros/tf2
+       dev-ros/tf2_geometry_msgs
+       dev-ros/tf2_ros
+       dev-ros/nodelet
+       dev-libs/console_bridge:=
+       dev-ros/pluginlib
+       dev-ros/message_filters
+       dev-ros/dynamic_reconfigure
+       dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+       test? ( dev-ros/rosunit )
+"