net-libs/srt: [QA] Do not install static library
authorAlessandro Barbieri <lssndrbarbieri@gmail.com>
Wed, 22 Apr 2020 08:32:58 +0000 (10:32 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 22 Apr 2020 08:32:58 +0000 (10:32 +0200)
Closes: https://github.com/gentoo/gentoo/pull/13290
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: Alessandro Barbieri <lssndrbarbieri@gmail.com>
Signed-off-by: David Seifert <soap@gentoo.org>
net-libs/srt/srt-1.3.2-r1.ebuild [moved from net-libs/srt/srt-1.3.2.ebuild with 87% similarity]
net-libs/srt/srt-1.4.0-r1.ebuild [moved from net-libs/srt/srt-1.4.1.ebuild with 91% similarity]
net-libs/srt/srt-1.4.1-r1.ebuild [moved from net-libs/srt/srt-1.4.0.ebuild with 88% similarity]
net-libs/srt/srt-9999.ebuild

similarity index 87%
rename from net-libs/srt/srt-1.3.2.ebuild
rename to net-libs/srt/srt-1.3.2-r1.ebuild
index 6e2cd2ff5ef9b5119c8df3876a0342bb7c61fc16..864f007208ac9134b549a310631040249de164a8 100644 (file)
@@ -32,20 +32,18 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
-DOCS=( README.md )
-
 PATCHES=(
        "${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
 )
 
 src_prepare() {
        cmake-utils_src_prepare
-       sed -i -e "s:hcrypt_ut.c::" "${S}"/haicrypt/*.maf || die
-       sed -i -e 's:DESTINATION lib:DESTINATION lib${LIB_SUFFIX}:' CMakeLists.txt || die
+       sed -i -e "s:hcrypt_ut.c::" haicrypt/*.maf || die
 }
 
 src_configure() {
        local mycmakeargs=(
+               -DENABLE_STATIC=OFF
                -DUSE_GNUTLS=$(usex gnutls)
        )
        cmake-multilib_src_configure
similarity index 91%
rename from net-libs/srt/srt-1.4.1.ebuild
rename to net-libs/srt/srt-1.4.0-r1.ebuild
index 715e4cbdfed99a198a86d93c46717a4c8df12eca..7a9dff6b43c159cfef181c29b4b8ed1c66798006 100644 (file)
@@ -32,8 +32,6 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
-DOCS=( README.md )
-
 PATCHES=(
        "${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
 )
@@ -41,11 +39,11 @@ PATCHES=(
 src_prepare() {
        cmake-utils_src_prepare
        sed -i -e "s:hcrypt_ut.c::" "${S}"/haicrypt/*.maf || die
-       sed -i -e 's:DESTINATION lib:DESTINATION lib${LIB_SUFFIX}:' CMakeLists.txt || die
 }
 
 src_configure() {
        local mycmakeargs=(
+               -DENABLE_STATIC=OFF
                -DUSE_GNUTLS=$(usex gnutls)
        )
        cmake-multilib_src_configure
similarity index 88%
rename from net-libs/srt/srt-1.4.0.ebuild
rename to net-libs/srt/srt-1.4.1-r1.ebuild
index 7188ae1c913ed61c88936ee84adeb8845c601d9a..7a9dff6b43c159cfef181c29b4b8ed1c66798006 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2018-2019 Gentoo Authors
+# Copyright 2018-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -32,8 +32,6 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
-DOCS=( README.md )
-
 PATCHES=(
        "${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
 )
@@ -41,11 +39,11 @@ PATCHES=(
 src_prepare() {
        cmake-utils_src_prepare
        sed -i -e "s:hcrypt_ut.c::" "${S}"/haicrypt/*.maf || die
-       sed -i -e 's:DESTINATION lib:DESTINATION lib${LIB_SUFFIX}:' CMakeLists.txt || die
 }
 
 src_configure() {
        local mycmakeargs=(
+               -DENABLE_STATIC=OFF
                -DUSE_GNUTLS=$(usex gnutls)
        )
        cmake-multilib_src_configure
index 05f29c86c32eef4f0cc8268f917dc68e835e527f..283aff3244f86ddcc12daaf0b1b3e21e584e9128 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 2018-2019 Gentoo Authors
+# Copyright 2018-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -36,20 +36,18 @@ DEPEND="${RDEPEND}
 
 RESTRICT="!test? ( test )"
 
-DOCS=( README.md )
-
 PATCHES=(
        "${FILESDIR}/${PN}-always-GNUInstallDirs.patch"
 )
 
 src_prepare() {
        cmake-utils_src_prepare
-       sed -i -e "s:hcrypt_ut.c::" "${S}"/haicrypt/*.maf || die
-       sed -i -e 's:DESTINATION lib:DESTINATION lib${LIB_SUFFIX}:' CMakeLists.txt || die
+       sed -i -e "s:hcrypt_ut.c::" haicrypt/*.maf || die
 }
 
 src_configure() {
        local mycmakeargs=(
+               -DENABLE_STATIC=OFF
                -DUSE_GNUTLS=$(usex gnutls)
                -DENABLE_UNITTESTS=$(usex test)
        )