media-sound/spotify: readding paxmarks
authorMatthew Thode <mthode@mthode.org>
Mon, 21 Sep 2015 19:19:27 +0000 (14:19 -0500)
committerMatthew Thode <mthode@mthode.org>
Mon, 21 Sep 2015 19:19:51 +0000 (14:19 -0500)
Package-Manager: portage-2.2.20.1

media-sound/spotify/spotify-1.0.14.ebuild

index 71eb9807b20ef183e421ecb053c47e1f2ec7cbe5..1105ded0ba7486e9cda50e0fcf64198309b6ea32 100644 (file)
@@ -80,6 +80,17 @@ src_install() {
                        "spotify-client.png"
        done
        domenu "${S}${SPOTIFY_PKG_HOME}/spotify.desktop"
+       if use pax_kernel; then
+               #create the headers, reset them to default, then paxmark -m them
+               pax-mark C "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark z "${ED}${SPOTIFY_HOME}/${PN}" || die
+               pax-mark m "${ED}${SPOTIFY_HOME}/${PN}" || die
+               eqawarn "You have set USE=pax_kernel meaning that you intend to run"
+               eqawarn "${PN} under a PaX enabled kernel.  To do so, we must modify"
+               eqawarn "the ${PN} binary itself and this *may* lead to breakage!  If"
+               eqawarn "you suspect that ${PN} is being broken by this modification,"
+               eqawarn "please open a bug."
+       fi
 }
 
 pkg_preinst() {