sys-libs/libcxx: Remove 7*
authorMichał Górny <mgorny@gentoo.org>
Fri, 1 May 2020 08:46:42 +0000 (10:46 +0200)
committerMichał Górny <mgorny@gentoo.org>
Fri, 1 May 2020 08:53:39 +0000 (10:53 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
sys-libs/libcxx/Manifest
sys-libs/libcxx/libcxx-7.1.0.ebuild [deleted file]

index 29811dbb1af12bc7a1cf8179652e30606cbd9750..f322c621eec39be9cb53b5842ad6ac1575ccd8a6 100644 (file)
@@ -1,4 +1,3 @@
-DIST libcxx-7.1.0.src.tar.xz 1638448 BLAKE2B eca192e03f839f4323e3c37beba2e6daaf935d4e784e0bc835a4d2c3ce0790f5539bdca0466feafd668d7c6675b11b7fe14d9adb680c46fd7b28b42a3b423219 SHA512 925ce5093445f84dc17d5b1610e4297ef3606b254b7350c50f88ba042fcca62125ffd97d21cb612707d5e9511267634ca1779619199f95ce819e5f5c0c2b55d5
 DIST libcxx-8.0.1.src.tar.xz 1739524 BLAKE2B 6e641cb6bda0de12c8408d3ab33f627389ac014aa65b3391c870aa96ffd347784e6b70b953bd1ee8eba56554e0f78a723ab77b9dba5f85e6219e2b95ca50c160 SHA512 75749d08b2b343c6f5f9aefb04be63e42f6d12efc51101d3647ed6f70c7a6d050afb3ab2f3636eae78cb523f5844de67b960a7a3145ed89ab0c7015deb14921e
 DIST llvmorg-10.0.0.tar.gz 120804856 BLAKE2B 6b0254f5b913398cdcf2b2ec1ff219888706d2b79d5296590934714e42ac79f6a6547941ac2b1d2c4e6313dd18b6c7068e748aa6ac033e49fccbf5d355aa8191 SHA512 baa182d62fef1851836013ae8a1a00861ea89769778d67fb97b407a9de664e6c85da2af9c5b3f75d2bf34ff6b00004e531ca7e4b3115a26c0e61c575cf2303a0
 DIST llvmorg-9.0.1.tar.gz 113193320 BLAKE2B b86e405f2b8e00436045fd409fe19cdde75c797b1192c62a22b5ec75e6b4dc8e874a0f33008dc31562445e4cbe53a992b6f48c684255a6a1ef261e595b8b161f SHA512 fa88beeaae94b6d0cd9b5ba38658d0ffed8004035d7d8a4f95c3d31a709b88b581ae9bd7761333c8e5375c44b8f6be01768b5a3be901163159d7e6c43b71da59
diff --git a/sys-libs/libcxx/libcxx-7.1.0.ebuild b/sys-libs/libcxx/libcxx-7.1.0.ebuild
deleted file mode 100644 (file)
index 1da0523..0000000
+++ /dev/null
@@ -1,215 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-# Ninja provides better scalability and cleaner verbose output, and is used
-# throughout all LLVM projects.
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-# (needed due to CMAKE_BUILD_TYPE != Gentoo)
-CMAKE_MIN_VERSION=3.7.0-r1
-PYTHON_COMPAT=( python2_7 )
-
-inherit cmake-multilib llvm multiprocessing python-any-r1 \
-       toolchain-funcs
-
-DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
-HOMEPAGE="https://libcxx.llvm.org/"
-SRC_URI="https://releases.llvm.org/${PV/_//}/${P/_/}.src.tar.xz"
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 x86"
-IUSE="elibc_glibc elibc_musl +libcxxabi libcxxrt +libunwind +static-libs test"
-REQUIRED_USE="libunwind? ( || ( libcxxabi libcxxrt ) )
-       ?? ( libcxxabi libcxxrt )"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       libcxxabi? ( ~sys-libs/libcxxabi-${PV}[libunwind=,static-libs?,${MULTILIB_USEDEP}] )
-       libcxxrt? ( sys-libs/libcxxrt[libunwind=,static-libs?,${MULTILIB_USEDEP}] )
-       !libcxxabi? ( !libcxxrt? ( >=sys-devel/gcc-4.7:=[cxx] ) )"
-# llvm-6 for new lit options
-# clang-3.9.0 installs necessary target symlinks unconditionally
-# which removes the need for MULTILIB_USEDEP
-DEPEND="${RDEPEND}
-       test? ( >=sys-devel/clang-3.9.0
-               $(python_gen_any_dep 'dev-python/lit[${PYTHON_USEDEP}]') )
-       app-arch/xz-utils
-       >=sys-devel/llvm-6"
-
-S=${WORKDIR}/${P/_/}.src
-
-DOCS=( CREDITS.TXT )
-
-PATCHES=(
-       # Add link flag "-Wl,-z,defs" to avoid underlinking; this is needed in a
-       # out-of-tree build.
-       "${FILESDIR}/${PN}-3.9-cmake-link-flags.patch"
-)
-
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
-python_check_deps() {
-       has_version "dev-python/lit[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
-       llvm_pkg_setup
-       use test && python-any-r1_pkg_setup
-
-       if ! use libcxxabi && ! use libcxxrt && ! tc-is-gcc ; then
-               eerror "To build ${PN} against libsupc++, you have to use gcc. Other"
-               eerror "compilers are not supported. Please set CC=gcc and CXX=g++"
-               eerror "and try again."
-               die
-       fi
-       if tc-is-gcc && [[ $(gcc-version) < 4.7 ]] ; then
-               eerror "${PN} needs to be built with gcc-4.7 or later (or other"
-               eerror "conformant compilers). Please use gcc-config to switch to"
-               eerror "gcc-4.7 or later version."
-               die
-       fi
-}
-
-test_compiler() {
-       $(tc-getCXX) ${CXXFLAGS} ${LDFLAGS} "${@}" -o /dev/null -x c++ - \
-               <<<'int main() { return 0; }' &>/dev/null
-}
-
-src_configure() {
-       # note: we need to do this before multilib kicks in since it will
-       # alter the CHOST
-       local cxxabi cxxabi_incs
-       if use libcxxabi; then
-               cxxabi=libcxxabi
-               cxxabi_incs="${EPREFIX}/usr/include/libcxxabi"
-       elif use libcxxrt; then
-               cxxabi=libcxxrt
-               cxxabi_incs="${EPREFIX}/usr/include/libcxxrt"
-       else
-               local gcc_inc="${EPREFIX}/usr/lib/gcc/${CHOST}/$(gcc-fullversion)/include/g++-v$(gcc-major-version)"
-               cxxabi=libsupc++
-               cxxabi_incs="${gcc_inc};${gcc_inc}/${CHOST}"
-       fi
-
-       multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
-       # we want -lgcc_s for unwinder, and for compiler runtime when using
-       # gcc, clang with gcc runtime (or any unknown compiler)
-       local extra_libs=() want_gcc_s=ON
-       if use libunwind; then
-               # work-around missing -lunwind upstream
-               extra_libs+=( -lunwind )
-               # if we're using libunwind and clang with compiler-rt, we want
-               # to link to compiler-rt instead of -lgcc_s
-               if tc-is-clang; then
-                       local compiler_rt=$($(tc-getCC) ${CFLAGS} ${CPPFLAGS} \
-                          ${LDFLAGS} -print-libgcc-file-name)
-                       if [[ ${compiler_rt} == *libclang_rt* ]]; then
-                               want_gcc_s=OFF
-                               extra_libs+=( "${compiler_rt}" )
-                       fi
-               fi
-       fi
-
-       # bootstrap: cmake is unhappy if compiler can't link to stdlib
-       local nolib_flags=( -nodefaultlibs -lc )
-       if ! test_compiler; then
-               if test_compiler "${nolib_flags[@]}"; then
-                       local -x LDFLAGS="${LDFLAGS} ${nolib_flags[*]}"
-                       ewarn "${CXX} seems to lack runtime, trying with ${nolib_flags[*]}"
-               fi
-       fi
-
-       local libdir=$(get_libdir)
-       local mycmakeargs=(
-               -DLIBCXX_LIBDIR_SUFFIX=${libdir#lib}
-               -DLIBCXX_ENABLE_SHARED=ON
-               -DLIBCXX_ENABLE_STATIC=$(usex static-libs)
-               -DLIBCXX_CXX_ABI=${cxxabi}
-               -DLIBCXX_CXX_ABI_INCLUDE_PATHS=${cxxabi_incs}
-               # we're using our own mechanism for generating linker scripts
-               -DLIBCXX_ENABLE_ABI_LINKER_SCRIPT=OFF
-               -DLIBCXX_HAS_MUSL_LIBC=$(usex elibc_musl)
-               -DLIBCXX_HAS_GCC_S_LIB=${want_gcc_s}
-               -DLIBCXX_INCLUDE_TESTS=$(usex test)
-               -DCMAKE_SHARED_LINKER_FLAGS="${extra_libs[*]} ${LDFLAGS}"
-       )
-
-       if use test; then
-               local clang_path=$(type -P "${CHOST:+${CHOST}-}clang" 2>/dev/null)
-               local jobs=${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}
-
-               [[ -n ${clang_path} ]] || die "Unable to find ${CHOST}-clang for tests"
-
-               mycmakeargs+=(
-                       -DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-                       -DLLVM_LIT_ARGS="-vv;-j;${jobs};--param=cxx_under_test=${clang_path}"
-               )
-       fi
-       cmake-utils_src_configure
-}
-
-multilib_src_test() {
-       cmake-utils_src_make check-libcxx
-}
-
-# Usage: deps
-gen_ldscript() {
-       local output_format
-       output_format=$($(tc-getCC) ${CFLAGS} ${LDFLAGS} -Wl,--verbose 2>&1 | sed -n 's/^OUTPUT_FORMAT("\([^"]*\)",.*/\1/p')
-       [[ -n ${output_format} ]] && output_format="OUTPUT_FORMAT ( ${output_format} )"
-
-       cat <<-END_LDSCRIPT
-/* GNU ld script
-   Include missing dependencies
-*/
-${output_format}
-GROUP ( $@ )
-END_LDSCRIPT
-}
-
-gen_static_ldscript() {
-       local libdir=$(get_libdir)
-       local cxxabi_lib=$(usex libcxxabi "libc++abi.a" "$(usex libcxxrt "libcxxrt.a" "libsupc++.a")")
-
-       # Move it first.
-       mv "${ED}/usr/${libdir}/libc++.a" "${ED}/usr/${libdir}/libc++_static.a" || die
-       # Generate libc++.a ldscript for inclusion of its dependencies so that
-       # clang++ -stdlib=libc++ -static works out of the box.
-       local deps="libc++_static.a ${cxxabi_lib} $(usex libunwind libunwind.a libgcc_eh.a)"
-       # On Linux/glibc it does not link without libpthread or libdl. It is
-       # fine on FreeBSD.
-       use elibc_glibc && deps+=" libpthread.a libdl.a"
-
-       gen_ldscript "${deps}" > "${ED}/usr/${libdir}/libc++.a" || die
-}
-
-gen_shared_ldscript() {
-       local libdir=$(get_libdir)
-       # libsupc++ doesn't have a shared version
-       local cxxabi_lib=$(usex libcxxabi "libc++abi.so" "$(usex libcxxrt "libcxxrt.so" "libsupc++.a")")
-
-       mv "${ED}/usr/${libdir}/libc++.so" "${ED}/usr/${libdir}/libc++_shared.so" || die
-       local deps="libc++_shared.so ${cxxabi_lib} $(usex libunwind libunwind.so libgcc_s.so)"
-
-       gen_ldscript "${deps}" > "${ED}/usr/${libdir}/libc++.so" || die
-}
-
-multilib_src_install() {
-       cmake-utils_src_install
-       gen_shared_ldscript
-       use static-libs && gen_static_ldscript
-}
-
-pkg_postinst() {
-       elog "This package (${PN}) is mainly intended as a replacement for the C++"
-       elog "standard library when using clang."
-       elog "To use it, instead of libstdc++, use:"
-       elog "    clang++ -stdlib=libc++"
-       elog "to compile your C++ programs."
-}