dev-vcs/stgit: version bump, 0.22
authorYixun Lan <dlan@gentoo.org>
Fri, 29 May 2020 14:25:06 +0000 (22:25 +0800)
committerYixun Lan <dlan@gentoo.org>
Fri, 29 May 2020 14:25:06 +0000 (22:25 +0800)
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: Yixun Lan <dlan@gentoo.org>
dev-vcs/stgit/Manifest
dev-vcs/stgit/stgit-0.22.ebuild [new file with mode: 0644]

index 36c521539290763770a40a29f1bd28d1dc8a0c20..998a87510f4b59a6ab6e8a633abd9759391fece2 100644 (file)
@@ -1,3 +1,4 @@
 DIST stgit-0.19.tar.gz 246256 BLAKE2B ece625a0f78f4a80a9a20b25d0638ee71475029ebd861b28dccc444a70d631e687372031c2dee03faebc8890b8742674d6fd7c2ee1794e8a2d7044721a254847 SHA512 0edad0c600145fc779262ddae4300d4718fd04316face62cb1fb5c01e39cb0824355091863aae8d5b14bee9ebb36ac591e5e0dc9fe343c12a7c781227cac6330
 DIST stgit-0.20.tar.gz 319696 BLAKE2B 85402c84148f5ec93c65be2899240ffa143049de63f734e56438fd17d59ba32cacd279dc3d2eb306ebd11f139f2b4183be814989443401f7d696eba93228a1b7 SHA512 45c4715f7b0c8d8e7f1104694feac7bff07428a6e532ba41bf30807b715990cc1b22a1e82757bb72eb886b987b7c9126d729f9fc161c03497c4d9fa719aae599
 DIST stgit-0.21.tar.gz 319605 BLAKE2B 92bb879d8b8804c8a1b2ca8038d010a0b5118970a4482d87d6bc295992849511c33acb46f376034af6609d42c0323d692bff0ea9bf217cc860e53915fb3c982e SHA512 394c2b30596819f1376bd7432be6923a8dad73f58f049022fe64d1520fd75418665af8069aac98843df051f7fbefbb367762ad4ba57f13bf747819035c7d63ee
+DIST stgit-0.22.tar.gz 308815 BLAKE2B 46c6214012b8d6973273bec716b1ffdafde3ea17930da94de0f73e91e8753fc7ce1d890964c8fac1d32e6343f86e54057b732414fb187b5c9f50e2fa581e6321 SHA512 bfef074b952e01d9041a4ed5dfc6786c29ebb4b09a424ca09e9131ad21c418c4d79ec13eb908f5e8b015ebbc709aacb13824a1c9cad6d97e018a166b014c5e6f
diff --git a/dev-vcs/stgit/stgit-0.22.ebuild b/dev-vcs/stgit/stgit-0.22.ebuild
new file mode 100644 (file)
index 0000000..caede5a
--- /dev/null
@@ -0,0 +1,83 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit bash-completion-r1 distutils-r1
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+UPSTREAM_VER=
+[[ -n ${UPSTREAM_VER} ]] && \
+       UPSTREAM_PATCHSET_URI="https://dev.gentoo.org/~dlan/distfiles/${P}-upstream-patches-${UPSTREAM_VER}.tar.xz"
+
+SRC_URI="https://github.com/ctmarinas/stgit/archive/v${PV}.tar.gz -> ${P}.tar.gz
+       ${UPSTREAM_PATCHSET_URI}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+RDEPEND=">=dev-vcs/git-1.6.3.3"
+
+# NOTE: It seems to be quite important which asciidoc version to use.
+# So keep an eye on it for the future.
+DEPEND="${RDEPEND}
+       doc? (
+               app-text/asciidoc
+               app-text/xmlto
+               dev-lang/perl
+       )"
+
+PATCHES=(
+       "${FILESDIR}/${PN}-0.16-man-linkfix.patch"
+)
+
+pkg_setup() {
+       if ! use doc; then
+               echo
+               ewarn "Manpages will not be built and installed."
+               ewarn "Enable the 'doc' useflag, if you want them."
+               echo
+       fi
+}
+
+python_prepare_all() {
+       # Upstream's patchset
+       [[ -n ${UPSTREAM_VER} ]] && \
+               eapply "${WORKDIR}"/patches-upstream
+
+       # this will be a noop, as we are working with a tarball,
+       # but throws git errors --> just get rid of it
+       echo "version=\"${PV}\"" > "${S}"/stgit/builtin_version.py
+
+       distutils-r1_python_prepare_all
+}
+
+src_compile() {
+       distutils-r1_src_compile
+
+       # bug 526468
+       if use doc; then
+               emake DESTDIR="${D}" \
+                       htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+                       mandir="${EPREFIX}/usr/share/man/" \
+                       doc
+       fi
+}
+
+src_install() {
+       if use doc; then
+               emake DESTDIR="${D}" \
+                       htmldir="${EPREFIX}/usr/share/doc/${PF}/html/" \
+                       mandir="${EPREFIX}/usr/share/man/" \
+                       install-doc install-html
+       fi
+
+       distutils-r1_src_install
+
+       newbashcomp completion/stgit.bash 'stg'
+}