dev-python/simplejson: version bump to 3.14.0
authorTim Harder <radhermit@gentoo.org>
Sun, 29 Apr 2018 04:07:27 +0000 (00:07 -0400)
committerTim Harder <radhermit@gentoo.org>
Sun, 29 Apr 2018 04:07:27 +0000 (00:07 -0400)
dev-python/simplejson/Manifest
dev-python/simplejson/simplejson-3.14.0.ebuild [new file with mode: 0644]

index 40c4c1ff074847ccb941057c99eac41333455978..b896c1b41d6d91eccb2415b7ba11e19321ffa964 100644 (file)
@@ -1,2 +1,3 @@
 DIST simplejson-3.10.0.tar.gz 77953 BLAKE2B 37c23259c7a5be2cb9081feecdd693865dfc98eea90d84c6b4627a081512fc1f66c3a0f5136aaa53be6b5269461c6bf72f62c72368fd68e2c96338f6c9a7f6e6 SHA512 c8782fe434f3f1e29562092fe81f46fc272f0b83fdb3ca31fc03707fe09f4d30696ad7ec07a33de873bd08a41b19f97b9d09e3079658952e5110cf8f68eb53c6
 DIST simplejson-3.13.2.tar.gz 79735 BLAKE2B 5feb87611451054ad8e856e55a4a6bca50470f7f72692de9ce5abddf9eb214e29505124634d4d5a4f825366afe9a97614c66cbe14a73a4e57a5f2f62cac876e8 SHA512 ea29bc615de7fd0eb2a98f5dbeea74ee49b6fed6602396e77baf4480c86f975eff7fd868ac44f62a1c2f3721d4fa5b807b74109e5e28810df70dbad758110f41
+DIST simplejson-3.14.0.tar.gz 80112 BLAKE2B 5866adeba886b4b4f526d4d7fb7ac65f12fa8cfe593a0ac40419c6f04e2f6b776adea49fdee861be54047666b7275bf229db7f7815515a9273878bf0eb68c5f5 SHA512 a81b20a75840566d5985803f35c56ee6957a433f0a9a6fc2f0fb2d46f978925cff0edc2f2c06fe85e7155c8301fbadc962152671c29310c6306f63afede75f98
diff --git a/dev-python/simplejson/simplejson-3.14.0.ebuild b/dev-python/simplejson/simplejson-3.14.0.ebuild
new file mode 100644 (file)
index 0000000..91c2b16
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Simple, fast, extensible JSON encoder/decoder for Python"
+HOMEPAGE="https://github.com/simplejson/simplejson https://pypi.org/project/simplejson/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( MIT AFL-2.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=( README.rst CHANGES.txt )
+
+python_compile() {
+       if ! python_is_python3; then
+               local CFLAGS=${CFLAGS}
+               append-cflags -fno-strict-aliasing
+       fi
+       distutils-r1_python_compile
+}
+
+python_test() {
+       esetup.py test
+}