games-arcade/sable: Stop using games.eclass
authorPacho Ramos <pacho@gentoo.org>
Tue, 24 Apr 2018 17:15:46 +0000 (19:15 +0200)
committerPacho Ramos <pacho@gentoo.org>
Tue, 24 Apr 2018 19:25:52 +0000 (21:25 +0200)
Package-Manager: Portage-2.3.31, Repoman-2.3.9

games-arcade/sable/sable-1.0-r1.ebuild [moved from games-arcade/sable/sable-1.0.ebuild with 64% similarity]

similarity index 64%
rename from games-arcade/sable/sable-1.0.ebuild
rename to games-arcade/sable/sable-1.0-r1.ebuild
index acffef5fd373783d0126852e94b0ad0b990354c7..9ff9a086c60ece6e610ebf3e31f43bcc7779760a 100644 (file)
@@ -1,8 +1,8 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
-inherit eutils games
+EAPI=6
+inherit desktop
 
 DESCRIPTION="A frantic 3D space shooter"
 HOMEPAGE="http://jeuxlibres.net/showgame/sable.html"
@@ -18,26 +18,22 @@ DEPEND="virtual/opengl
        media-libs/libsdl[joystick,opengl,sound,video]
        media-libs/sdl-image[png]
        media-libs/sdl-mixer"
-RDEPEND=${DEPEND}
+RDEPEND="${DEPEND}"
 
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
 
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-gentoo.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
 
 src_compile() {
-       emake INSTALL_RESDIR="${GAMES_DATADIR}"
+       emake INSTALL_RESDIR="/usr/share"
 }
 
 src_install() {
-       dogamesbin ${PN}
-       insinto "${GAMES_DATADIR}"/${PN}
+       dobin ${PN}
+       insinto /usr/share/${PN}
        doins -r models sfx textures
-       dodoc ChangeLog README
+       einstalldocs
 
        doicon "${DISTDIR}"/${PN}.png
        make_desktop_entry ${PN} Sable
-
-       prepgamesdirs
 }