Revert "sys-apps/gawk: restore USE=forced-sandbox"
authorMike Gilbert <floppym@gentoo.org>
Sat, 30 May 2020 03:53:48 +0000 (23:53 -0400)
committerMike Gilbert <floppym@gentoo.org>
Sat, 30 May 2020 03:54:57 +0000 (23:54 -0400)
This reverts commit d19efe2a0c309bde3ceda7e7a9fba3fc9864d124.

Signed-off-by: Mike Gilbert <floppym@gentoo.org>
sys-apps/gawk/gawk-4.2.1-r1.ebuild
sys-apps/gawk/gawk-5.0.1.ebuild
sys-apps/gawk/gawk-5.1.0.ebuild
sys-apps/gawk/metadata.xml

index 6982b29dc59be4e84c65b9a40d21a22bf1e2565a..807061875e314e1cb96fd370f9fb9f92ae726a41 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="forced-sandbox mpfr nls readline"
+IUSE="mpfr nls readline"
 
 RDEPEND="
        dev-libs/gmp:0=
@@ -38,16 +38,6 @@ src_prepare() {
                        -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
                        extension/inplace.c || die
        fi
-
-       if use forced-sandbox ; then
-               # Upstream doesn't want to add a configure flag for this.
-               # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
-               sed -i \
-                       -e '/^int do_flags = false;/s:false:DO_SANDBOX:' \
-                       main.c || die
-               # Make sure the sed took.
-               grep -q '^int do_flags = DO_SANDBOX;' main.c || die "forcing sandbox failed"
-       fi
 }
 
 src_configure() {
@@ -71,14 +61,6 @@ src_install() {
        rm "${ED%/}"/usr/include/awk/config.h || die
 }
 
-src_test() {
-       if use forced-sandbox ; then
-               ewarn "Tests disabled as they don't account for this mode."
-               return
-       fi
-       default
-}
-
 pkg_postinst() {
        # symlink creation here as the links do not belong to gawk, but to any awk
        if has_version app-admin/eselect \
index 42d0a4c552545db673facb6697afe61366eab9ae..b44a5513e78bcee627b413d10cefd74494b9afaa 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="forced-sandbox mpfr nls readline"
+IUSE="mpfr nls readline"
 
 RDEPEND="
        dev-libs/gmp:0=
@@ -40,16 +40,6 @@ src_prepare() {
                        -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
                        extension/inplace.c || die
        fi
-
-       if use forced-sandbox ; then
-               # Upstream doesn't want to add a configure flag for this.
-               # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
-               sed -i \
-                       -e '/^int do_flags = false;/s:false:DO_SANDBOX:' \
-                       main.c || die
-               # Make sure the sed took.
-               grep -q '^int do_flags = DO_SANDBOX;' main.c || die "forcing sandbox failed"
-       fi
 }
 
 src_configure() {
@@ -73,14 +63,6 @@ src_install() {
        rm "${ED}"/usr/include/awk/config.h || die
 }
 
-src_test() {
-       if use forced-sandbox ; then
-               ewarn "Tests disabled as they don't account for this mode."
-               return
-       fi
-       default
-}
-
 pkg_postinst() {
        # symlink creation here as the links do not belong to gawk, but to any awk
        if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
index d0cc5570fb282f26d3236d25116844510a96568f..850ebc1769ed95175b0446d9e983372e5e027fb2 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="mirror://gnu/gawk/${P}.tar.xz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="forced-sandbox mpfr nls readline"
+IUSE="mpfr nls readline"
 
 RDEPEND="
        dev-libs/gmp:0=
@@ -42,16 +42,6 @@ src_prepare() {
                        -e '/\<_XOPEN_SOURCE_EXTENDED\>/s/1//' \
                        extension/inplace.c || die
        fi
-
-       if use forced-sandbox ; then
-               # Upstream doesn't want to add a configure flag for this.
-               # https://lists.gnu.org/archive/html/bug-sed/2018-03/msg00001.html
-               sed -i \
-                       -e '/^int do_flags = false;/s:false:DO_SANDBOX:' \
-                       main.c || die
-               # Make sure the sed took.
-               grep -q '^int do_flags = DO_SANDBOX;' main.c || die "forcing sandbox failed"
-       fi
 }
 
 src_configure() {
@@ -75,14 +65,6 @@ src_install() {
        rm "${ED}"/usr/include/awk/config.h || die
 }
 
-src_test() {
-       if use forced-sandbox ; then
-               ewarn "Tests disabled as they don't account for this mode."
-               return
-       fi
-       default
-}
-
 pkg_postinst() {
        # symlink creation here as the links do not belong to gawk, but to any awk
        if has_version app-admin/eselect && has_version app-eselect/eselect-awk ; then
index 58cec04bdcb0d5e48c6c645be1d634f34e1f592f..3fa1f988999130ca86d52ecf11390d970c7952a5 100644 (file)
@@ -6,7 +6,6 @@
        <name>Gentoo Base System</name>
 </maintainer>
 <use>
-       <flag name="forced-sandbox">Always enable --sandbox mode for simpler/secure runtime (disables e/r/w commands)</flag>
        <flag name="mpfr">use mpfr for high precision arithmetic (-M / --bignum)</flag>
 </use>
 </pkgmetadata>