app-misc/calendar: use insinto/doins instead of cp and clear error.
authorPatrice Clement <monsieurp@gentoo.org>
Sat, 21 Jan 2017 22:11:11 +0000 (23:11 +0100)
committerPatrice Clement <monsieurp@gentoo.org>
Sat, 21 Jan 2017 22:11:28 +0000 (23:11 +0100)
Gentoo-Bug: https://bugs.gentoo.org/606668

Package-Manager: portage-2.3.0

app-misc/calendar/calendar-0.9.1-r1.ebuild

index f320572b6a3d77e88df914e206dd889670d16ca3..f21f5c23c7a83f2969cab4c636bcf211401f7aef 100644 (file)
@@ -22,8 +22,13 @@ src_compile() {
 }
 
 src_install() {
-       cp -R "${S}/calendars" "${D}/usr/share/calendar" || die "cp failed"
        dobin "${PN}"
        doman "${PN}.1"
+
+       insinto "/usr/share"
+       doins -r "${PN}s"
+
+       mv "${D}/usr/share/${PN}s" "${D}/usr/share/${PN}" || die
+
        einstalldocs
 }