app-crypt/veracrypt: remove unused patches
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>
Sat, 2 Nov 2019 10:39:15 +0000 (11:39 +0100)
committerGöktürk Yüksek <gokturk@gentoo.org>
Tue, 5 Nov 2019 00:55:50 +0000 (19:55 -0500)
Closes: https://github.com/gentoo/gentoo/pull/13526
Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com>
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
app-crypt/veracrypt/files/veracrypt-1.19-execstack-fix.patch [deleted file]
app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch [deleted file]
app-crypt/veracrypt/files/veracrypt-1.19-remove-packaging-from-makefile.patch [deleted file]
app-crypt/veracrypt/files/veracrypt-1.22-sysmacros-fix.patch [deleted file]

diff --git a/app-crypt/veracrypt/files/veracrypt-1.19-execstack-fix.patch b/app-crypt/veracrypt/files/veracrypt-1.19-execstack-fix.patch
deleted file mode 100644 (file)
index 9b1e634..0000000
+++ /dev/null
@@ -1,60 +0,0 @@
---- src/Crypto/Aes_hw_cpu.asm.old
-+++ src/Crypto/Aes_hw_cpu.asm
-@@ -328,3 +328,12 @@
-
-
- %endif        ; __BITS__ != 16
-+      %ifidn __OUTPUT_FORMAT__,elf
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf32
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf64
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
---- src/Crypto/AesSmall_x86.asm.old
-+++ src/Crypto/AesSmall_x86.asm
-@@ -1442,3 +1442,12 @@
-     db  v8(0xe1),v8(0x69),v8(0x14),v8(0x63),v8(0x55),v8(0x21),v8(0x0c),v8(0x7d)
-
- %endif
-+      %ifidn __OUTPUT_FORMAT__,elf
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf32
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf64
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
---- src/Crypto/Aes_x64.asm.old
-+++ src/Crypto/Aes_x64.asm
-@@ -905,3 +905,12 @@
- %endif
-
- %endif
-+      %ifidn __OUTPUT_FORMAT__,elf
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf32
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf64
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
---- src/Crypto/Aes_x86.asm.old
-+++ src/Crypto/Aes_x86.asm
-@@ -644,3 +644,12 @@
-     do_exit
-
- %endif
-+      %ifidn __OUTPUT_FORMAT__,elf
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf32
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
-+      %ifidn __OUTPUT_FORMAT__,elf64
-+      section .note.GNU-stack noalloc noexec nowrite progbits
-+      %endif
diff --git a/app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch b/app-crypt/veracrypt/files/veracrypt-1.19-makefile-archdetect.patch
deleted file mode 100644 (file)
index 41fc6d5..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-From 181857089b11045c701e9195275a408430beb580 Mon Sep 17 00:00:00 2001
-From: Mounir IDRASSI <mounir.idrassi@idrix.fr>
-Date: Sat, 5 Nov 2016 23:39:46 +0100
-Subject: [PATCH] Linux: Always use "uname -m" to determine processor type.
- This fixes Slackware build issue.
-
----
- src/Makefile | 5 +----
- 1 file changed, 1 insertion(+), 4 deletions(-)
-
-diff --git a/src/Makefile b/src/Makefile
-index 7bfc5ad..00e6e5b 100644
---- src/Makefile
-+++ src/Makefile
-@@ -131,10 +131,7 @@ export PLATFORM_UNSUPPORTED := 0
- export CPU_ARCH ?= unknown
- export SIMD_SUPPORTED := 0
--ARCH = $(shell uname -p)
--ifeq "$(ARCH)" "unknown"
--      ARCH = $(shell uname -m)
--endif
-+ARCH = $(shell uname -m)
- ifneq (,$(filter i386 i486 i586 i686 x86,$(ARCH)))
-       CPU_ARCH = x86
diff --git a/app-crypt/veracrypt/files/veracrypt-1.19-remove-packaging-from-makefile.patch b/app-crypt/veracrypt/files/veracrypt-1.19-remove-packaging-from-makefile.patch
deleted file mode 100644 (file)
index 5aad4b9..0000000
+++ /dev/null
@@ -1,52 +0,0 @@
---- src/Main/Main.make.orig
-+++ src/Main/Main.make
-@@ -190,49 +190,6 @@
-       rm -fr "$(PWD)/Setup/MacOSX/VeraCrypt_dmg"
- endif
-
--
--
--ifeq "$(PLATFORM)" "Linux"
--ifeq "$(TC_BUILD_CONFIG)" "Release"
--      mkdir -p $(PWD)/Setup/Linux/usr/bin
--      mkdir -p $(PWD)/Setup/Linux/usr/share/$(APPNAME)/doc
--      cp $(PWD)/Main/$(APPNAME) $(PWD)/Setup/Linux/usr/bin/$(APPNAME)
--      cp $(PWD)/Setup/Linux/$(APPNAME)-uninstall.sh $(PWD)/Setup/Linux/usr/bin/$(APPNAME)-uninstall.sh
--      chmod +x $(PWD)/Setup/Linux/usr/bin/$(APPNAME)-uninstall.sh
--      cp $(PWD)/License.txt $(PWD)/Setup/Linux/usr/share/$(APPNAME)/doc/License.txt
--      cp "$(PWD)/Release/Setup Files/VeraCrypt User Guide.pdf" "$(PWD)/Setup/Linux/usr/share/$(APPNAME)/doc/VeraCrypt User Guide.pdf"
--
--ifndef TC_NO_GUI
--      mkdir -p $(PWD)/Setup/Linux/usr/share/applications
--      mkdir -p $(PWD)/Setup/Linux/usr/share/pixmaps
--      cp $(PWD)/Resources/Icons/VeraCrypt-256x256.xpm $(PWD)/Setup/Linux/usr/share/pixmaps/$(APPNAME).xpm
--      cp $(PWD)/Setup/Linux/$(APPNAME).desktop $(PWD)/Setup/Linux/usr/share/applications/$(APPNAME).desktop
--endif
--
--
--      tar cfz $(PWD)/Setup/Linux/$(PACKAGE_NAME) --directory $(PWD)/Setup/Linux usr
--
--      @rm -fr $(INTERNAL_INSTALLER_NAME)
--      @echo "#!/bin/sh" > $(INTERNAL_INSTALLER_NAME)
--      @echo "VERSION=$(TC_VERSION)" >> $(INTERNAL_INSTALLER_NAME)
--      @echo "PACKAGE_TYPE=tar" >> $(INTERNAL_INSTALLER_NAME)
--      @echo "PACKAGE_NAME=$(PACKAGE_NAME)" >> $(INTERNAL_INSTALLER_NAME)
--      @echo "PACKAGE_START=1107" >> $(INTERNAL_INSTALLER_NAME)
--      @echo "INSTALLER_TYPE=$(INSTALLER_TYPE)" >> $(INTERNAL_INSTALLER_NAME)
--
--      @cat $(PWD)/Setup/Linux/veracrypt_install_template.sh >> $(INTERNAL_INSTALLER_NAME)
--      @cat $(PWD)/Setup/Linux/$(PACKAGE_NAME) >> $(INTERNAL_INSTALLER_NAME)
--      chmod +x $(INTERNAL_INSTALLER_NAME)
--
--      rm -fr $(PWD)/Setup/Linux/packaging
--      mkdir -p $(PWD)/Setup/Linux/packaging
--      cp $(INTERNAL_INSTALLER_NAME) $(PWD)/Setup/Linux/packaging/.
--      makeself $(PWD)/Setup/Linux/packaging $(PWD)/Setup/Linux/$(INSTALLER_NAME) "VeraCrypt $(TC_VERSION) Installer" ./$(INTERNAL_INSTALLER_NAME)
--
--endif
--
--endif
--
- $(OBJS): $(PCH)
-
- Resources.o: $(RESOURCES)
diff --git a/app-crypt/veracrypt/files/veracrypt-1.22-sysmacros-fix.patch b/app-crypt/veracrypt/files/veracrypt-1.22-sysmacros-fix.patch
deleted file mode 100644 (file)
index 702e8f7..0000000
+++ /dev/null
@@ -1,36 +0,0 @@
-From 0a50becec3a3cca71e575dfec35d69ab295c85cc Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?G=C3=B6kt=C3=BCrk=20Y=C3=BCksek?= <gokturk@gentoo.org>
-Date: Tue, 3 Apr 2018 23:06:20 -0400
-Subject: [PATCH] Platform/Unix: include <sys/sysmacros.h> for major/minor
- macros
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Starting with glibc 2.26, macros "major" and "minor" are only
-available from <sys/sysmacros.h> [0]. The build fails with the
-following without including this header:
-
-Unix/FilesystemPath.cpp:84:49: error: ‘major’ was not declared in this scope
-Unix/FilesystemPath.cpp:84:113: error: ‘minor’ was not declared in this scope
-
-[0] https://sourceware.org/ml/libc-alpha/2017-02/msg00079.html
----
- src/Platform/Unix/FilesystemPath.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/Platform/Unix/FilesystemPath.cpp b/src/Platform/Unix/FilesystemPath.cpp
-index d6c9cd2..7c28af4 100644
---- a/Platform/Unix/FilesystemPath.cpp
-+++ b/Platform/Unix/FilesystemPath.cpp
-@@ -15,6 +15,7 @@
- #include "Platform/StringConverter.h"
- #include <stdio.h>
- #include <sys/stat.h>
-+#include <sys/sysmacros.h>
- namespace VeraCrypt
- {
--- 
-2.16.3
-