games-puzzle/world-of-goo-gog: Fix bad usex usage on x86
authorJames Le Cuirot <chewi@gentoo.org>
Thu, 30 Apr 2020 23:35:23 +0000 (00:35 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Thu, 30 Apr 2020 23:38:17 +0000 (00:38 +0100)
Closes: https://bugs.gentoo.org/720186
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
games-puzzle/world-of-goo-gog/world-of-goo-gog-1.51.29337.ebuild

index 186582c1e154a074b94257f31384969e763b4684..28a6b68bfeca9f7544e2bd0228dced20f0448ec3 100644 (file)
@@ -47,12 +47,12 @@ src_unpack() {
 
 src_install() {
        exeinto "${dir}"
-       newexe data/noarch/game/${MY_PN}.bin.x86$(usex amd64 _64) ${MY_PN}.bin
+       newexe data/noarch/game/${MY_PN}.bin.x86$(usex amd64 _64 "") ${MY_PN}.bin
        dosym "../..${dir}"/${MY_PN}.bin /usr/bin/${PN%-*}
 
        insinto "${dir}"
        doins -r data/noarch/game/game/
-       use bundled-libs && doins -r data/noarch/game/lib$(usex amd64 64)/
+       use bundled-libs && doins -r data/noarch/game/lib$(usex amd64 64 "")/
 
        newicon -s 256 data/noarch/game/game/gooicon.png ${PN%-*}.png
        make_desktop_entry ${PN%-*} "World of Goo" ${PN%-*}