app-emulation/docker-compose: Remove old
authorSebastian Pipping <sping@gentoo.org>
Sun, 7 Jul 2019 14:21:43 +0000 (16:21 +0200)
committerSebastian Pipping <sping@gentoo.org>
Sun, 7 Jul 2019 14:22:47 +0000 (16:22 +0200)
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.67, Repoman-2.3.12

app-emulation/docker-compose/Manifest
app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild [deleted file]
app-emulation/docker-compose/docker-compose-1.23.2.ebuild [deleted file]
app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch [deleted file]

index ffe2528f81e150023d63668c3c5c9193c4566f1d..677fb229edc3cec96fb45fb9af34754e0588b9cb 100644 (file)
@@ -1,3 +1,2 @@
-DIST docker-compose-1.23.2.tar.gz 302950 BLAKE2B b96db2e718bd6b05f6a35829749570320209def17b7536e402b9991b56e05a2d8da97fbd8d79d8125d9df6ff361a181fbfd71346a33a68704db0327a92757f66 SHA512 baa233c84ac770798ba3d8d256687630b331d774a8d60f3c0d5046aa0a74c8c3b8b0b8bc4431f3bc7d5b7a54f0646f5e2fd14d5af31db37cb546e86c96c8c1db
 DIST docker-compose-1.24.0.tar.gz 307601 BLAKE2B cb2a6f96e14c04d0279b25c075182d8f09e5a622e4cee2ce74995224e3a8634cc5f22ccc548b7754bbeb11630c1e638386cb1a6df927b3619cb6e7e3595aac6c SHA512 318c6bf9877147de09526b4d49c3fd86012d85626e7a9a15863ca55a60e10fa85b27429605045d0aaa993dddd3bc2e5f23cbb76856276a874e84793b878a3e86
 DIST docker-compose-1.24.1.tar.gz 307749 BLAKE2B 7ded0a4b82a7a9beb9de38752f38998ca4ea9421e5ed5630627820ec7e250ad6f03f6788bcbebe8bc0dd4c064d275bb4ca5a6055a95b6a0f72d7ae9038ec7f22 SHA512 9b8632ef263b8dfa678e8b99b46e00441f779716a524280ce25f62fcd2605f400723b7790c466338374c34653946dc2c5d7f09593ddd892fee3409c2a2fd1a5f
diff --git a/app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild b/app-emulation/docker-compose/docker-compose-1.23.2-r1.ebuild
deleted file mode 100644 (file)
index 15e7493..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 2018-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Multi-container orchestration for Docker"
-HOMEPAGE="https://github.com/docker/compose"
-SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
-       >=dev-python/docker-py-3.6.0[${PYTHON_USEDEP}]
-       >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
-       >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
-       >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
-       >=dev-python/PySocks-1.6.0[${PYTHON_USEDEP}]
-       >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
-       >=dev-python/requests-2.18.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
-       >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
-
-DEPEND="${RDEPEND}
-       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
-
-S="${WORKDIR}/compose-${PV}"
-
-PATCHES=(
-       # Bug #679968 -- https://bugs.gentoo.org/679968
-       # Bug #681002 -- https://bugs.gentoo.org/681002
-       "${FILESDIR}"/${PN}-1.23.2-setup-py.patch
-)
-
-src_prepare() {
-       # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
-       sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
-
-       default
-}
-
-python_test() {
-       distutils_install_for_testing
-       ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       newbashcomp contrib/completion/bash/docker-compose ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       doins contrib/completion/zsh/*
-
-       distutils-r1_python_install_all
-}
diff --git a/app-emulation/docker-compose/docker-compose-1.23.2.ebuild b/app-emulation/docker-compose/docker-compose-1.23.2.ebuild
deleted file mode 100644 (file)
index c9a313c..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 2018-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit bash-completion-r1 distutils-r1
-
-DESCRIPTION="Multi-container orchestration for Docker"
-HOMEPAGE="https://github.com/docker/compose"
-SRC_URI="https://github.com/docker/compose/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       >=dev-python/cached-property-1.2.0[${PYTHON_USEDEP}]
-       <dev-python/cached-property-2
-       >=dev-python/docker-py-3.6.0[${PYTHON_USEDEP}]
-       <dev-python/docker-py-4.0
-       >=dev-python/dockerpty-0.4.1[${PYTHON_USEDEP}]
-       <dev-python/dockerpty-0.5
-       >=dev-python/docopt-0.6.1[${PYTHON_USEDEP}]
-       <dev-python/docopt-0.7
-       >=dev-python/jsonschema-2.5.1[${PYTHON_USEDEP}]
-       <dev-python/jsonschema-3
-       >=dev-python/PySocks-1.5.6[${PYTHON_USEDEP}]
-       <dev-python/PySocks-2
-       >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-4
-       >=dev-python/requests-2.6.1[${PYTHON_USEDEP}]
-       >=dev-python/six-1.3.0[${PYTHON_USEDEP}]
-       <dev-python/six-2
-       >=dev-python/texttable-0.9.0[${PYTHON_USEDEP}]
-       <dev-python/texttable-0.10
-       >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
-       <dev-python/websocket-client-1.0
-       $(python_gen_cond_dep '>=dev-python/enum34-1.0.4[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
-       $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )"
-
-DEPEND="${RDEPEND}
-       test? ( <dev-python/pytest-4[${PYTHON_USEDEP}]
-       <dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep '>=dev-python/mock-1.0.1[${PYTHON_USEDEP}]' 'python2_7' ) )"
-
-S="${WORKDIR}/compose-${PV}"
-
-src_prepare() {
-       # Address QA issue "docker-compose.exe: missing alias (symlink) for completed command."
-       sed 's,^\(complete.*\) docker-compose\.exe\(.*\),\1\2,' -i contrib/completion/bash/docker-compose || die
-
-       # Get rid of requests boundary
-       sed -i -e  "/^.*requests/s/, <.*/',/" setup.py || die
-
-       default
-
-}
-
-python_test() {
-       distutils_install_for_testing
-       ${PYTHON} -m pytest tests/unit/ || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
-       newbashcomp contrib/completion/bash/docker-compose ${PN}
-
-       insinto /usr/share/zsh/site-functions
-       doins contrib/completion/zsh/*
-
-       distutils-r1_python_install_all
-}
diff --git a/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch b/app-emulation/docker-compose/files/docker-compose-1.23.2-setup-py.patch
deleted file mode 100644 (file)
index 193ece1..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-From 15b1ac5bfeb0ca2a8524dae10db7573b4efacba9 Mon Sep 17 00:00:00 2001
-From: Sebastian Pipping <sebastian@pipping.org>
-Date: Fri, 10 May 2019 23:54:14 +0200
-Subject: [PATCH] setup.py: Drop generic upper version boundaries
-
----
- setup.py | 26 +++++++++++++-------------
- 1 file changed, 13 insertions(+), 13 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 22dafdb..00167ce 100644
---- a/setup.py
-+++ b/setup.py
-@@ -30,16 +30,16 @@ def find_version(*file_paths):
- install_requires = [
--    'cached-property >= 1.2.0, < 2',
--    'docopt >= 0.6.1, < 0.7',
--    'PyYAML >= 3.10, < 4',
--    'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0, < 2.21',
--    'texttable >= 0.9.0, < 0.10',
--    'websocket-client >= 0.32.0, < 1.0',
--    'docker >= 3.6.0, < 4.0',
--    'dockerpty >= 0.4.1, < 0.5',
--    'six >= 1.3.0, < 2',
--    'jsonschema >= 2.5.1, < 3',
-+    'cached-property >= 1.2.0',
-+    'docopt >= 0.6.1',
-+    'PyYAML >= 3.10',
-+    'requests >= 2.6.1, != 2.11.0, != 2.12.2, != 2.18.0',
-+    'texttable >= 0.9.0',
-+    'websocket-client >= 0.32.0',
-+    'docker >= 3.6.0',
-+    'dockerpty >= 0.4.1',
-+    'six >= 1.3.0',
-+    'jsonschema >= 2.5.1',
- ]
-@@ -52,11 +52,11 @@ if sys.version_info[:2] < (3, 4):
-     tests_require.append('mock >= 1.0.1')
- extras_require = {
--    ':python_version < "3.4"': ['enum34 >= 1.0.4, < 2'],
-+    ':python_version < "3.4"': ['enum34 >= 1.0.4'],
-     ':python_version < "3.5"': ['backports.ssl_match_hostname >= 3.5'],
-     ':python_version < "3.3"': ['ipaddress >= 1.0.16'],
--    ':sys_platform == "win32"': ['colorama >= 0.4, < 0.5'],
--    'socks': ['PySocks >= 1.5.6, != 1.5.7, < 2'],
-+    ':sys_platform == "win32"': ['colorama >= 0.4'],
-+    'socks': ['PySocks >= 1.5.6, != 1.5.7'],
- }
--- 
-2.21.0
-