app-admin/durep: drop last-rited pkg
authorAaron Bauman <bman@gentoo.org>
Sun, 8 Dec 2019 19:05:08 +0000 (14:05 -0500)
committerAaron Bauman <bman@gentoo.org>
Sun, 8 Dec 2019 19:19:18 +0000 (14:19 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
app-admin/durep/Manifest [deleted file]
app-admin/durep/durep-0.9-r4.ebuild [deleted file]
app-admin/durep/files/durep-0.9-dirhandle.patch [deleted file]
app-admin/durep/files/durep-0.9-gigabyte.patch [deleted file]
app-admin/durep/files/durep-0.9-r4-color-output.patch [deleted file]
app-admin/durep/metadata.xml [deleted file]
profiles/package.mask

diff --git a/app-admin/durep/Manifest b/app-admin/durep/Manifest
deleted file mode 100644 (file)
index 4c00caa..0000000
+++ /dev/null
@@ -1 +0,0 @@
-DIST durep-0.9.tar.gz 13713 BLAKE2B ac8cab90eeec1f9dcf1c5f6ba3043ee1de909cc288f3d1692d272b77c426932cb8b9c500fc7901c85a8eeeef3db4632b76c1ff5cf8a094c971867a3557052322 SHA512 a8a58cf4a77fa43e06eb22ce70e566fe9c5dd6921677dbe4691a6dd95e2fad3735778a9858e3b80957ba6efd20293fcd2ba4ddc9cfe29f5813997de0f9c96b6d
diff --git a/app-admin/durep/durep-0.9-r4.ebuild b/app-admin/durep/durep-0.9-r4.ebuild
deleted file mode 100644 (file)
index 8a1b40e..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-inherit eutils
-
-DESCRIPTION="A perl script designed for monitoring disk usage in a more visual way than du"
-HOMEPAGE="https://gentoo.org"
-SRC_URI="http://www.hibernaculum.net/download/${P}.tar.gz"
-
-LICENSE="Artistic"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="dev-lang/perl"
-RDEPEND="${DEPEND}
-       dev-perl/MLDBM
-       virtual/perl-Getopt-Long
-       virtual/perl-Term-ANSIColor"
-
-src_prepare() {
-       epatch "${FILESDIR}"/${P}-gigabyte.patch \
-               "${FILESDIR}"/${PF}-color-output.patch \
-               "${FILESDIR}"/${P}-dirhandle.patch
-}
-
-src_install() {
-       dobin durep
-       doman durep.1
-       dodoc BUGS CHANGES README THANKS
-       dohtml -A cgi *.cgi *.css *.png
-}
diff --git a/app-admin/durep/files/durep-0.9-dirhandle.patch b/app-admin/durep/files/durep-0.9-dirhandle.patch
deleted file mode 100644 (file)
index ee29306..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- durep       2007-09-08 11:44:05.000000000 -0500
-+++ durep.new   2008-12-15 10:04:14.907825184 -0600
-@@ -175,6 +175,7 @@
-   my $coalesced_size = 0;
-   my $node = {};
-   my $temp;
-+  my $dirhandle;
-
-   $node->{ID} = $next_id++;
-   if(defined $parent) {
-@@ -196,9 +197,9 @@
-
-   $node->{TYPE} &= $TYPE_COLLAPSED unless $store;
-
--  opendir(DIR, $dir) or warn "Unable to open dir '$dir': $!\n" and return $node;
-+  opendir($dirhandle, $dir) or warn "Unable to open dir '$dir': $!\n" and return $node;
-
--  foreach(readdir(DIR)) {
-+  foreach(readdir($dirhandle)) {
-     @stats = lstat "$dir/$_" or warn "Unable to lstat '$dir/$_': $!\n" and next;
-
-     $node->{MTIME} = $stats[9] if($_ eq ".");
-@@ -247,7 +248,7 @@
-     $file_count++;
-     $node->{FCOUNT}++;
-   }
--  closedir(DIR);
-+  closedir($dirhandle);
-
-   if($coalesced_count) {
-     if($store) {
diff --git a/app-admin/durep/files/durep-0.9-gigabyte.patch b/app-admin/durep/files/durep-0.9-gigabyte.patch
deleted file mode 100644 (file)
index 315cb1c..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-fix `durep -hs 1g` output
-
-Patch by Stephen Tallowitz
-
-http://bugs.gentoo.org/108942
-
---- durep
-+++ durep
-@@ -468,7 +468,7 @@
-     elsif ($temp =~ m/^[mM]/) {
-       return $size * 1048576;
-     }
--    elsif ($temp =~ m/^[mM]/) {
-+    elsif ($temp =~ m/^[gG]/) {
-       return $size * 1048576 * 1024;
-     }
-     return $size;
diff --git a/app-admin/durep/files/durep-0.9-r4-color-output.patch b/app-admin/durep/files/durep-0.9-r4-color-output.patch
deleted file mode 100644 (file)
index 6b89561..0000000
+++ /dev/null
@@ -1,98 +0,0 @@
---- durep
-+++ durep
-@@ -14,6 +14,8 @@
- #############################################################################
- use Getopt::Long;
-+use feature 'switch';
-+use Term::ANSIColor qw(:constants);
- use File::Basename;
- use MLDBM qw(DB_File Storable);
- use Fcntl;
-@@ -27,6 +29,7 @@
- our ($root_node, $filesystem_id, @stats);
- our ($opt_help, $opt_version, $opt_textdepth, $opt_hidesize, $opt_showdate, $opt_nosort, $opt_quiet);
- our ($opt_savefile, $opt_loadfile, $opt_desc, $opt_collate);
-+our ($opt_nocolor);
- our ($opt_files, $opt_onefilesystem, $opt_collapsepath, $opt_excludepath, $opt_coalescefiles);
- our ($root_dir, $file_count, $dir_count, $next_id);
- our ($TYPE_FILE, $TYPE_DIR, $TYPE_EMPTY, $TYPE_COALESCED, $TYPE_COLLAPSED);
-@@ -56,6 +59,8 @@
-           "d|desc=s"            => \$opt_desc,
-           "c|collate=s"         => \$opt_collate,
-+          "nc|nocolor"          => \$opt_nocolor,
-+
-           "f|files"             => \$opt_files,
-           "x|one-file-system"   => \$opt_onefilesystem,
-           "cp|collapse-path=s"  => \$opt_collapsepath,
-@@ -332,13 +337,58 @@
-     printf(" [%s%s] ", "#" x $numofchars, " " x (30-$numofchars));
-     printf("%6.2f%% ", $percent);
-     printf("%s ", shortDate($entry->{MTIME})) if $opt_showdate;
--    printf("%s%s\n", $entry->{NAME}, $entry->{TYPE} & $TYPE_DIR ? "/" : "");
-+   
-+    printColor( $entry ) unless ( $opt_nocolor );
-+    printNoColor( $entry ) if ( $opt_nocolor );
-     if($entry->{TYPE} & $TYPE_DIR) {
-       printDir($entry, $indent+1) if(!defined $opt_textdepth || ($opt_textdepth > $indent+1));
-     }
-   }
- }
-+sub printColor {
-+    my $entry = shift;
-+    
-+    my @tmp = split /\./, $entry->{NAME};
-+    
-+    if ( $entry->{TYPE} & $TYPE_DIR ) {
-+        print BLUE, BOLD, $entry->{NAME}."/\n", RESET
-+    }
-+    else {
-+        given ($tmp[$#tmp]) {
-+            #executable (bright green)
-+            when([ qw(cmd exe com btm bat sh csh) ]) {
-+                print BOLD, GREEN, $entry->{NAME}."\n", RESET
-+            }
-+            #archives / compressed (bright red)
-+            when([ qw(tar tgz arj taz lzh zip z Z gz bz2 tbz2 tz deb rpm rar ace zoo cpio 7z rz) ]) {
-+                print BOLD, RED, $entry->{NAME}."\n", RESET 
-+            }
-+            #image formats
-+            when([ qw(jpg jpeg gif bmp ppm tga xbm xpm tif tiff png mng xcf pcx mpg mpeg m2v avi mkv
-+                    ogm mp4 mp4v mov qt wmv asf rm rmvb flc fli gl dl) ]) {
-+                print BOLD, MAGENTA, $entry->{NAME}."\n", RESET
-+            }
-+            #misc.
-+            when([ qw(pdf ps txt patch diff log tex doc) ]) {
-+                print GREEN, $entry->{NAME}."\n", RESET
-+            }
-+            when([ qw(mp3 wav mid midi au ogg flac aac) ]) {
-+                print CYAN, $entry->{NAME}."\n", RESET
-+            }
-+            default {
-+                print $entry->{NAME}."\n", RESET
-+            }
-+        }
-+    }
-+}
-+
-+sub printNoColor {
-+    my $entry = shift;
-+
-+    printf("%s%s\n", $entry->{NAME}, $entry->{TYPE} & $TYPE_DIR ? "/" : "");
-+}
-+
- sub processSizeOption {
-   my ($size, $temp);
-@@ -438,6 +488,9 @@
-    -d, --desc=<description>     give description of save file
-    -c, --collate=<dir>          collate save files in dir for web report
-+Color Option:
-+  -nc, --nocolor              no color output
-+                              By default durep color outpu
- Inclusion Options:
-    -f, --files                  do not descend into subdirs, only report files
-    -x, --one-file-system        do not traverse file systems
diff --git a/app-admin/durep/metadata.xml b/app-admin/durep/metadata.xml
deleted file mode 100644 (file)
index a1d1cac..0000000
+++ /dev/null
@@ -1,6 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-       <!-- maintainer-needed -->
-       <longdescription>A perl script designed for monitoring disk usage. Similar to du</longdescription>
-</pkgmetadata>
index 5474c16fc6f8c6754cc22a792e97e21626b7845a..57fa7880968d36627a834b1bdfc0e56dd1c0cdac 100644 (file)
@@ -562,11 +562,6 @@ media-video/emovix
 # what does it even do? EAPI=4  Removal in 30 days
 app-backup/furball
 
-# Aaron Bauman <bman@gentoo.org> (2019-11-09)
-# maintainer-need, upstream website is dead
-# EAPI=4. Removal in 30 days
-app-admin/durep
-
 # Michał Górny <mgorny@gentoo.org> (2019-10-20)
 # Testing version that breaks multiple plugins.  Let's keep it masked
 # until upstream releases fixed versions.