dev-vcs/svn2git: Fix compilation
authorSebastian Pipping <sping@gentoo.org>
Wed, 17 Apr 2019 21:57:51 +0000 (23:57 +0200)
committerSebastian Pipping <sping@gentoo.org>
Wed, 17 Apr 2019 21:58:29 +0000 (23:58 +0200)
Closes: https://bugs.gentoo.org/682802
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Package-Manager: Portage-2.3.62, Repoman-2.3.12

dev-vcs/svn2git/files/svn2git-1.0.13-src-pro.patch [new file with mode: 0644]
dev-vcs/svn2git/svn2git-1.0.13-r1.ebuild [new file with mode: 0644]

diff --git a/dev-vcs/svn2git/files/svn2git-1.0.13-src-pro.patch b/dev-vcs/svn2git/files/svn2git-1.0.13-src-pro.patch
new file mode 100644 (file)
index 0000000..74ee430
--- /dev/null
@@ -0,0 +1,23 @@
+From 59a038796e6bb55b11b6d82f7d5aae42399da38a Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Bj=C3=B6rn=20Kautler?= <Bjoern@Kautler.net>
+Date: Fri, 12 Apr 2019 01:39:51 +0200
+Subject: [PATCH] Fix evaluation of emptyness of SVN_LIBDIR that sometimes
+ always gives false, sometime always true, but never what is intended
+
+---
+ src/src.pro | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/src.pro b/src/src.pro
+index 426d304..cfbd865 100644
+--- a/src/src.pro
++++ b/src/src.pro
+@@ -28,7 +28,7 @@ DEPENDPATH += .
+ QT = core
+ INCLUDEPATH += . $$SVN_INCLUDE $$APR_INCLUDE
+-!isEmpty($$SVN_LIBDIR): LIBS += -L$$SVN_LIBDIR
++!isEmpty(SVN_LIBDIR): LIBS += -L$$SVN_LIBDIR
+ LIBS += -lsvn_fs-1 -lsvn_repos-1 -lapr-1 -lsvn_subr-1
+ # Input
diff --git a/dev-vcs/svn2git/svn2git-1.0.13-r1.ebuild b/dev-vcs/svn2git/svn2git-1.0.13-r1.ebuild
new file mode 100644 (file)
index 0000000..dc22eca
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop qmake-utils
+[[ "${PV}" == "9999" ]] && inherit git-r3
+
+DESCRIPTION="Tool for one-time conversion from svn to git"
+HOMEPAGE="https://github.com/svn-all-fast-export/svn2git"
+if [[ "${PV}" == "9999" ]]; then
+       EGIT_REPO_URI="https://github.com/svn-all-fast-export/svn2git.git"
+else
+       SRC_URI="https://github.com/svn-all-fast-export/svn2git/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+# KEYWORDS way up
+
+DEPEND="
+       dev-qt/qtcore:5
+       dev-vcs/subversion"
+RDEPEND="${DEPEND}
+       dev-vcs/git"
+
+DOCS=( README.md )
+
+PATCHES=(
+       "${FILESDIR}"/${P}-src-pro.patch
+)
+
+src_configure() {
+       local qmake_args=(
+               APR_INCLUDE=/usr/include/apr-1
+               PREFIX=/usr
+               SVN_INCLUDE=/usr/include/subversion-1
+               VERSION=${PV}
+       )
+       eqmake5 "${qmake_args[@]}" fast-export2.pro
+}
+
+src_install() {
+       einstalldocs
+       insinto /usr/share/${PN}/samples
+       doins samples/*.rules || die 'doins failed'
+       dobin svn-all-fast-export || die 'dobin failed'
+       dosym svn-all-fast-export /usr/bin/svn2git || die 'dosym failed'
+}