dev-ros/rqt_gui_py: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:09:35 +0000 (12:09 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 10:12:08 +0000 (12:12 +0200)
Package-Manager: portage-2.2.21

dev-ros/rqt_gui_py/Manifest [new file with mode: 0644]
dev-ros/rqt_gui_py/metadata.xml [new file with mode: 0644]
dev-ros/rqt_gui_py/rqt_gui_py-0.2.14.ebuild [new file with mode: 0644]
dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/rqt_gui_py/Manifest b/dev-ros/rqt_gui_py/Manifest
new file mode 100644 (file)
index 0000000..4bd724f
--- /dev/null
@@ -0,0 +1 @@
+DIST rqt-0.2.14.tar.gz 96624 SHA256 0b80921c0a1f0811ede8afe16b5479f44c3cb085b23d6e81560a4b7874f565af SHA512 852933ae34ecd996c979de5d8431fb9e7c15f43570fdc6b82336098ab2859670407cb8f2319665bfbfaa815221c6e8a1698fe12349d2092fd98f632c4a0d92f5 WHIRLPOOL 56c2e3b24b10bcaee19523c32f6f63581290a20dbce6112e2327578dd5ecebf3f78e40274d12c5a253005c91f63889c6fb40b011c2e49c7ba2f4b2851dc23e42
diff --git a/dev-ros/rqt_gui_py/metadata.xml b/dev-ros/rqt_gui_py/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.2.14.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.2.14.ebuild
new file mode 100644 (file)
index 0000000..4c1e30c
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/qt_gui[${PYTHON_USEDEP}]
+       dev-ros/rqt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
new file mode 100644 (file)
index 0000000..4c1e30c
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-ros/rospy[${PYTHON_USEDEP}]
+       dev-ros/qt_gui[${PYTHON_USEDEP}]
+       dev-ros/rqt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"