net-firewall/ipt_netflow: Check for CONFIG_VLAN_8021Q
authorJeroen Roovers <jer@gentoo.org>
Thu, 20 Jun 2019 07:08:17 +0000 (09:08 +0200)
committerJeroen Roovers <jer@gentoo.org>
Thu, 20 Jun 2019 07:10:03 +0000 (09:10 +0200)
Package-Manager: Portage-2.3.67, Repoman-2.3.14
Fixes: https://bugs.gentoo.org/688362
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-firewall/ipt_netflow/ipt_netflow-2.3_p20190619.ebuild
net-firewall/ipt_netflow/ipt_netflow-9999.ebuild

index 3a1ad78c15f5214e67154ce3f76d6e854c332f7d..5f49f78b07dfd4130d3b44a5b8a1301225b78c15 100644 (file)
@@ -34,7 +34,7 @@ pkg_setup() {
        BUILD_TARGETS="all"
        MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
        IPT_LIB="/usr/$(get_libdir)/xtables"
-       local CONFIG_CHECK="~IP_NF_IPTABLES"
+       local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
        use debug && CONFIG_CHECK+=" ~DEBUG_FS"
        use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
        linux-mod_pkg_setup
@@ -50,7 +50,7 @@ src_prepare() {
        default
 
        # Fix incorrect module version in sources
-       sed -i -e "/IPT_NETFLOW_VERSION/s/2.2/${PV}/" ipt_NETFLOW.c || die
+       sed -i -e "/IPT_NETFLOW_VERSION/s/2.3/${PV}/" ipt_NETFLOW.c || die
 
        # Checking for directory is enough
        sed -i -e 's:-s /etc/snmp/snmpd.conf:-d /etc/snmp:' configure || die
index 2a4bba4304bce7bebca15590c2d6a68122fa3b39..71ba1b74afbf5e28f2d538a3234a31ff06959ed5 100644 (file)
@@ -34,7 +34,7 @@ pkg_setup() {
        BUILD_TARGETS="all"
        MODULE_NAMES="ipt_NETFLOW(ipt_netflow:${S})"
        IPT_LIB="/usr/$(get_libdir)/xtables"
-       local CONFIG_CHECK="~IP_NF_IPTABLES"
+       local CONFIG_CHECK="~IP_NF_IPTABLES VLAN_8021Q"
        use debug && CONFIG_CHECK+=" ~DEBUG_FS"
        use natevents && CONFIG_CHECK+=" NF_CONNTRACK_EVENTS NF_NAT_NEEDED"
        linux-mod_pkg_setup